summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json12
-rw-r--r--php-laminas-mvc-plugin-flashmessenger.spec39
2 files changed, 25 insertions, 26 deletions
diff --git a/composer.json b/composer.json
index 49939d2..3fd186d 100644
--- a/composer.json
+++ b/composer.json
@@ -19,26 +19,22 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "1.2.x-dev",
- "dev-develop": "1.3.x-dev"
- },
"laminas": {
"component": "Laminas\\Mvc\\Plugin\\FlashMessenger"
}
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-mvc": "^3.0",
"laminas/laminas-session": "^2.8.5",
"laminas/laminas-stdlib": "^3.2.1",
- "laminas/laminas-view": "^2.10",
+ "laminas/laminas-view": "^2.12",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-i18n": "^2.8",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+ "phpunit/phpunit": "^9.3"
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0"
@@ -64,7 +60,7 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-mvc-plugin-flashmessenger": "self.version"
+ "zendframework/zend-mvc-plugin-flashmessenger": "^1.2.0"
},
"suggests": {
"laminas/laminas-i18n": "Laminas\\I18n component"
diff --git a/php-laminas-mvc-plugin-flashmessenger.spec b/php-laminas-mvc-plugin-flashmessenger.spec
index 1d68513..fa6e11d 100644
--- a/php-laminas-mvc-plugin-flashmessenger.spec
+++ b/php-laminas-mvc-plugin-flashmessenger.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f5a522c3aab215a9b89a0630beb91582f4a3f202
+%global gh_commit f7569d05dfd774a2c84328792ee716e2d8b1e33e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-flashmessenger
@@ -24,8 +24,8 @@
%endif
Name: php-%{gh_project}
-Version: 1.2.0
-Release: 5%{?dist}
+Version: 1.3.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
License: BSD
@@ -33,24 +33,22 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: %{name}-php8.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.10 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.12 with php-autoloader(%{gh_owner}/laminas-view) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-i18n": "^2.8",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
+# "phpunit/phpunit": "^9.3"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.8 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
# remirepo:8
%else
@@ -61,26 +59,26 @@ BuildRequires: php-laminas-view
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-i18n
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-mvc": "^3.0",
# "laminas/laminas-session": "^2.8.5",
# "laminas/laminas-stdlib": "^3.2.1",
-# "laminas/laminas-view": "^2.10",
+# "laminas/laminas-view": "^2.12",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.10 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.12 with php-autoloader(%{gh_owner}/laminas-view) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggests": {
# "laminas/laminas-i18n": "Laminas\\I18n component"
@@ -99,8 +97,8 @@ Requires: php-composer(fedora/autoloader)
Requires: php-spl
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 1.2.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 1.2.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -121,7 +119,6 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -181,7 +178,7 @@ ret=0
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -203,6 +200,12 @@ exit $ret
%changelog
+* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+- raise dependency on PHP 7.3
+- raise dependency on laminas-view 2.12
+- switch to phpunit9
+
* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 1.2.0-5
- add patch for PHP 8 from
https://github.com/laminas/laminas-mvc-plugin-flashmessenger/pull/11