summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-01 10:17:17 +0100
committerRemi Collet <remi@php.net>2021-12-01 10:17:17 +0100
commitd5cc7d310809a216057d8d9eccdee87b5286c1be (patch)
treeffcab1480eedcbbdf2d0d89cd039f12dc1915d71
parent194712b68ca056721fd976faa07572b6b25868f5 (diff)
update to 1.4.0
-rw-r--r--composer.json2
-rw-r--r--php-laminas-mvc-plugin-flashmessenger.spec11
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 3fd186d..69bae94 100644
--- a/composer.json
+++ b/composer.json
@@ -24,7 +24,7 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"laminas/laminas-mvc": "^3.0",
"laminas/laminas-session": "^2.8.5",
"laminas/laminas-stdlib": "^3.2.1",
diff --git a/php-laminas-mvc-plugin-flashmessenger.spec b/php-laminas-mvc-plugin-flashmessenger.spec
index fa6e11d..2d4427a 100644
--- a/php-laminas-mvc-plugin-flashmessenger.spec
+++ b/php-laminas-mvc-plugin-flashmessenger.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f7569d05dfd774a2c84328792ee716e2d8b1e33e
+%global gh_commit d683b79132990b48fc720259337ecd353cba4c43
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-flashmessenger
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.3.0
+Version: 1.4.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -66,7 +66,7 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-mvc": "^3.0",
# "laminas/laminas-session": "^2.8.5",
# "laminas/laminas-stdlib": "^3.2.1",
@@ -175,7 +175,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -200,6 +200,9 @@ exit $ret
%changelog
+* Wed Dec 1 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+
* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
- update to 1.3.0
- raise dependency on PHP 7.3