summaryrefslogtreecommitdiffstats
path: root/php-laminas-mvc-plugin-fileprg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-mvc-plugin-fileprg.spec')
-rw-r--r--php-laminas-mvc-plugin-fileprg.spec38
1 files changed, 22 insertions, 16 deletions
diff --git a/php-laminas-mvc-plugin-fileprg.spec b/php-laminas-mvc-plugin-fileprg.spec
index 8abf329..2a57589 100644
--- a/php-laminas-mvc-plugin-fileprg.spec
+++ b/php-laminas-mvc-plugin-fileprg.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-mvc-plugin-fileprg
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4a1a3729b3789a4d9e7cfe285ce84a636be87a67
+%global gh_commit 2d6a64bf916b3f5f26a062b9c62d06af26ee483f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-plugin-fileprg
@@ -24,7 +24,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.1.0
+Version: 1.2.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj}/%{subsubp} component
@@ -36,11 +36,11 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-reflection
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
@@ -48,7 +48,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-form) >= 2.7
BuildRequires: (php-autoloader(%{gh_owner}/laminas-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-inputfilter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:10
@@ -62,23 +62,23 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-filter": "^2.6.1",
# "laminas/laminas-form": "^2.7",
# "laminas/laminas-inputfilter": "^2.8.1",
# "laminas/laminas-mvc": "^3.0",
# "laminas/laminas-session": "^2.8.5",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-stdlib": "^3.3",
# "laminas/laminas-validator": "^2.6",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
@@ -86,7 +86,7 @@ Requires: (php-autoloader(%{gh_owner}/laminas-form) >= 2.7
Requires: (php-autoloader(%{gh_owner}/laminas-inputfilter) >= 2.8.1 with php-autoloader(%{gh_owner}/laminas-inputfilter) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-session) >= 2.8.5 with php-autoloader(%{gh_owner}/laminas-session) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# remirepo:10
@@ -106,8 +106,8 @@ Requires: php-composer(fedora/autoloader)
Requires: php-reflection
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 1.1.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 1.1.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -183,10 +183,10 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\%{subsubp}\\Module") ? 0 : 1
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
exit $ret
@@ -208,6 +208,12 @@ exit $ret
%changelog
+* Wed Apr 14 2021 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+- raise dependency on PHP 7.3
+- raise dependency on aminas-stdlib 3.3
+- switch to phpunit9
+
* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 1.1.0-1
- switch to Laminas