summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-15 11:39:10 +0100
committerRemi Collet <remi@remirepo.net>2020-12-15 11:39:10 +0100
commit2168cb1b14d6824253594f232c0552a8ddf497e9 (patch)
tree4b0a113630f50189237b9243cc1619e49e7523ac
new package - WIP - not readyHEADmaster
-rw-r--r--Makefile3
-rw-r--r--composer.json68
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-laminas-mvc-middleware.spec190
4 files changed, 289 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2117eea
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,68 @@
+{
+ "name": "laminas/laminas-mvc-middleware",
+ "description": "Dispatch middleware pipelines in place of controllers in laminas-mvc.",
+ "license": "BSD-3-Clause",
+ "keywords": [
+ "laminas",
+ "components",
+ "middleware",
+ "mvc",
+ "psr-7",
+ "psr-15"
+ ],
+ "homepage": "https://laminas.dev",
+ "support": {
+ "docs": "https://docs.laminas.dev/laminas-mvc-middleware/",
+ "issues": "https://github.com/laminas/laminas-mvc-middleware/issues",
+ "source": "https://github.com/laminas/laminas-mvc-middleware",
+ "rss": "https://github.com/laminas/laminas-mvc-middleware/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Mvc\\Middleware"
+ }
+ },
+ "require": {
+ "php": "^5.6 || ^7.0",
+ "http-interop/http-middleware": "^0.4.1",
+ "laminas/laminas-mvc": "^3.1",
+ "laminas/laminas-psr7bridge": "^1.2.2",
+ "laminas/laminas-servicemanager": "^3.3",
+ "laminas/laminas-stratigility": "^2.2.2p2"
+ },
+ "require-dev": {
+ "container-interop/container-interop": "^1.2",
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-diactoros": "^1.8 || ^2.1",
+ "laminas/laminas-router": "^3.3",
+ "phpunit/phpunit": "^7.5.20 || ^6.4.4 || ^5.7.14"
+ },
+ "autoload": {
+ "psr-4": {
+ "Laminas\\Mvc\\Middleware\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "LaminasTest\\Mvc\\Middleware\\": "test/"
+ }
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-laminas-mvc-middleware.spec b/php-laminas-mvc-middleware.spec
new file mode 100644
index 0000000..4480ebe
--- /dev/null
+++ b/php-laminas-mvc-middleware.spec
@@ -0,0 +1,190 @@
+# remirepo/Fedora spec file for php-laminas-mvc-middleware
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit f2d31a99dea5f564e5a4135c9e469d5800a92540
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner laminas
+%global gh_project laminas-mvc-middleware
+%global php_home %{_datadir}/php
+%global namespace Laminas
+%global library Mvc
+%global subproj Middleware
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+######## TODO : not compatible with http-interop/http-middleware 0.5
+
+Name: php-%{gh_project}
+Version: 1.1.0
+Release: 1%{?dist}
+Summary: %{namespace} Framework %{library}/%{subproj} component
+
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(http-interop/http-middleware) >= 0.4.1 with php-composer(http-interop/http-middleware) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.1 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-psr7bridge) >= 1.2.2 with php-autoloader(%{gh_owner}/laminas-psr7bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stratigility) >= 2.2 with php-autoloader(%{gh_owner}/laminas-stratigility) < 3)
+# From composer, "require-dev": {
+# "container-interop/container-interop": "^1.2",
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-diactoros": "^1.8 || ^2.1",
+# "laminas/laminas-router": "^3.3",
+# "phpunit/phpunit": "^7.5.20 || ^6.4.4 || ^5.7.14"
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-diactoros) >= 1.8 with php-autoloader(%{gh_owner}/laminas-diactoros) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.3 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+# remirepo:14
+%else
+BuildRequires: php-http-interop-http-middleware
+BuildRequires: php-laminas-mvc
+BuildRequires: php-laminas-psr7bridge
+BuildRequires: php-laminas-servicemanager
+BuildRequires: php-laminas-stratigility
+BuildRequires: php-container-interop
+BuildRequires: php-laminas-diactoros
+BuildRequires: php-laminas-router
+%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.5.20
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "http-interop/http-middleware": "^0.4.1",
+# "laminas/laminas-mvc": "^3.1",
+# "laminas/laminas-psr7bridge": "^1.2.2",
+# "laminas/laminas-servicemanager": "^3.3",
+# "laminas/laminas-stratigility": "^2.2.2p2"
+Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(http-interop/http-middleware) >= 0.4.1 with php-composer(http-interop/http-middleware) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.1 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-psr7bridge) >= 1.2.2 with php-autoloader(%{gh_owner}/laminas-psr7bridge) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stratigility) >= 2.2.2 with php-autoloader(%{gh_owner}/laminas-stratigility) < 3)
+# remirepo:7
+%else
+Requires: php-http-interop-http-middleware
+Requires: php-laminas-mvc
+Requires: php-laminas-psr7bridge
+Requires: php-laminas-servicemanager
+Requires: php-laminas-stratigility
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 1.1.0
+# only core and standard
+
+# Compatibily ensure by the bridge
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+%{gh_project} provides integration between:
+
+* laminas-console
+* laminas-mvc
+* laminas-router
+* laminas-view
+
+and replaces the console functionality found in the v2 releases of the latter
+three components.
+
+Documentation: https://docs.laminas.dev/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Interop/Http/Middleware/autoload.php',
+ '%{php_home}/%{namespace}/Mvc/autoload.php',
+ '%{php_home}/%{namespace}/Psr7Bridge/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Stratigility/autoload.php',
+]);
+EOF
+
+
+%install
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/%{library}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Interop/Container/autoload.php',
+ [
+ '%{php_home}/%{namespace}/Diactoros2/autoload.php',
+ '%{php_home}/%{namespace}/Diactoros/autoload.php',
+ ],
+ '%{php_home}/%{namespace}/Router/autoload.php',
+]);
+EOF
+
+
+: upstream test suite
+ret=0
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/%{namespace}/%{library}/%{subproj}
+
+
+%changelog
+* Tue Dec 15 2020 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- initial package
+