summaryrefslogtreecommitdiffstats
path: root/php-laminas-mvc-i18n.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-15 14:07:43 +0100
committerRemi Collet <remi@remirepo.net>2020-01-15 14:07:43 +0100
commit14d5156b3cfe8faa2f2a2f70e81d6259cf0a8241 (patch)
tree3337511a83f9aa5877aefa95b8754be246eeeea4 /php-laminas-mvc-i18n.spec
duplicate ZF
Diffstat (limited to 'php-laminas-mvc-i18n.spec')
-rw-r--r--php-laminas-mvc-i18n.spec222
1 files changed, 222 insertions, 0 deletions
diff --git a/php-laminas-mvc-i18n.spec b/php-laminas-mvc-i18n.spec
new file mode 100644
index 0000000..4fff3e0
--- /dev/null
+++ b/php-laminas-mvc-i18n.spec
@@ -0,0 +1,222 @@
+# remirepo/Fedora spec file for php-zendframework-zend-mvc-i18n
+#
+# Copyright (c) 2016-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 7a1b3aca3a8874adb32390d34794cdc525c1c909
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-mvc-i18n
+%global php_home %{_datadir}/php
+%global library I18n
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.1.1
+Release: 1%{?dist}
+Summary: Zend Framework Mvc-%{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-intl
+BuildRequires: php-spl
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
+# "zendframework/zend-cache": "^2.6.1",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.7 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-cache) < 3)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.5
+# remirepo:18
+%else
+BuildRequires: php-composer(container-interop/container-interop) < 2
+BuildRequires: php-composer(container-interop/container-interop) >= 1.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-router) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+BuildRequires: php-autoloader(%{gh_owner}/zend-cache) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "container-interop/container-interop": "^1.1",
+# "zendframework/zend-i18n": "^2.7",
+# "zendframework/zend-router": "^3.0",
+# "zendframework/zend-servicemanager": "^2.7.10 || ^3.0.3",
+# "zendframework/zend-stdlib": "^2.7.6 || ^3.0",
+# "zendframework/zend-validator": "^2.6"
+Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.7 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:14
+%else
+Requires: php-composer(container-interop/container-interop) < 2
+Requires: php-composer(container-interop/container-interop) >= 1.1
+Requires: php-autoloader(%{gh_owner}/zend-i18n) < 3
+Requires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-router) < 4
+Requires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
+Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
+Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 1.0.0
+Requires: php-intl
+Requires: php-spl
+%if ! %{bootstrap}
+# From composer, "suggest": {
+# "zendframework/zend-cache": "To enable caching of translation strings"
+Suggests: php-autoloader(%{gh_owner}/zend-cache)
+%endif
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+zend-mvc-i18n provides integration between:
+
+* zend-i18n
+* zend-mvc
+* zend-router
+
+and replaces the i18n functionality found in the v2 releases of the latter
+two components.
+
+* File issues at https://github.com/zendframework/zend-mvc-i18n/issues
+* Documentation is at https://zendframework.github.io/zend-mvc-i18n/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create dependency autoloader - deprecated
+cat << 'EOF' | tee autoload.php
+<?php
+require_once '%{php_home}/Interop/Container/autoload.php';
+EOF
+
+
+: Create autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Interop/Container/autoload.php',
+ '%{php_home}/Zend/I18n/autoload.php',
+ '%{php_home}/Zend/Router/autoload.php',
+ '%{php_home}/Zend/ServiceManager/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/Zend/Validator/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/Cache/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/Mvc
+cp -pr src %{buildroot}%{php_home}/Zend/Mvc/%{library}
+
+install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-%{library}-autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/Mvc/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/Mvc/%{library}
+%{php_home}/Zend/Mvc-%{library}-autoload.php
+
+
+%changelog
+* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1 (no change)
+
+* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+- raise dependency on zend-servicemanager 2.7.10
+
+* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 1.1.10-4
+- switch from zend-loader to fedora/autoloader
+
+* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 1.1.10-1
+- initial package
+