summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-24 13:55:33 +0200
committerRemi Collet <remi@php.net>2022-10-24 13:55:33 +0200
commit2d4116a261c852a159af253418625c62f23aed54 (patch)
tree181d41cef90447eab5a53d0382ea8d51dd6c0105
parent14838fc2d01dd872f3389f1e6f2081bcf5602a2d (diff)
update to 1.6.0
raise dependency on PHP 8.0
-rw-r--r--composer.json8
-rw-r--r--php-laminas-mvc-i18n.spec21
2 files changed, 17 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 18dced0..4fca816 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
"config": {
"sort-packages": true,
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
@@ -32,7 +32,7 @@
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"ext-intl": "*",
"container-interop/container-interop": "^1.1",
"laminas/laminas-i18n": "^2.13.0",
@@ -42,11 +42,11 @@
"laminas/laminas-validator": "^2.19.0"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.3.0",
+ "laminas/laminas-coding-standard": "~2.4.0",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.5",
"psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.24.0"
+ "vimeo/psalm": "^4.29.0"
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0",
diff --git a/php-laminas-mvc-i18n.spec b/php-laminas-mvc-i18n.spec
index 5f088e7..b3fe974 100644
--- a/php-laminas-mvc-i18n.spec
+++ b/php-laminas-mvc-i18n.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 6dc949c045d7a2c27652a3bb891d46ef5e1814e4
+%global gh_commit b073da7b27ec8a8e8cf6df770cd58c1ba38af096
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-i18n
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.4.0
+Version: 1.6.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
@@ -35,7 +35,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-intl
BuildRequires: php-spl
# remirepo:1
@@ -47,11 +47,11 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.10
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.19.0 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.2 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
+# "laminas/laminas-coding-standard": "~2.4.0",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.5",
# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.24.0"
+# "vimeo/psalm": "^4.29.0"
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
# remirepo:9
%else
@@ -70,14 +70,14 @@ BuildRequires: phpunit9 >= 9.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "container-interop/container-interop": "^1.1",
# "laminas/laminas-i18n": "^2.13.0",
# "laminas/laminas-router": "^3.5.0",
# "laminas/laminas-servicemanager": "^3.15.1",
# "laminas/laminas-stdlib": "^3.10.1",
# "laminas/laminas-validator": "^2.19.0"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.13 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
@@ -189,7 +189,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Translator") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -214,8 +214,13 @@ exit $ret
%changelog
+* Mon Oct 24 2022 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- raise dependency on PHP 8.0
+
* Fri Jul 22 2022 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0
+- raise dependency on PHP 7.4
- raise dependency on laminas-i18n 2.13.0
- raise dependency on laminas-router 3.5.0
- raise dependency on laminas-servicemanager 3.15.1