summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-15 14:22:04 +0100
committerRemi Collet <remi@remirepo.net>2020-01-15 14:22:04 +0100
commit216e4b57d04dcd04ba68e2bf63998c10cf7ae2bd (patch)
tree59677a5f291fef5b552c8956bde02d4c51d53d42
parent14d5156b3cfe8faa2f2a2f70e81d6259cf0a8241 (diff)
switch to Laminas
-rw-r--r--composer.json76
-rw-r--r--php-laminas-mvc-i18n.spec205
2 files changed, 149 insertions, 132 deletions
diff --git a/composer.json b/composer.json
index d6a31d9..6d0f8e3 100644
--- a/composer.json
+++ b/composer.json
@@ -1,63 +1,64 @@
{
- "name": "zendframework/zend-mvc-i18n",
- "description": "Integration between zend-mvc and zend-i18n",
+ "name": "laminas/laminas-mvc-i18n",
+ "description": "Integration between laminas-mvc and laminas-i18n",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"mvc",
"i18n"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-mvc-i18n/",
- "issues": "https://github.com/zendframework/zend-mvc-i18n/issues",
- "source": "https://github.com/zendframework/zend-mvc-i18n",
- "rss": "https://github.com/zendframework/zend-mvc-i18n/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-mvc-i18n/",
+ "issues": "https://github.com/laminas/laminas-mvc-i18n/issues",
+ "source": "https://github.com/laminas/laminas-mvc-i18n",
+ "rss": "https://github.com/laminas/laminas-mvc-i18n/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1.x-dev",
+ "dev-develop": "1.2.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Mvc\\I18n",
+ "config-provider": "Laminas\\Mvc\\I18n\\ConfigProvider"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
"container-interop/container-interop": "^1.1",
- "zendframework/zend-i18n": "^2.7",
- "zendframework/zend-router": "^3.0",
- "zendframework/zend-servicemanager": "^2.7.10 || ^3.0.3",
- "zendframework/zend-stdlib": "^2.7.6 || ^3.0",
- "zendframework/zend-validator": "^2.6"
+ "laminas/laminas-i18n": "^2.7",
+ "laminas/laminas-router": "^3.0",
+ "laminas/laminas-servicemanager": "^2.7.10 || ^3.0.3",
+ "laminas/laminas-stdlib": "^2.7.6 || ^3.0",
+ "laminas/laminas-validator": "^2.6",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
- "zendframework/zend-cache": "^2.6.1",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "laminas/laminas-cache": "^2.6.1",
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
},
"conflict": {
- "phpspec/prophecy": "<1.8.0",
- "zendframework/zend-mvc": "<3.0.0"
+ "laminas/laminas-mvc": "<3.0.0",
+ "phpspec/prophecy": "<1.8.0"
},
"suggest": {
- "zendframework/zend-cache": "To enable caching of translation strings"
+ "laminas/laminas-cache": "To enable caching of translation strings"
},
"autoload": {
"psr-4": {
- "Zend\\Mvc\\I18n\\": "src/"
+ "Laminas\\Mvc\\I18n\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Mvc\\I18n\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "1.1.x-dev",
- "dev-develop": "1.2.x-dev"
- },
- "zf": {
- "component": "Zend\\Mvc\\I18n",
- "config-provider": "Zend\\Mvc\\I18n\\ConfigProvider"
+ "LaminasTest\\Mvc\\I18n\\": "test/"
}
},
"scripts": {
@@ -69,5 +70,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-mvc-i18n": "self.version"
}
}
diff --git a/php-laminas-mvc-i18n.spec b/php-laminas-mvc-i18n.spec
index 4fff3e0..73a6e6e 100644
--- a/php-laminas-mvc-i18n.spec
+++ b/php-laminas-mvc-i18n.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-mvc-i18n
+# remirepo/Fedora spec file for php-laminas-mvc-i18n
#
# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
@@ -7,25 +7,28 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7a1b3aca3a8874adb32390d34794cdc525c1c909
+%global gh_commit 4184f6572b5244a5f5781604f1e03d7955e304a0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-mvc-i18n
+%global gh_owner laminas
+%global gh_project laminas-mvc-i18n
+%global zf_name zend-mvc-i18n
%global php_home %{_datadir}/php
-%global library I18n
+%global namespace Laminas
+%global library Mvc
+%global subproj I18n
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 1.1.1
Release: 1%{?dist}
-Summary: Zend Framework Mvc-%{library} component
+Summary: %{namespace} Framework %{library}/%{subproj} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -35,40 +38,33 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-intl
BuildRequires: php-spl
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
-# "zendframework/zend-cache": "^2.6.1",
-# "zendframework/zend-coding-standard": "~1.0.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.7 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-cache) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.5
-# remirepo:18
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.7 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "require-dev": {
+# "laminas/laminas-cache": "^2.6.1",
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
+# remirepo:10
%else
-BuildRequires: php-composer(container-interop/container-interop) < 2
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-router) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-cache) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.6.1
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-container-interop
+BuildRequires: php-laminas-i18n
+BuildRequires: php-laminas-router
+BuildRequires: php-laminas-servicemanager
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-validator
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-cache
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -76,62 +72,62 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "container-interop/container-interop": "^1.1",
-# "zendframework/zend-i18n": "^2.7",
-# "zendframework/zend-router": "^3.0",
-# "zendframework/zend-servicemanager": "^2.7.10 || ^3.0.3",
-# "zendframework/zend-stdlib": "^2.7.6 || ^3.0",
-# "zendframework/zend-validator": "^2.6"
+# "laminas/laminas-i18n": "^2.7",
+# "laminas/laminas-router": "^3.0",
+# "laminas/laminas-servicemanager": "^2.7.10 || ^3.0.3",
+# "laminas/laminas-stdlib": "^2.7.6 || ^3.0",
+# "laminas/laminas-validator": "^2.6",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/zend-i18n) >= 2.7 with php-autoloader(%{gh_owner}/zend-i18n) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.6 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-# remirepo:14
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-i18n) >= 2.7 with php-autoloader(%{gh_owner}/laminas-i18n) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "suggest": {
+# "laminas/laminas-cache": "To enable caching of translation strings"
+Suggests: php-autoloader(%{gh_owner}/laminas-cache)
+
+# remirepo:9
%else
-Requires: php-composer(container-interop/container-interop) < 2
-Requires: php-composer(container-interop/container-interop) >= 1.1
-Requires: php-autoloader(%{gh_owner}/zend-i18n) < 3
-Requires: php-autoloader(%{gh_owner}/zend-i18n) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-router) < 4
-Requires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.6
-Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
-Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.6
+Requires: php-container-interop
+Requires: php-laminas-i18n
+Requires: php-laminas-router
+Requires: php-laminas-servicemanager
+Requires: php-laminas-stdlib
+Requires: php-laminas-validator
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 1.0.0
+# From phpcompatinfo report for version 1.1.1
Requires: php-intl
Requires: php-spl
-%if ! %{bootstrap}
-# From composer, "suggest": {
-# "zendframework/zend-cache": "To enable caching of translation strings"
-Suggests: php-autoloader(%{gh_owner}/zend-cache)
-%endif
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 1.1.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-zend-mvc-i18n provides integration between:
+%{gh_project} provides integration between:
-* zend-i18n
-* zend-mvc
-* zend-router
+* laminas-i18n
+* laminas-mvc
+* laminas-router
and replaces the i18n functionality found in the v2 releases of the latter
two components.
-* File issues at https://github.com/zendframework/zend-mvc-i18n/issues
-* Documentation is at https://zendframework.github.io/zend-mvc-i18n/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -141,35 +137,40 @@ mv LICENSE.md LICENSE
%build
-: Create dependency autoloader - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-require_once '%{php_home}/Interop/Container/autoload.php';
-EOF
-
-
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Interop/Container/autoload.php',
- '%{php_home}/Zend/I18n/autoload.php',
- '%{php_home}/Zend/Router/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/%{namespace}/I18n/autoload.php',
+ '%{php_home}/%{namespace}/Router/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Cache/autoload.php',
+ '%{php_home}/%{namespace}/Cache/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(dirname(__DIR__))) . '/%{namespace}/%{library}/%{subproj}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/Mvc
-cp -pr src %{buildroot}%{php_home}/Zend/Mvc/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/%{library}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}
-install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-%{library}-autoload.php
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}/%{subproj}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/%{subproj}/autoload.php
%check
@@ -177,12 +178,19 @@ install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-%{library}-autoload.
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/Mvc/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/%{subproj}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Translator") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -200,11 +208,16 @@ exit $ret
%license LICENSE
%doc *.md
%doc composer.json
-%{php_home}/Zend/Mvc/%{library}
-%{php_home}/Zend/Mvc-%{library}-autoload.php
+%dir %{php_home}/Zend/%{library}
+ %{php_home}/Zend/%{library}/%{subproj}
+%dir %{php_home}/%{namespace}/%{library}
+ %{php_home}/%{namespace}/%{library}/%{subproj}
%changelog
+* Wed Jan 15 2020 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- switch to Laminas
+
* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 1.1.1-1
- update to 1.1.1 (no change)