summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-25 15:44:34 +0100
committerRemi Collet <remi@php.net>2022-02-25 15:44:34 +0100
commit1c77bec93636bf8ea8d71976b8dd5da07455e747 (patch)
tree80e24a6c456caa3a325fa3a23748e238e4fc837d
parentb03d7694ec09b19384e557bdd0df4c5356fa4f10 (diff)
update to 1.3.1 (no change)
-rw-r--r--composer.json16
-rw-r--r--php-laminas-mvc-i18n.spec25
2 files changed, 24 insertions, 17 deletions
diff --git a/composer.json b/composer.json
index ca20738..61f8dfc 100644
--- a/composer.json
+++ b/composer.json
@@ -17,7 +17,10 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.3.99"
+ }
},
"extra": {
"laminas": {
@@ -26,14 +29,13 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"container-interop/container-interop": "^1.1",
"laminas/laminas-i18n": "^2.11",
"laminas/laminas-router": "^3.0",
"laminas/laminas-servicemanager": "^3.6",
"laminas/laminas-stdlib": "^3.3",
- "laminas/laminas-validator": "^2.14",
- "laminas/laminas-zendframework-bridge": "^1.2"
+ "laminas/laminas-validator": "^2.14"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -44,7 +46,8 @@
},
"conflict": {
"laminas/laminas-mvc": "<3.0.0",
- "phpspec/prophecy": "<1.8.0"
+ "phpspec/prophecy": "<1.8.0",
+ "zendframework/zend-mvc-i18n": "*"
},
"suggest": {
"laminas/laminas-cache": "To enable caching of translation strings"
@@ -70,8 +73,5 @@
"static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
- },
- "replace": {
- "zendframework/zend-mvc-i18n": "^1.1.1"
}
}
diff --git a/php-laminas-mvc-i18n.spec b/php-laminas-mvc-i18n.spec
index 245b075..b0832b7 100644
--- a/php-laminas-mvc-i18n.spec
+++ b/php-laminas-mvc-i18n.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-mvc-i18n
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7ece491a02000a6c4ea2c4457fead3d12efc6eba
+%global gh_commit 3f6c81d839507dee8bbf74a09a9bfc65ecd3bb88
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mvc-i18n
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.2.0
+Version: 1.3.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library}/%{subproj} component
@@ -71,14 +71,13 @@ BuildRequires: phpunit9 >= 9.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "container-interop/container-interop": "^1.1",
# "laminas/laminas-i18n": "^2.11",
# "laminas/laminas-router": "^3.0",
# "laminas/laminas-servicemanager": "^3.6",
# "laminas/laminas-stdlib": "^3.3",
-# "laminas/laminas-validator": "^2.14",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-validator": "^2.14"
Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -110,8 +109,8 @@ Requires: php-intl
Requires: php-spl
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 1.1.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 1.2.0
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -194,7 +193,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Translator") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -219,6 +218,14 @@ exit $ret
%changelog
+* Fri Feb 25 2022 Remi Collet <remi@remirepo.net> - 1.3.1-1
+- update to 1.3.1 (no change)
+
+* Wed Dec 1 2021 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Tue Apr 6 2021 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0 (no change)
- raise dependency on PHP 7.3