summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-16 11:02:56 +0100
committerRemi Collet <remi@remirepo.net>2020-01-16 11:02:56 +0100
commitd14ea92a6e555889cb0b68114e266d88afd1b834 (patch)
tree8c5f1870650a081d06a15cbf723771d595be6989
parentad5e70720360e795b0b40fc5ffb3b16e77012eb6 (diff)
switch to Laminas
-rw-r--r--composer.json80
-rw-r--r--php-laminas-mvc-console.spec261
2 files changed, 174 insertions, 167 deletions
diff --git a/composer.json b/composer.json
index 185b968..acfa743 100644
--- a/composer.json
+++ b/composer.json
@@ -1,65 +1,66 @@
{
- "name": "zendframework/zend-mvc-console",
- "description": "Integration between zend-mvc and zend-console",
+ "name": "laminas/laminas-mvc-console",
+ "description": "Integration between laminas-mvc and laminas-console",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"mvc",
"console"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-mvc-console/",
- "issues": "https://github.com/zendframework/zend-mvc-console/issues",
- "source": "https://github.com/zendframework/zend-mvc-console",
- "rss": "https://github.com/zendframework/zend-mvc-console/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-mvc-console/",
+ "issues": "https://github.com/laminas/laminas-mvc-console/issues",
+ "source": "https://github.com/laminas/laminas-mvc-console",
+ "rss": "https://github.com/laminas/laminas-mvc-console/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.2.x-dev",
+ "dev-develop": "1.3.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Mvc\\Console"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
"container-interop/container-interop": "^1.1",
- "zendframework/zend-console": "^2.6",
- "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
- "zendframework/zend-modulemanager": "^2.7.1",
- "zendframework/zend-mvc": "^3.0.3",
- "zendframework/zend-router": "^3.0",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-stdlib": "^2.7.5 || ^3.0",
- "zendframework/zend-text": "^2.6",
- "zendframework/zend-view": "^2.6.3"
+ "laminas/laminas-console": "^2.6",
+ "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+ "laminas/laminas-modulemanager": "^2.7.1",
+ "laminas/laminas-mvc": "^3.0.3",
+ "laminas/laminas-router": "^3.0",
+ "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "laminas/laminas-stdlib": "^2.7.5 || ^3.0",
+ "laminas/laminas-text": "^2.6",
+ "laminas/laminas-view": "^2.6.3",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-filter": "^2.6.1"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-filter": "^2.6.1",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
},
"conflict": {
- "zendframework/zend-mvc": "<3.0.0"
+ "laminas/laminas-mvc": "<3.0.0"
},
"suggest": {
- "zendframework/zend-filter": "^2.6.1, to filter rendered results"
+ "laminas/laminas-filter": "^2.6.1, to filter rendered results"
},
"autoload": {
"psr-4": {
- "Zend\\Mvc\\Console\\": "src/"
+ "Laminas\\Mvc\\Console\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Mvc\\Console\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "1.2.x-dev",
- "dev-develop": "1.3.x-dev"
- },
- "zf": {
- "component": "Zend\\Mvc\\Console"
+ "LaminasTest\\Mvc\\Console\\": "test/"
}
},
"scripts": {
@@ -71,5 +72,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-mvc-console": "self.version"
}
}
diff --git a/php-laminas-mvc-console.spec b/php-laminas-mvc-console.spec
index f11d009..99f644c 100644
--- a/php-laminas-mvc-console.spec
+++ b/php-laminas-mvc-console.spec
@@ -1,31 +1,34 @@
-# remirepo/Fedora spec file for php-zendframework-zend-mvc-console
+# remirepo/Fedora spec file for php-laminas-mvc-console
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 821c18e0d57e71b370166bd2f35623befddaf2ee
+%global gh_commit 0c16223557fdb9bba853f6de22e1040824c1c966
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-mvc-console
+%global gh_owner laminas
+%global gh_project laminas-mvc-console
+%global zf_name zend-mvc-console
%global php_home %{_datadir}/php
-%global library Console
+%global namespace Laminas
+%global library Mvc
+%global subproj Console
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 1.2.0
Release: 1%{?dist}
-Summary: Zend Framework Mvc-%{library} component
+Summary: %{namespace} Framework %{library}/%{subproj} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -35,52 +38,40 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
# From composer, "require-dev": {
-# "squizlabs/php_codesniffer": "^2.3.1",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-filter": "^2.6.1"
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-filter": "^2.6.1",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-console) >= 2.6 with php-autoloader(%{gh_owner}/zend-console) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-modulemanager) >= 2.7.1 with php-autoloader(%{gh_owner}/zend-modulemanager) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0.3 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-text) >= 2.6 with php-autoloader(%{gh_owner}/zend-text) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-view) >= 2.6.3 with php-autoloader(%{gh_owner}/zend-view) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-filter) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
-# remirepo:26
+BuildRequires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.7.1 with php-autoloader(%{gh_owner}/laminas-modulemanager) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-text) >= 2.6 with php-autoloader(%{gh_owner}/laminas-text) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.6.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+# remirepo:14
%else
-BuildRequires: php-composer(container-interop/container-interop) < 2
-BuildRequires: php-composer(container-interop/container-interop) >= 1.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-console) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-console) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-modulemanager) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-modulemanager) >= 2.7.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0.3
-BuildRequires: php-autoloader(%{gh_owner}/zend-router) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-text) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-text) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-view) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-view) >= 2.6.3
-BuildRequires: php-autoloader(%{gh_owner}/zend-filter) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-filter) >= 2.6.1
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-container-interop
+BuildRequires: php-laminas-console
+BuildRequires: php-laminas-eventmanager
+BuildRequires: php-laminas-modulemanager
+BuildRequires: php-laminas-mvc
+BuildRequires: php-laminas-router
+BuildRequires: php-laminas-servicemanager
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-text
+BuildRequires: php-laminas-view
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-filter
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -88,78 +79,73 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "container-interop/container-interop": "^1.1",
-# "zendframework/zend-console": "^2.6",
-# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
-# "zendframework/zend-modulemanager": "^2.7.1",
-# "zendframework/zend-mvc": "^3.0.3",
-# "zendframework/zend-router": "^3.0",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-stdlib": "^2.7.5 || ^3.0",
-# "zendframework/zend-text": "^2.6",
-# "zendframework/zend-view": "^2.6.3"
+# "laminas/laminas-console": "^2.6",
+# "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+# "laminas/laminas-modulemanager": "^2.7.1",
+# "laminas/laminas-mvc": "^3.0.3",
+# "laminas/laminas-router": "^3.0",
+# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-stdlib": "^2.7.5 || ^3.0",
+# "laminas/laminas-text": "^2.6",
+# "laminas/laminas-view": "^2.6.3",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
-Requires: (php-autoloader(%{gh_owner}/zend-console) >= 2.6 with php-autoloader(%{gh_owner}/zend-console) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2 with php-autoloader(%{gh_owner}/zend-eventmanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-modulemanager) >= 2.7.1 with php-autoloader(%{gh_owner}/zend-modulemanager) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-mvc) >= 3.0.3 with php-autoloader(%{gh_owner}/zend-mvc) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-router) >= 3.0 with php-autoloader(%{gh_owner}/zend-router) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.5 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-text) >= 2.6 with php-autoloader(%{gh_owner}/zend-text) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-view) >= 2.6.3 with php-autoloader(%{gh_owner}/zend-view) < 3)
-# remirepo:22
+Requires: (php-composer(container-interop/container-interop) >= 1.1 with php-composer(container-interop/container-interop) < 2)
+Requires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.7.1 with php-autoloader(%{gh_owner}/laminas-modulemanager) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-router) >= 3.0 with php-autoloader(%{gh_owner}/laminas-router) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-text) >= 2.6 with php-autoloader(%{gh_owner}/laminas-text) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.6.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "suggest": {
+# "laminas/laminas-filter": "^2.6.1, to filter rendered results"
+Suggests: php-composer(%{gh_owner}/laminas-filter)
+# remirepo:13
%else
-Requires: php-composer(container-interop/container-interop) < 2
-Requires: php-composer(container-interop/container-interop) >= 1.1
-Requires: php-autoloader(%{gh_owner}/zend-console) < 3
-Requires: php-autoloader(%{gh_owner}/zend-console) >= 2.6
-Requires: php-autoloader(%{gh_owner}/zend-eventmanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-eventmanager) >= 2.6.2
-Requires: php-autoloader(%{gh_owner}/zend-modulemanager) < 3
-Requires: php-autoloader(%{gh_owner}/zend-modulemanager) >= 2.7.1
-Requires: php-autoloader(%{gh_owner}/zend-mvc) < 4
-Requires: php-autoloader(%{gh_owner}/zend-mvc) >= 3.0.3
-Requires: php-autoloader(%{gh_owner}/zend-router) < 4
-Requires: php-autoloader(%{gh_owner}/zend-router) >= 3.0
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-Requires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.5
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7.5
-Requires: php-autoloader(%{gh_owner}/zend-text) < 3
-Requires: php-autoloader(%{gh_owner}/zend-text) >= 2.6
-Requires: php-autoloader(%{gh_owner}/zend-view) < 3
-Requires: php-autoloader(%{gh_owner}/zend-view) >= 2.6.3
+Requires: php-container-interop
+Requires: php-laminas-console
+Requires: php-laminas-eventmanager
+Requires: php-laminas-modulemanager
+Requires: php-laminas-mvc
+Requires: php-laminas-router
+Requires: php-laminas-servicemanager
+Requires: php-laminas-stdlib
+Requires: php-laminas-text
+Requires: php-laminas-view
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 1.1.10
+# From phpcompatinfo report for version 1.2.0
Requires: php-spl
-%if ! %{bootstrap}
-# From composer, "suggest": {
-# "zendframework/zend-filter": "^2.6.1, to filter rendered results"
-Suggests: php-composer(%{gh_owner}/zend-filter)
-%endif
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 1.2.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-zend-mvc-console provides integration between:
+%{gh_project} provides integration between:
-* zend-console
-* zend-mvc
-* zend-router
-* zend-view
+* laminas-console
+* laminas-mvc
+* laminas-router
+* laminas-view
and replaces the console functionality found in the v2 releases of the latter
three components.
-* File issues at https://github.com/zendframework/zend-mvc-console/issues
-* Documentation is at https://zendframework.github.io/zend-mvc-console/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -169,38 +155,44 @@ mv LICENSE.md LICENSE
%build
-: Create dependency autoloader - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-require_once '%{php_home}/Interop/Container/autoload.php';
-EOF
-
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/Interop/Container/autoload.php',
- '%{php_home}/Zend/Console/autoload.php',
- '%{php_home}/Zend/EventManager/autoload.php',
- '%{php_home}/Zend/ModuleManager/autoload.php',
- '%{php_home}/Zend/Mvc/autoload.php',
- '%{php_home}/Zend/Router/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
- '%{php_home}/Zend/Text/autoload.php',
- '%{php_home}/Zend/View/autoload.php',
+ '%{php_home}/%{namespace}/Console/autoload.php',
+ '%{php_home}/%{namespace}/EventManager/autoload.php',
+ '%{php_home}/%{namespace}/ModuleManager/autoload.php',
+ '%{php_home}/%{namespace}/Mvc/autoload.php',
+ '%{php_home}/%{namespace}/Router/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Text/autoload.php',
+ '%{php_home}/%{namespace}/View/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Filter/autoload.php',
+ '%{php_home}/%{namespace}/Filter/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(dirname(__DIR__))) . '/%{namespace}/%{library}/%{subproj}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/Mvc
-cp -pr src %{buildroot}%{php_home}/Zend/Mvc/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/%{library}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}
-install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-%{library}-autoload.php
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}/%{subproj}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/%{subproj}/autoload.php
%check
@@ -208,12 +200,19 @@ install -m644 autoload.php %{buildroot}%{php_home}/Zend/Mvc-%{library}-autoload.
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/Mvc/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Mvc\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/%{subproj}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\%{subproj}\\ConfigProvider") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -226,15 +225,19 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
-%{php_home}/Zend/Mvc/%{library}
-%{php_home}/Zend/Mvc-%{library}-autoload.php
+%{php_home}/Zend/%{library}/%{subproj}
+%{php_home}/%{namespace}/%{library}/%{subproj}
%changelog
+* Thu Jan 16 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- switch to Laminas
+
* Thu May 3 2018 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0
- use range dependencies on F27+