summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json13
-rw-r--r--php-laminas-modulemanager.spec15
2 files changed, 21 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 2900460..a31b648 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,13 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "sort-packages": true,
+ "platform": {
+ "php": "7.3.99"
+ }
},
"extra": {
},
@@ -33,7 +39,9 @@
"laminas/laminas-loader": "^2.8",
"laminas/laminas-mvc": "^3.1.1",
"laminas/laminas-servicemanager": "^3.7",
- "phpunit/phpunit": "^9.5.5"
+ "phpunit/phpunit": "^9.5.5",
+ "psalm/plugin-phpunit": "^0.16.1",
+ "vimeo/psalm": "^4.10"
},
"suggest": {
"laminas/laminas-console": "Laminas\\Console component",
@@ -61,6 +69,7 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
+ "static-analysis": "psalm --shepherd --stats",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"conflict": {
diff --git a/php-laminas-modulemanager.spec b/php-laminas-modulemanager.spec
index 1208dd6..ed5ac5b 100644
--- a/php-laminas-modulemanager.spec
+++ b/php-laminas-modulemanager.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-laminas-modulemanager
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
%bcond_with bootstrap
%bcond_without tests
-%global gh_commit 6acf5991d10b0b38a2edb08729ed48981b2a5dad
+%global gh_commit cd2dd3b3dc59e75a9f2117374222c0d84b25bf19
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-modulemanager
@@ -20,7 +20,7 @@
%global library ModuleManager
Name: php-%{gh_project}
-Version: 2.11.0
+Version: 2.12.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -47,7 +47,9 @@ BuildRequires: (php-composer(webimpress/safe-writer) >= 2.1
# "laminas/laminas-loader": "^2.8",
# "laminas/laminas-mvc": "^3.1.1",
# "laminas/laminas-servicemanager": "^3.7",
-# "phpunit/phpunit": "^9.5.5"
+# "phpunit/phpunit": "^9.5.5",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "vimeo/psalm": "^4.10"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.8 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
%if %{without bootstrap}
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 3.1.1 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
@@ -201,7 +203,7 @@ exit (class_exists("\\Zend\\%{library}\\ModuleEvent") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -224,6 +226,9 @@ exit $ret
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0 (no change)
+
* Thu Oct 14 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
- update to 2.11.0
- keep compatibility using laminas-zendframework-bridge