summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-25 14:33:44 +0200
committerRemi Collet <remi@remirepo.net>2020-08-25 14:33:44 +0200
commit62c0028f3a7cf02ef796a23bad94a985408742cf (patch)
treef6d76c65496b00e61cea4f9f90f3cd1a7392f2c6
parent145a80bd619ec169d802efc4f975407613a4b09b (diff)
update to 2.9.0
add dependency on webimpress/safe-writer
-rw-r--r--composer.json9
-rw-r--r--php-laminas-modulemanager.spec46
2 files changed, 34 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index 6636b0c..65d8054 100644
--- a/composer.json
+++ b/composer.json
@@ -20,8 +20,8 @@
},
"extra": {
"branch-alias": {
- "dev-master": "2.8.x-dev",
- "dev-develop": "2.9.x-dev"
+ "dev-master": "2.9.x-dev",
+ "dev-develop": "2.10.x-dev"
}
},
"require": {
@@ -29,7 +29,8 @@
"laminas/laminas-config": "^3.1 || ^2.6",
"laminas/laminas-eventmanager": "^3.2 || ^2.6.3",
"laminas/laminas-stdlib": "^3.1 || ^2.7",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-zendframework-bridge": "^1.0",
+ "webimpress/safe-writer": "^1.0.2 || ^2.1"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
@@ -73,6 +74,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-modulemanager": "self.version"
+ "zendframework/zend-modulemanager": "^2.8.4"
}
}
diff --git a/php-laminas-modulemanager.spec b/php-laminas-modulemanager.spec
index 41220ff..004bea4 100644
--- a/php-laminas-modulemanager.spec
+++ b/php-laminas-modulemanager.spec
@@ -7,8 +7,10 @@
# Please, preserve the changelog entries
#
# When build without laminas-mvc
-%global bootstrap 1
-%global gh_commit 92b1cde1aab5aef687b863face6dd5d9c6751c78
+%bcond_with bootstrap
+%bcond_without tests
+
+%global gh_commit 789bbd4ab391da9221f265f6bb2d594f8f11855b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-modulemanager
@@ -16,10 +18,9 @@
%global php_home %{_datadir}/php
%global namespace Laminas
%global library ModuleManager
-%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.8.4
+Version: 2.9.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -30,7 +31,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
# remirepo:1
@@ -39,6 +40,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-composer(webimpress/safe-writer) >= 2.1 with php-composer(webimpress/safe-writer) < 3)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-console": "^2.6",
@@ -50,21 +52,22 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
BuildRequires: (php-autoloader(%{gh_owner}/laminas-console) >= 2.6 with php-autoloader(%{gh_owner}/laminas-console) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-di) >= 2.6 with php-autoloader(%{gh_owner}/laminas-di) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
-%if ! %{bootstrap}
+%if %{without bootstrap}
# ignore max version, test suite pass with 3.1
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mvc) >= 2.7 with php-autoloader(%{gh_owner}/laminas-mvc) < 4)
%endif
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-# remirepo:11
+# remirepo:14
%else
BuildRequires: php-laminas-config
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-webimpress-safe-writer
BuildRequires: php-laminas-console
BuildRequires: php-laminas-di
BuildRequires: php-laminas-loader
-%if ! %{bootstrap}
+%if %{without bootstrap}
BuildRequires: php-laminas-mvc
%endif
BuildRequires: php-laminas-servicemanager
@@ -80,7 +83,8 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-config": "^3.1 || ^2.6",
# "laminas/laminas-eventmanager": "^3.2 || ^2.6.3",
# "laminas/laminas-stdlib": "^3.1 || ^2.7",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-zendframework-bridge": "^1.0",
+# "webimpress/safe-writer": "^1.0.2 || ^2.1"
Requires: php(language) >= 5.6
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -88,6 +92,7 @@ Requires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6
Requires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.2 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-composer(webimpress/safe-writer) >= 2.1 with php-composer(webimpress/safe-writer) < 3)
# From composer, "suggest": {
# "laminas/laminas-console": "Laminas\\Console component",
# "laminas/laminas-loader": "Laminas\\Loader component if you are not using Composer autoloading for your modules",
@@ -97,24 +102,26 @@ Suggests: php-autoloader(%{gh_owner}/laminas-console)
Suggests: php-autoloader(%{gh_owner}/laminas-loader)
Suggests: php-autoloader(%{gh_owner}/laminas-mvc)
Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
-# remirepo:6
+# remirepo:7
%else
Requires: php-laminas-config
Requires: php-laminas-eventmanager
Requires: php-laminas-stdlib
Requires: php-laminas-zendframework-bridge
+Requires: php-webimpress-safe-writer
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 2.8.4
Requires: php-spl
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.8.4-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Obsoletes: php-zendframework-%{zf_name} < 2.8.5
+Provides: php-zendframework-%{zf_name} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
@@ -129,7 +136,7 @@ and/or public assets such as images, CSS, and JavaScript.
The possibilities are endless.
%{namespace}\ModuleManager is the component that enables the design of a module
-architecture for PHP applcations.
+architecture for PHP applications.
Documentation: https://docs.laminas.dev/%{gh_project}/
@@ -151,6 +158,7 @@ cat << 'EOF' | tee -a src/autoload.php
],
'%{php_home}/%{namespace}/EventManager/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/Webimpress/SafeWriter/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/%{namespace}/Console/autoload.php',
@@ -181,7 +189,7 @@ cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
@@ -202,13 +210,13 @@ require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
exit (class_exists("\\Zend\\%{library}\\ModuleEvent") ? 0 : 1);
'
-%if %{bootstrap}
+%if %{without bootstrap}
rm -r test/Listener/
%endif
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -231,6 +239,10 @@ exit $ret
%changelog
+* Tue Aug 25 2020 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- update to 2.9.0
+- add dependency on webimpress/safe-writer
+
* Wed Jan 15 2020 Remi Collet <remi@remirepo.net> - 2.8.4-1
- switch to Laminas
- bootstrap build without laminas-mvc