summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-laminas-mime.spec15
2 files changed, 14 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index abd1869..9e5f58a 100644
--- a/composer.json
+++ b/composer.json
@@ -16,7 +16,10 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
- "sort-packages": true
+ "sort-packages": true,
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
},
"require": {
"php": "^7.3 || ~8.0.0 || ~8.1.0",
@@ -25,7 +28,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "~2.2.1",
"laminas/laminas-mail": "^2.12",
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^9.5"
},
"suggest": {
"laminas/laminas-mail": "Laminas\\Mail component"
diff --git a/php-laminas-mime.spec b/php-laminas-mime.spec
index b9d3f32..2b8fdea 100644
--- a/php-laminas-mime.spec
+++ b/php-laminas-mime.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-mime
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
# When build without laminas-mail
%global bootstrap 0
-%global gh_commit 72d21a1b4bb7086d4a4d7058c0abca180b209184
+%global gh_commit 62a899a7c9100889c2d2386b1357003a2cb52fa9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mime
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.9.1
+Version: 2.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -38,7 +38,7 @@ BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.2.1",
# "laminas/laminas-mail": "^2.12",
-# "phpunit/phpunit": "^9.3"
+# "phpunit/phpunit": "^9.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -55,7 +55,7 @@ BuildRequires: php-laminas-mail
%endif
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -163,7 +163,7 @@ rm test/DecodeTest.php
: upstream test suite
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80 php81; do
+for cmd in "php %{phpunit}" php80 php81 php82; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} \
@@ -190,6 +190,9 @@ exit $ret
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0
+
* Thu Sep 23 2021 Remi Collet <remi@remirepo.net> - 2.9.1-1
- update to 2.9.1