summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-06 11:55:34 +0100
committerRemi Collet <remi@remirepo.net>2020-03-06 11:55:34 +0100
commit6edf99c2b82b485ade92b60b13f22a2b9e78949b (patch)
treef9bf4f166b876676ac5468fa3b563abfb33cdc81
parentdc3882fc7c3e6d5a41579916814f4111feea3f1a (diff)
update to 2.7.3
switch to phpunit7
-rw-r--r--composer.json2
-rw-r--r--php-laminas-mime.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index cd4f45f..7bcef78 100644
--- a/composer.json
+++ b/composer.json
@@ -32,7 +32,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-mail": "^2.6",
- "phpunit/phpunit": "^5.7.21 || ^6.3"
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
},
"suggest": {
"laminas/laminas-mail": "Laminas\\Mail component"
diff --git a/php-laminas-mime.spec b/php-laminas-mime.spec
index 3c3ca1a..56ef4ab 100644
--- a/php-laminas-mime.spec
+++ b/php-laminas-mime.spec
@@ -8,7 +8,7 @@
#
# When build without laminas-mail
%global bootstrap 1
-%global gh_commit 2dbace2c69542e5a251af3becb6d7209ac9fb42b
+%global gh_commit e844abb02e868fae154207929190292ad25057cc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mime
@@ -19,8 +19,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.7.2
-Release: 2%{?dist}
+Version: 2.7.3
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -38,7 +38,7 @@ BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-mail": "^2.6",
-# "phpunit/phpunit": "^5.7.21 || ^6.3"
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -54,8 +54,8 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-mail
%endif
%endif
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: %{phpunit}
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.5.20
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -167,7 +167,7 @@ ret=0
for cmd in "php %{phpunit}" php72 php73 php74; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit6} \
+ $1 ${2:-%{_bindir}/phpunit7} \
%if %{bootstrap}
--filter '^((?!(testFromMessageDecode|testFromMessageMultiPart)).)*$' \
%endif
@@ -191,6 +191,10 @@ exit $ret
%changelog
+* Fri Mar 6 2020 Remi Collet <remi@remirepo.net> - 2.7.3-1
+- update to 2.7.3
+- switch to phpunit7
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.7.2-2
- cleanup