summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-laminas-memory.spec20
2 files changed, 17 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 15972db..535b53c 100644
--- a/composer.json
+++ b/composer.json
@@ -19,16 +19,19 @@
"sort-packages": true,
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
+ },
+ "platform": {
+ "php": "8.0.99"
}
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0"
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
},
"require-dev": {
"laminas/laminas-cache": "^3.0",
"laminas/laminas-cache-storage-adapter-memory": "^2.0",
"laminas/laminas-coding-standard": "~2.3.0",
- "phpunit/phpunit": "^9.3"
+ "phpunit/phpunit": "^9.5"
},
"suggest": {
"laminas/laminas-cache": "To support swapping memory objects into and out of non-memory cache storage"
diff --git a/php-laminas-memory.spec b/php-laminas-memory.spec
index 1a065ce..6e25866 100644
--- a/php-laminas-memory.spec
+++ b/php-laminas-memory.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c5b51ba1958d55bceb5c79506fd7f25eef96156c
+%global gh_commit f337bd5106b7464839e5c16ce0bdf1aea2809d1a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-memory
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.9.0
+Version: 2.10.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,13 +34,13 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-spl
# From composer, "require-dev": {
# "laminas/laminas-cache": "^3.0",
# "laminas/laminas-cache-storage-adapter-memory": "^2.0",
# "laminas/laminas-coding-standard": "^2.0",
-# "phpunit/phpunit": "^9.3"
+# "phpunit/phpunit": "^9.5"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -52,14 +52,14 @@ BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-cache
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0"
-Requires: php(language) >= 7.3
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0"
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -157,7 +157,7 @@ exit (class_exists("\\Zend\\%{library}\\Value") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -180,6 +180,10 @@ exit $ret
%changelog
+* Wed Nov 16 2022 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- update to 2.10.0 (no change)
+- raise dependency on PHP 8.0
+
* Thu Mar 24 2022 Remi Collet <remi@remirepo.net> - 2.9.0-1
- update to 2.9.0