summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-09 11:42:08 +0100
committerRemi Collet <remi@remirepo.net>2020-01-09 11:42:08 +0100
commitcb47b5e58bb8cff299c0dd8047cd8e5e8954ab33 (patch)
treeebbee0b2249e25fa40395b93a7f4eace2cd20b82
parent8d58a2b12989e834a8dda91424bf8770a0464586 (diff)
switch to Laminas
-rw-r--r--composer.json54
-rw-r--r--php-laminas-memory.spec107
2 files changed, 102 insertions, 59 deletions
diff --git a/composer.json b/composer.json
index 36bb385..bd15d21 100644
--- a/composer.json
+++ b/composer.json
@@ -1,48 +1,49 @@
{
- "name": "zendframework/zend-memory",
+ "name": "laminas/laminas-memory",
"description": "Manage data in an environment with limited memory",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"memory"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-memory/",
- "issues": "https://github.com/zendframework/zend-memory/issues",
- "source": "https://github.com/zendframework/zend-memory",
- "rss": "https://github.com/zendframework/zend-memory/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-memory/",
+ "issues": "https://github.com/laminas/laminas-memory/issues",
+ "source": "https://github.com/laminas/laminas-memory",
+ "rss": "https://github.com/laminas/laminas-memory/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.6.x-dev",
+ "dev-develop": "2.7.x-dev"
+ }
},
"require": {
- "php": "^5.6 || ^7.0"
+ "php": "^5.6 || ^7.0",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
- "zendframework/zend-cache": "^2.7",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "laminas/laminas-cache": "^2.7",
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
},
"suggest": {
- "zendframework/zend-cache": "To support swapping memory objects into and out of non-memory cache storage"
+ "laminas/laminas-cache": "To support swapping memory objects into and out of non-memory cache storage"
},
"autoload": {
"psr-4": {
- "Zend\\Memory\\": "src/"
+ "Laminas\\Memory\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Memory\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.6.x-dev",
- "dev-develop": "2.7.x-dev"
+ "LaminasTest\\Memory\\": "test/"
}
},
"scripts": {
@@ -54,5 +55,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-memory": "self.version"
}
}
diff --git a/php-laminas-memory.spec b/php-laminas-memory.spec
index c2e0ad1..066a475 100644
--- a/php-laminas-memory.spec
+++ b/php-laminas-memory.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-memory
+# remirepo/Fedora spec file for php-laminas-memory
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 00a733ebbc4e6ec978939c1b09b928174e15808f
+%global gh_commit 7d4f8a727b781f1acd5713b9667cdb6e42dbec17
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-memory
+%global gh_owner laminas
+%global gh_project laminas-memory
+%global zf_name zend-memory
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Memory
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.6.1
-Release: 2%{?dist}
-Summary: Zend Framework %{library} component
+Release: 1%{?dist}
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -35,46 +37,56 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
-# "zendframework/zend-cache": "^2.7",
-# "zendframework/zend-coding-standard": "~1.0.0"
+# "laminas/laminas-cache": "^2.7",
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.7 with php-autoloader(%{gh_owner}/zend-cache) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.4
-# remirepo:6
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.7 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
+# remirepo:4
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-cache) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.7
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-cache
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0"
+# "php": "^5.6 || ^7.0",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
%if ! %{bootstrap}
# From composer, "suggest": {
-# "zendframework/zend-cache": "To support swapping memory objects into and out of non-memory cache storage"
-Suggests: php-autoloader(%{gh_owner}/zend-cache)
+# "laminas/laminas-cache": "To support swapping memory objects into and out of non-memory cache storage"
+Suggests: php-autoloader(%{gh_owner}/laminas-cache)
+%endif
+# remirepo:8
+%else
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.5.1
+# From phpcompatinfo report for version 2.6.1
Requires: php-spl
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.6.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-The Zend\Memory component is intended to manage data in an environment with
+The %{namespace}\Memory component is intended to manage data in an environment with
limited memory.
Memory objects (memory containers) are generated by memory manager by request
@@ -85,7 +97,7 @@ memory usage to exceed the limit you specify, some managed objects are copied
to cache storage outside of memory. In this way, the total memory used by
managed objects does not exceed the limit you need to enforce.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -99,14 +111,28 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Cache/autoload.php',
+ '%{php_home}/%{namespace}/Cache/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -114,12 +140,20 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\Value") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -132,14 +166,19 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Thu Jan 9 2020 Remi Collet <remi@remirepo.net> - 2.6.1-1
+- switch to Laminas
+
* Wed Oct 16 2019 Remi Collet <remi@remirepo.net> - 2.6.1-2
- update to 2.6.1 (no change)