summaryrefslogtreecommitdiffstats
path: root/php-laminas-math.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-06 16:54:58 +0100
committerRemi Collet <remi@remirepo.net>2020-01-06 16:54:58 +0100
commit28a54778d45b008a2172b21aa281449c911e3176 (patch)
tree4fef28c120706a49b8447fdd10b9b75a50fe35bf /php-laminas-math.spec
parent4bf400c8fdf7048e268398fad5d79ccf33213980 (diff)
switch to Laminas
add patch to fix test suite from https://github.com/laminas/laminas-math/pull/2
Diffstat (limited to 'php-laminas-math.spec')
-rw-r--r--php-laminas-math.spec120
1 files changed, 73 insertions, 47 deletions
diff --git a/php-laminas-math.spec b/php-laminas-math.spec
index d3f76df..e31dc7d 100644
--- a/php-laminas-math.spec
+++ b/php-laminas-math.spec
@@ -1,17 +1,19 @@
-# remirepo/Fedora spec file for php-zendframework-zend-math
+# remirepo/Fedora spec file for php-laminas-math
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 07e43d87fd5c7edc4f54121b9a4625eb10e4b726
+%global gh_commit dd603c7d151d46eafd243a405d5b7eefa4222d74
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-math
+%global gh_owner laminas
+%global gh_project laminas-math
+%global zf_name zend-math
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Math
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,42 +21,43 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 3.2.0
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: Laminas Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-math/pull/2.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
BuildRequires: php(language) >= 5.6
+BuildRequires: php-mbstring
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-composer(paragonie/random_compat) >= 2.0.11 with php-composer(paragonie/random_compat) < 3)
+# remirepo:3
+%else
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-paragonie-random-compat >= 2.0.11
+%endif
BuildRequires: php-bcmath
BuildRequires: php-gmp
-BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
# test suite hangs without (need investigation)
BuildRequires: php-mcrypt
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
-# "zendframework/zend-coding-standard": "~1.0.0"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(paragonie/random_compat) >= 2.0.11 with php-composer(paragonie/random_compat) < 3)
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
%global phpunit %{_bindir}/phpunit7
BuildRequires: phpunit7 >= 7.1.2
-# remirepo:6
-%else
-BuildRequires: php-composer(paragonie/random_compat) < 3
-BuildRequires: php-composer(paragonie/random_compat) >= 2.0.11
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
-%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -62,19 +65,20 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "ext-mbstring": "*",
+# "laminas/laminas-zendframework-bridge": "^1.0",
# "paragonie/random_compat": "^2.0.11 || 9.99.99"
Requires: php(language) >= 5.6
Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(paragonie/random_compat) >= 2.0.11 with php-composer(paragonie/random_compat) < 3)
+Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-composer(paragonie/random_compat) >= 2.0.11 with php-composer(paragonie/random_compat) < 3)
# remirepo:4
%else
-Requires: php-composer(paragonie/random_compat) < 3
-Requires: php-composer(paragonie/random_compat) >= 2.0.11
+Requires: php-laminas-zendframework-bridge
+Requires: php-paragonie-random-compat >= 2.0.11
%endif
-# From phpcompatinfo report for version 3.1.0
-Requires: php-mbstring
+# From phpcompatinfo report for version 3.2.0
Requires: php-pcre
Requires: php-spl
%if ! %{bootstrap}
@@ -87,33 +91,32 @@ Requires: php-gmp
Requires: php-composer(fedora/autoloader)
%endif
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 3.2.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\Math provides general mathematical functions.
+%{gh_project} provides general mathematical functions.
So far the supported functionalities are:
-* Zend\Math\Rand, a random number generator;
-* Zend\Math\BigInteger, a library to manage big integers.
+* Laminas\Math\Rand, a random number generator;
+* Laminas\Math\BigInteger, a library to manage big integers.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1 -b .pr2
mv LICENSE.md LICENSE
-%build
-: Create dependency autoloader - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-require_once '%{php_home}/random_compat/autoload.php';
-EOF
+%build
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
@@ -122,13 +125,25 @@ cat << 'EOF' | tee -a src/autoload.php
]);
EOF
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
+]);
+EOF
+
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
-install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -136,18 +151,25 @@ install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
require_once dirname(__DIR__) . '/test/TestAsset/random_bytes.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
+
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\Rand") ? 0 : 1);
+'
+
exit $ret
%else
: Test suite disabled
@@ -159,12 +181,16 @@ exit $ret
%license LICENSE
%doc *.md
%doc composer.json
-%dir %{php_home}/Zend
%{php_home}/Zend/%{library}
-%{php_home}/Zend/%{library}-autoload.php
+%{php_home}/%{namespace}/%{library}
%changelog
+* Mon Jan 6 2020 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- switch to Laminas
+- add patch to fix test suite from
+ https://github.com/laminas/laminas-math/pull/2
+
* Tue Dec 11 2018 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0 (no change)