summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-22 10:25:50 +0100
committerRemi Collet <remi@remirepo.net>2021-01-22 10:25:50 +0100
commitdeab1f192547b7be8dbaea2c696e2a9eabb23412 (patch)
treea02bfb5f0dd3157efc5064c9275b9f12221792ee
parent15129940d661ff889ea970ae9b7732e9a58fe703 (diff)
update to 3.3.0
raise dependency on PHP 7.3 drop dependency on paragonie/random_compat switch to phpunit9 drop patch merged upstream add patch for PHP 8 from https://github.com/laminas/laminas-math/pull/8
-rw-r--r--2.patch22
-rw-r--r--8.patchbin0 -> 433 bytes
-rw-r--r--composer.json9
-rw-r--r--php-laminas-math.spec54
4 files changed, 32 insertions, 53 deletions
diff --git a/2.patch b/2.patch
deleted file mode 100644
index 8557772..0000000
--- a/2.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 3488ee782f69b710ba6231898d9c4e3f78c4c864 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 6 Jan 2020 16:50:00 +0100
-Subject: [PATCH] fix typo from Laminas move
-
----
- test/BigInteger/Adapter/AbstractTestCase.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/BigInteger/Adapter/AbstractTestCase.php b/test/BigInteger/Adapter/AbstractTestCase.php
-index e5f34d0..6f618fc 100644
---- a/test/BigInteger/Adapter/AbstractTestCase.php
-+++ b/test/BigInteger/Adapter/AbstractTestCase.php
-@@ -363,7 +363,7 @@ public function binaryConversionProvider()
- 'FV31FwuflLcgcehcYduXOp0sUSL/frxiCjv0lGfFOReOCZjSvGUnltTXMgppIO4p2Ij5dSQolfwW9/xby+yLFg6s=',
-
- // negative binary, two's complement
-- '/yMGxfR3xo0T8eZnZTpdMc7x4siOgXJqjkSJ3IznmRnhCKXR2HZ0+oBnbj0dhZxjwNZJ9+un4yxNNcZ5LLaminasI+q' .
-+ '/yMGxfR3xo0T8eZnZTpdMc7x4siOgXJqjkSJ3IznmRnhCKXR2HZ0+oBnbj0dhZxjwNZJ9+un4yxNNcZ5LZfI+q' .
- 'iCuj0YGtI344Xo54kaMVi067dAIFDnfXEC2uYOsbocfZnLUOa2GkrKM31lt8R1id3Borb12oD6QgDpDQTdOnxV',
- ],
- ];
diff --git a/8.patch b/8.patch
new file mode 100644
index 0000000..68c4e67
--- /dev/null
+++ b/8.patch
Binary files differ
diff --git a/composer.json b/composer.json
index 2cf752b..1677bc4 100644
--- a/composer.json
+++ b/composer.json
@@ -25,14 +25,13 @@
}
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"ext-mbstring": "*",
- "laminas/laminas-zendframework-bridge": "^1.0",
- "paragonie/random_compat": "^2.0.11 || 9.99.99"
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"ext-bcmath": "If using the bcmath functionality",
@@ -62,6 +61,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-math": "self.version"
+ "zendframework/zend-math": "^3.2.0"
}
}
diff --git a/php-laminas-math.spec b/php-laminas-math.spec
index 43037d9..eb7ad63 100644
--- a/php-laminas-math.spec
+++ b/php-laminas-math.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-math
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit dd603c7d151d46eafd243a405d5b7eefa4222d74
+%global gh_commit 67fb8962d11c75bb494a23b273e3453720353515
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-math
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 3.2.0
-Release: 2%{?dist}
+Version: 3.3.0
+Release: 1%{?dist}
Summary: Laminas Framework %{library} component
License: BSD
@@ -31,21 +31,19 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-math/pull/2.patch
+Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-math/pull/8.patch
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
-BuildRequires: (php-composer(paragonie/random_compat) >= 2.0.11 with php-composer(paragonie/random_compat) < 3)
# remirepo:3
%else
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-paragonie-random-compat >= 2.0.11
%endif
BuildRequires: php-bcmath
BuildRequires: php-gmp
@@ -55,28 +53,25 @@ BuildRequires: php-spl
BuildRequires: php-mcrypt
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+# "phpunit/phpunit": "^9.3"
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "ext-mbstring": "*",
-# "laminas/laminas-zendframework-bridge": "^1.0",
-# "paragonie/random_compat": "^2.0.11 || 9.99.99"
-Requires: php(language) >= 5.6
+# "laminas/laminas-zendframework-bridge": "^1.0"
+Requires: php(language) >= 7.3
Requires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
-Requires: (php-composer(paragonie/random_compat) >= 2.0.11 with php-composer(paragonie/random_compat) < 3)
-# remirepo:4
+# remirepo:3
%else
Requires: php-laminas-zendframework-bridge
-Requires: php-paragonie-random-compat >= 2.0.11
%endif
# From phpcompatinfo report for version 3.2.0
Requires: php-pcre
@@ -95,8 +90,8 @@ Requires: php-composer(fedora/autoloader)
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 3.2.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 3.3.0
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -114,7 +109,7 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr2
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -123,9 +118,6 @@ mv LICENSE.md LICENSE
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/random_compat/autoload.php',
-]);
EOF
cat << 'EOF' | tee zf.php
@@ -160,10 +152,10 @@ require_once dirname(__DIR__) . '/test/TestAsset/random_bytes.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
@@ -180,6 +172,7 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -189,6 +182,15 @@ exit $ret
%changelog
+* Fri Jan 22 2021 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- raise dependency on PHP 7.3
+- drop dependency on paragonie/random_compat
+- switch to phpunit9
+- drop patch merged upstream
+- add patch for PHP 8 from
+ https://github.com/laminas/laminas-math/pull/8
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 3.2.0-2
- cleanup