summaryrefslogtreecommitdiffstats
path: root/php-laminas-mail.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-24 11:58:57 +0100
committerRemi Collet <remi@php.net>2022-02-24 11:58:57 +0100
commit14a7f609ae05ff484235fd4d61602512aea319c9 (patch)
treeffdb400caf3038b5c4714acd3c83ea342868aee5 /php-laminas-mail.spec
parentf895c842e0887125a0387848fc25d26bde41b06d (diff)
update to 2.16.0
drop dependency on true/punycode add dependency on intl extension
Diffstat (limited to 'php-laminas-mail.spec')
-rw-r--r--php-laminas-mail.spec30
1 files changed, 16 insertions, 14 deletions
diff --git a/php-laminas-mail.spec b/php-laminas-mail.spec
index 8ffeccd..e266832 100644
--- a/php-laminas-mail.spec
+++ b/php-laminas-mail.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-mail
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%bcond_without tests
-%global gh_commit 70c3476913c74e9befd782ab665ad1b9ebac556e
+%global gh_commit 1ee1a384b96c8af29ecad9b3a7adc27a150ebc49
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-mail
@@ -18,7 +18,7 @@
%global library Mail
Name: php-%{gh_project}
-Version: 2.15.1
+Version: 2.16.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,6 +34,7 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-iconv
+BuildRequires: php-intl
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -44,7 +45,6 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.9.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-BuildRequires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
BuildRequires: (php-composer(webmozart/assert) >= 1.10 with php-composer(webmozart/assert) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
@@ -60,14 +60,13 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.13
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
# ignore min version
BuildRequires: (php-composer(symfony/process) >= 4 with php-composer(symfony/process) < 6)
-# remirepo:13
+# remirepo:12
%else
BuildRequires: php-laminas-loader
BuildRequires: php-laminas-mime
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-true-punycode
BuildRequires: php-webmozart-assert
BuildRequires: php-laminas-crypt
BuildRequires: php-laminas-db
@@ -88,8 +87,8 @@ BuildRequires: php-fedora-autoloader-devel
# "laminas/laminas-stdlib": "^3.6",
# "laminas/laminas-validator": "^2.15",
# "symfony/polyfill-mbstring": "^1.12.0",
-# "true/punycode": "^2.1",
-# "webmozart/assert": "^1.10"
+# "webmozart/assert": "^1.10",
+# "symfony/polyfill-intl-idn": "^1.24.0"
Requires: php(language) >= 7.3
Requires: php-iconv
Requires: php-mbstring
@@ -100,7 +99,6 @@ Requires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.9.
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
-Requires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
Requires: (php-composer(webmozart/assert) >= 1.10 with php-composer(webmozart/assert) < 2)
# From composer, "suggest": {
# "laminas/laminas-crypt": "Crammd5 support in SMTP Auth",
@@ -109,21 +107,21 @@ Suggests: php-autoloader(%{gh_owner}/laminas-crypt)
Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
# From phpcompatinfo report
Recommends: php-imap
-# remirepo:9
+# remirepo:8
%else
Requires: php-laminas-loader
Requires: php-laminas-mime
Requires: php-laminas-stdlib
Requires: php-laminas-validator
Requires: php-laminas-zendframework-bridge
-Requires: php-true-punycode
Requires: php-webmozart-assert
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.10.0
+# From phpcompatinfo report for version 2.16.0
Requires: php-ctype
Requires: php-date
+Requires: php-intl
Requires: php-pcre
Requires: php-spl
@@ -164,7 +162,6 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/%{namespace}/Mime/autoload.php',
'%{php_home}/%{namespace}/Stdlib/autoload.php',
'%{php_home}/%{namespace}/Validator/autoload.php',
- '%{php_home}/TrueBV/autoload.php',
'%{php_home}/Webmozart/Assert/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
@@ -219,7 +216,7 @@ exit (class_exists("\\Zend\\%{library}\\Message") ? 0 : 1);
: upstream test suite
# testCanUseTraversableAsSpec use Composer\\InstalledVersions
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -244,6 +241,11 @@ exit $ret
%changelog
+* Thu Feb 24 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
+- update to 2.16.0
+- drop dependency on true/punycode
+- add dependency on intl extension
+
* Fri Sep 24 2021 Remi Collet <remi@remirepo.net> - 2.15.1-1
- update to 2.15.1
- keep compatibility using laminas-zendframework-bridge