summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-09 16:06:36 +0100
committerRemi Collet <remi@remirepo.net>2020-01-09 16:06:36 +0100
commit9c5184c6dae9e8df20e1cbd334a0f6af6089a44d (patch)
treeb22649e98605ba5a094423f2ea33866dd7192150
parenta184494d26acbbdbd14cdd550f465a9f529540ff (diff)
switch to Laminas
-rw-r--r--composer.json74
-rw-r--r--php-laminas-mail.spec212
2 files changed, 145 insertions, 141 deletions
diff --git a/composer.json b/composer.json
index b172cef..df6c46b 100644
--- a/composer.json
+++ b/composer.json
@@ -1,61 +1,62 @@
{
- "name": "zendframework/zend-mail",
+ "name": "laminas/laminas-mail",
"description": "Provides generalized functionality to compose and send both text and MIME-compliant multipart e-mail messages",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"mail"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-mail/",
- "issues": "https://github.com/zendframework/zend-mail/issues",
- "source": "https://github.com/zendframework/zend-mail",
- "rss": "https://github.com/zendframework/zend-mail/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-mail/",
+ "issues": "https://github.com/laminas/laminas-mail/issues",
+ "source": "https://github.com/laminas/laminas-mail",
+ "rss": "https://github.com/laminas/laminas-mail/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.10.x-dev",
+ "dev-develop": "2.11.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\Mail",
+ "config-provider": "Laminas\\Mail\\ConfigProvider"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
"ext-iconv": "*",
- "zendframework/zend-loader": "^2.5",
- "zendframework/zend-mime": "^2.5",
- "zendframework/zend-stdlib": "^2.7 || ^3.0",
- "zendframework/zend-validator": "^2.10.2",
+ "laminas/laminas-loader": "^2.5",
+ "laminas/laminas-mime": "^2.5",
+ "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "laminas/laminas-validator": "^2.10.2",
+ "laminas/laminas-zendframework-bridge": "^1.0",
"true/punycode": "^2.1"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.25 || ^6.4.4 || ^7.1.4",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-config": "^2.6",
- "zendframework/zend-crypt": "^2.6 || ^3.0",
- "zendframework/zend-servicemanager": "^2.7.10 || ^3.3.1"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-config": "^2.6",
+ "laminas/laminas-crypt": "^2.6 || ^3.0",
+ "laminas/laminas-servicemanager": "^2.7.10 || ^3.3.1",
+ "phpunit/phpunit": "^5.7.25 || ^6.4.4 || ^7.1.4"
},
"suggest": {
- "zendframework/zend-crypt": "Crammd5 support in SMTP Auth",
- "zendframework/zend-servicemanager": "^2.7.10 || ^3.3.1 when using SMTP to deliver messages"
+ "laminas/laminas-crypt": "Crammd5 support in SMTP Auth",
+ "laminas/laminas-servicemanager": "^2.7.10 || ^3.3.1 when using SMTP to deliver messages"
},
"autoload": {
"psr-4": {
- "Zend\\Mail\\": "src/"
+ "Laminas\\Mail\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Mail\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.10.x-dev",
- "dev-develop": "2.11.x-dev"
- },
- "zf": {
- "component": "Zend\\Mail",
- "config-provider": "Zend\\Mail\\ConfigProvider"
+ "LaminasTest\\Mail\\": "test/"
}
},
"scripts": {
@@ -67,5 +68,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-mail": "self.version"
}
}
diff --git a/php-laminas-mail.spec b/php-laminas-mail.spec
index c6fb770..ee0f04e 100644
--- a/php-laminas-mail.spec
+++ b/php-laminas-mail.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-mail
+# remirepo/Fedora spec file for php-laminas-mail
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d7beb63d5f7144a21ac100072c453e63860cdab8
+%global gh_commit 019fb670c1dff6be7fc91d3b88942bd0a5f68792
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-mail
+%global gh_owner laminas
+%global gh_project laminas-mail
+%global zf_name zend-mail
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Mail
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.10.0
-Release: 6%{?dist}
-Summary: Zend Framework %{library} component
+Release: 1%{?dist}
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -42,48 +44,35 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5 with php-autoloader(%{gh_owner}/zend-loader) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-mime) >= 2.5 with php-autoloader(%{gh_owner}/zend-mime) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-BuildRequires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
-# remirepo:12
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.5 with php-autoloader(%{gh_owner}/laminas-mime) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.2 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
+# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-config": "^2.6",
+# "laminas/laminas-crypt": "^2.6 || ^3.0",
+# "laminas/laminas-servicemanager": "^2.7.10 || ^3.3.1",
+# "phpunit/phpunit": "^5.7.25 || ^6.4.4 || ^7.1.4"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.0 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+# remirepo:11
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-loader) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-mime) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-mime) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2
-BuildRequires: php-composer(true/punycode) >= 2.1
-BuildRequires: php-composer(true/punycode) < 3
+BuildRequires: php-laminas-loader
+BuildRequires: php-laminas-mime
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-validator
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-true-punycode
+BuildRequires: php-laminas-config
+BuildRequires: php-laminas-crypt
+BuildRequires: php-laminas-servicemanager
%endif
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.25 || ^6.4.4 || ^7.1.4",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-config": "^2.6",
-# "zendframework/zend-crypt": "^2.6 || ^3.0",
-# "zendframework/zend-servicemanager": "^2.7.10 || ^3.3.1"
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-config) >= 2.6 with php-autoloader(%{gh_owner}/zend-config) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-crypt) >= 2.6 with php-autoloader(%{gh_owner}/zend-crypt) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
BuildRequires: phpunit7 >= 7.1.4
%global phpunit %{_bindir}/phpunit7
-# remirepo:10
-%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-crypt) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-crypt) >= 2.6
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.10
-BuildRequires: phpunit6 >= 6.4.4
-%global phpunit %{_bindir}/phpunit6
-%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -91,68 +80,63 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "ext-iconv": "*",
-# "zendframework/zend-loader": "^2.5",
-# "zendframework/zend-mime": "^2.5",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0",
-# "zendframework/zend-validator": "^2.10.2",
+# "laminas/laminas-loader": "^2.5",
+# "laminas/laminas-mime": "^2.5",
+# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-validator": "^2.10.2",
+# "laminas/laminas-zendframework-bridge": "^1.0",
# "true/punycode": "^2.1"
Requires: php(language) >= 5.6
Requires: php-iconv
-%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5 with php-autoloader(%{gh_owner}/zend-loader) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-mime) >= 2.5 with php-autoloader(%{gh_owner}/zend-mime) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-Requires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
-# remirepo:12
-%else
-Requires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5
-Requires: php-autoloader(%{gh_owner}/zend-loader) < 3
-Requires: php-autoloader(%{gh_owner}/zend-mime) >= 2.5
-Requires: php-autoloader(%{gh_owner}/zend-mime) < 3
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.2
-Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
-Requires: php-composer(true/punycode) >= 2.1
-Requires: php-composer(true/punycode) < 3
-%endif
+Requires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-mime) >= 2.5 with php-autoloader(%{gh_owner}/laminas-mime) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.2 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+Requires: (php-composer(true/punycode) >= 2.1 with php-composer(true/punycode) < 3)
# From composer, "suggest": {
-# "ext-intl": "Handle IDN in AddressList hostnames",
-# "zendframework/zend-crypt": "Crammd5 support in SMTP Auth",
-# "zendframework/zend-servicemanager": "^2.7.10 || ^3.3.1 when using SMTP to deliver messages"
-# remirepo:1
-%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
-Suggests: php-intl
-Suggests: php-autoloader(%{gh_owner}/zend-crypt)
-Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
-# remirepo:1
-%endif
+# "laminas/laminas-crypt": "Crammd5 support in SMTP Auth",
+# "laminas/laminas-servicemanager": "^2.7.10 || ^3.3.1 when using SMTP to deliver messages"
+Suggests: php-autoloader(%{gh_owner}/laminas-crypt)
+Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
+# From phpcompatinfo report
+Recommends: php-imap
+# remirepo:8
+%else
+Requires: php-laminas-loader
+Requires: php-laminas-mime
+Requires: php-laminas-stdlib
+Requires: php-laminas-validator
+Requires: php-laminas-zendframework-bridge
+Requires: php-true-punycode
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.8.0
+# From phpcompatinfo report for version 2.10.0
Requires: php-ctype
Requires: php-date
Requires: php-pcre
Requires: php-spl
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.10.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\Mail provides generalized functionality to compose and send both text
-and MIME-compliant multipart email messages. Mail can be sent with Zend\Mail
+%{namespace}\Mail provides generalized functionality to compose and send both text
+and MIME-compliant multipart email messages. Mail can be sent with %{namespace}\Mail
via the Mail\Transport\Sendmail, Mail\Transport\Smtp or the
Mail\Transport\File transport. Of course, you can also implement your own
transport by implementing the Mail\Transport\TransportInterface.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -163,34 +147,40 @@ mv LICENSE.md LICENSE
%build
-: Create dependency autoloader - deprecated
-cat << 'EOF' | tee autoload.php
-<?php
-require_once '%{php_home}/TrueBV/autoload.php';
-EOF
-
: Create autoloader
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Loader/autoload.php',
- '%{php_home}/Zend/Mime/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/%{namespace}/Loader/autoload.php',
+ '%{php_home}/%{namespace}/Mime/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
'%{php_home}/TrueBV/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/ServiceManager/autoload.php',
- '%{php_home}/Zend/Crypt/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Crypt/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
-install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -198,15 +188,22 @@ install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Config/autoload.php',
+ '%{php_home}/%{namespace}/Config/autoload.php',
]);
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\Message") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} \
@@ -226,10 +223,13 @@ exit $ret
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
-%{php_home}/Zend/%{library}-autoload.php
+%{php_home}/%{namespace}/%{library}
%changelog
+* Thu Jan 9 2020 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- switch to Laminas
+
* Wed Oct 9 2019 Remi Collet <remi@remirepo.net> - 2.10.0-6
- add patch for PHP 7.4 from
https://github.com/zendframework/zend-mail/pull/244