summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-23 10:25:01 +0100
committerRemi Collet <remi@remirepo.net>2020-11-23 10:25:01 +0100
commit765b43b957781a2c3aadf215ab6d02a8259c8de3 (patch)
tree9db9d21cb1030262ce7d66f70d7559f22720e162
parent9777b0ce2f96a9a7f54e7d1d1572c72b9fbea47b (diff)
update to 2.13.0
raise dependency on PHP 7.3 raise dependency on zend-servicemanager 3.3 switch to phpunit9
-rw-r--r--composer.json15
-rw-r--r--php-laminas-log.spec45
2 files changed, 34 insertions, 26 deletions
diff --git a/composer.json b/composer.json
index 9ebd529..46940f8 100644
--- a/composer.json
+++ b/composer.json
@@ -20,19 +20,15 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.12.x-dev",
- "dev-develop": "2.13.x-dev"
- },
"laminas": {
"component": "Laminas\\Log",
"config-provider": "Laminas\\Log\\ConfigProvider"
}
},
"require": {
- "php": "^5.6 || ^7.0",
- "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "php": "^7.3 || ~8.0.0",
+ "laminas/laminas-servicemanager": "^3.3.0",
+ "laminas/laminas-stdlib": "^3.0",
"laminas/laminas-zendframework-bridge": "^1.0",
"psr/log": "^1.1.2"
},
@@ -44,7 +40,8 @@
"laminas/laminas-mail": "^2.6.1",
"laminas/laminas-validator": "^2.10.1",
"mikey179/vfsstream": "^1.6.7",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.15"
+ "phpspec/prophecy-phpunit": "^2.0",
+ "phpunit/phpunit": "^9.4.1"
},
"provide": {
"psr/log-implementation": "1.0.0"
@@ -81,6 +78,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-log": "self.version"
+ "zendframework/zend-log": "^2.12.0"
}
}
diff --git a/php-laminas-log.spec b/php-laminas-log.spec
index 976950c..173acb2 100644
--- a/php-laminas-log.spec
+++ b/php-laminas-log.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4e92d841b48868714a070b10866e94be80fc92ff
+%global gh_commit 71bb2c98e0286c447488e71290ecf0beb44e6ca5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-log
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.12.0
+Version: 2.13.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-dom
@@ -43,7 +43,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-composer(psr/log) >= 1.1.2 with php-composer(psr/log) < 2)
@@ -55,28 +55,31 @@ BuildRequires: (php-composer(psr/log) >= 1.1.
# "laminas/laminas-mail": "^2.6.1",
# "laminas/laminas-validator": "^2.10.1",
# "mikey179/vfsstream": "^1.6.7",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.15"
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.4.1"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.6 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-escaper) >= 2.5 with php-autoloader(%{gh_owner}/laminas-escaper) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.5 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-mail) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-mail) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-composer(mikey179/vfsstream) >= 1.6.6 with php-composer(mikey179/vfsstream) < 2)
-# remirepo:8
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:13
%else
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-PsrLog
BuildRequires: php-mikey179-vfsstream
+BuildRequires: php-phpspec-prophecy-phpunit
BuildRequires: php-laminas-db
BuildRequires: php-laminas-escaper
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-mail
BuildRequires: php-laminas-validator
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.15
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.4.1
# Optional dep
BuildRequires: php-autoloader(%{gh_owner}/laminas-mime) >= 2.5
%endif
@@ -84,16 +87,16 @@ BuildRequires: php-autoloader(%{gh_owner}/laminas-mime) >= 2.5
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "php": "^7.3 || ~8.0.0",
+# "laminas/laminas-servicemanager": "^3.3.0",
+# "laminas/laminas-stdlib": "^3.0",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/log": "^1.1.2"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
Requires: (php-composer(psr/log) >= 1.1.2 with php-composer(psr/log) < 2)
@@ -129,11 +132,12 @@ Requires: php-pcre
Requires: php-spl
# mongo is optional
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.12.0-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.12.1
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -201,6 +205,7 @@ require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/org/bovigo/vfs/autoload.php',
'%{php_home}/%{namespace}/Filter/autoload.php',
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
@@ -218,10 +223,10 @@ exit (class_exists("\\Zend\\%{library}\\Logger") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} || ret=1
fi
done
exit $ret
@@ -241,6 +246,12 @@ exit $ret
%changelog
+* Mon Nov 23 2020 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- raise dependency on PHP 7.3
+- raise dependency on zend-servicemanager 3.3
+- switch to phpunit9
+
* Wed Jan 15 2020 Remi Collet <remi@remirepo.net> - 2.12.0-1
- switch to Laminas