summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json16
-rw-r--r--php-laminas-ldap.spec28
2 files changed, 26 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index d0434be..6e682a5 100644
--- a/composer.json
+++ b/composer.json
@@ -21,17 +21,18 @@
"extra": {
},
"require": {
- "php": "^7.3 || ~8.0.0",
- "ext-ldap": "*",
- "laminas/laminas-zendframework-bridge": "^1.1"
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "ext-ldap": "*"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-config": "^3.4",
+ "laminas/laminas-config": "^3.7.0",
"laminas/laminas-eventmanager": "^3.3",
"laminas/laminas-stdlib": "^3.3",
"php-mock/php-mock-phpunit": "^2.6",
- "phpunit/phpunit": "^9.5.0"
+ "phpunit/phpunit": "^9.5.8",
+ "psalm/plugin-phpunit": "^0.16.1",
+ "vimeo/psalm": "^4.13.1"
},
"suggest": {
"laminas/laminas-eventmanager": "Laminas\\EventManager component"
@@ -53,10 +54,11 @@
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-ldap": "^2.10.1"
+ "conflict": {
+ "zendframework/zend-ldap": "*"
}
}
diff --git a/php-laminas-ldap.spec b/php-laminas-ldap.spec
index 7af3633..4918003 100644
--- a/php-laminas-ldap.spec
+++ b/php-laminas-ldap.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c1370452cd6548e103fb181d8e6e1fca9954dba4
+%global gh_commit b07b8714363d5acb82af74efb9e96d5436e1b044
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-ldap
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.11.0
+Version: 2.12.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -41,25 +41,27 @@ BuildRequires: php-ldap
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^3.4",
+# "laminas/laminas-config": "^3.7.0",
# "laminas/laminas-eventmanager": "^3.3",
# "laminas/laminas-stdlib": "^3.3",
# "php-mock/php-mock-phpunit": "^2.6",
-# "phpunit/phpunit": "^9.5.0"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+# "phpunit/phpunit": "^9.5.8",
+# "psalm/plugin-phpunit": "^0.16.1",
+# "vimeo/psalm": "^4.13.1"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.7 with php-autoloader(%{gh_owner}/laminas-config) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.6 with php-composer(php-mock/php-mock-phpunit) < 3)
# remirepo:7
%else
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-config
+BuildRequires: php-laminas-config3
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-mock-phpunit2
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.0
+BuildRequires: phpunit9 >= 9.5.8
BuildRequires: php-date
BuildRequires: php-iconv
BuildRequires: php-json
@@ -71,9 +73,8 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "ext-ldap": "*",
-# "laminas/laminas-zendframework-bridge": "^1.1"
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "ext-ldap": "*"
Requires: php(language) >= 7.3
Requires: php-ldap
# remirepo:1
@@ -174,7 +175,7 @@ exit (class_exists("\\Zend\\%{library}\\Ldap") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} || ret=1
@@ -197,6 +198,11 @@ exit $ret
%changelog
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
* Wed Jan 13 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
- update to 2.11.0
- raise dependency on PHP 7.3