summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json18
-rw-r--r--php-laminas-ldap.spec45
2 files changed, 35 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index d6d5707..fbbf681 100644
--- a/composer.json
+++ b/composer.json
@@ -20,25 +20,25 @@
"dealerdirect/phpcodesniffer-composer-installer": true
},
"platform": {
- "php": "7.4.99"
+ "php": "8.0.99"
},
"sort-packages": true
},
"extra": {
},
"require": {
- "php": "^7.4 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"ext-ldap": "*"
},
"require-dev": {
"laminas/laminas-coding-standard": "~2.4.0",
- "laminas/laminas-config": "^3.7.0",
- "laminas/laminas-eventmanager": "^3.4.0",
- "laminas/laminas-stdlib": "^3.7.1",
- "php-mock/php-mock-phpunit": "^2.6.0",
- "phpunit/phpunit": "^9.5.19",
- "psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.22.0"
+ "laminas/laminas-config": "^3.8.0",
+ "laminas/laminas-eventmanager": "^3.6.0",
+ "laminas/laminas-stdlib": "^3.15.0",
+ "php-mock/php-mock-phpunit": "^2.6.1",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.0",
+ "vimeo/psalm": "^5.0.0"
},
"suggest": {
"laminas/laminas-eventmanager": "Laminas\\EventManager component"
diff --git a/php-laminas-ldap.spec b/php-laminas-ldap.spec
index 87d6994..05dc545 100644
--- a/php-laminas-ldap.spec
+++ b/php-laminas-ldap.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e21bf1177b2cbdae57f75355a8fd0774438a42d2
+%global gh_commit cb66c477ec2fd2a7f38527c59d0635a9166b6597
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-ldap
@@ -22,11 +22,11 @@
%endif
Name: php-%{gh_project}
-Version: 2.15.0
+Version: 2.17.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -34,24 +34,24 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-ldap
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.4.0",
-# "laminas/laminas-config": "^3.7.0",
-# "laminas/laminas-eventmanager": "^3.4.0",
-# "laminas/laminas-stdlib": "^3.7.1",
-# "php-mock/php-mock-phpunit": "^2.6.0",
-# "phpunit/phpunit": "^9.5.19",
-# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.22.0"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.7 with php-autoloader(%{gh_owner}/laminas-config) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.7.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
-BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.6.0 with php-composer(php-mock/php-mock-phpunit) < 3)
+# "laminas/laminas-config": "^3.8.0",
+# "laminas/laminas-eventmanager": "^3.6.0",
+# "laminas/laminas-stdlib": "^3.15.0",
+# "php-mock/php-mock-phpunit": "^2.6.1",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.0",
+# "vimeo/psalm": "^5.0.0"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.8 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.6 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.15 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-composer(php-mock/php-mock-phpunit) >= 2.6.1 with php-composer(php-mock/php-mock-phpunit) < 3)
# remirepo:7
%else
BuildRequires: php-laminas-zendframework-bridge
@@ -61,7 +61,7 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-mock-phpunit2
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.19
+BuildRequires: phpunit9 >= 9.5.25
BuildRequires: php-date
BuildRequires: php-iconv
BuildRequires: php-json
@@ -73,9 +73,9 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "ext-ldap": "*"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
Requires: php-ldap
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -175,7 +175,7 @@ exit (class_exists("\\Zend\\%{library}\\Ldap") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} || ret=1
@@ -198,6 +198,13 @@ exit $ret
%changelog
+* Wed Dec 21 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+
+* Mon Oct 24 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
+- update to 2.16.0
+- raise dependency on PHP 8.0
+
* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 2.15.0-1
- update to 2.15.0