summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json7
-rw-r--r--php-laminas-json-server.spec11
2 files changed, 12 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 41e9073..34f6a29 100644
--- a/composer.json
+++ b/composer.json
@@ -21,7 +21,10 @@
"allow-plugins": {
"dealerdirect/phpcodesniffer-composer-installer": true
},
- "sort-packages": true
+ "sort-packages": true,
+ "platform": {
+ "php": "7.4.99"
+ }
},
"require": {
"php": "^7.4 || ~8.0.0 || ~8.1.0",
@@ -33,7 +36,7 @@
"ext-json": "*",
"laminas/laminas-coding-standard": "^2.3",
"phpunit/phpunit": "^9.5.11",
- "psalm/plugin-phpunit": "^0.16.1",
+ "psalm/plugin-phpunit": "^0.17.0",
"vimeo/psalm": "^4.18.0"
},
"conflict": {
diff --git a/php-laminas-json-server.spec b/php-laminas-json-server.spec
index 28c8797..ccab492 100644
--- a/php-laminas-json-server.spec
+++ b/php-laminas-json-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f8e12c6973d396e56c6c2099093aaddb6e709145
+%global gh_commit 3768ee566399572da524e2e0930624bbc143b016
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-json-server
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.5.0
+Version: 3.6.0
Release: 1%{?dist}
Summary: %{namespace} Json-Server is a JSON-RPC server implementation
@@ -49,7 +49,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "ext-json": "*",
# "laminas/laminas-coding-standard": "^2.3",
# "phpunit/phpunit": "^9.5.11",
-# "psalm/plugin-phpunit": "^0.16.1",
+# "psalm/plugin-phpunit": "^0.17.0",
# "vimeo/psalm": "^4.18.0"
# remirepo:6
%else
@@ -161,7 +161,7 @@ exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Response") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
@@ -184,6 +184,9 @@ exit $ret
%changelog
+* Tue Sep 20 2022 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0
+
* Fri Feb 4 2022 Remi Collet <remi@remirepo.net> - 3.5.0-1
- update to 3.5.0