summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-04 14:07:10 +0100
committerRemi Collet <remi@php.net>2022-02-04 14:07:10 +0100
commitf5a0a8a52950d6507854a8288d9d87e6f6924519 (patch)
tree4250c36da068a0e57465f74ee6b2f692803a570a
parent930ca23816602a0a097c5b24db39aa29dd6250f2 (diff)
update to 3.5.0
-rw-r--r--composer.json7
-rw-r--r--php-laminas-json-server.spec11
2 files changed, 12 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index ba53418..41e9073 100644
--- a/composer.json
+++ b/composer.json
@@ -18,17 +18,20 @@
"forum": "https://discourse.laminas.dev"
},
"config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ },
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.4 || ~8.0.0 || ~8.1.0",
"laminas/laminas-http": "^2.15.1",
"laminas/laminas-json": "^3.3.0",
"laminas/laminas-server": "^2.11.0"
},
"require-dev": {
"ext-json": "*",
- "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-coding-standard": "^2.3",
"phpunit/phpunit": "^9.5.11",
"psalm/plugin-phpunit": "^0.16.1",
"vimeo/psalm": "^4.18.0"
diff --git a/php-laminas-json-server.spec b/php-laminas-json-server.spec
index 4178329..28c8797 100644
--- a/php-laminas-json-server.spec
+++ b/php-laminas-json-server.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 436b1375d3fd6ea58919881d9ec9d3652156ef24
+%global gh_commit f8e12c6973d396e56c6c2099093aaddb6e709145
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-json-server
@@ -23,7 +23,7 @@
%endif
Name: php-%{gh_project}
-Version: 3.4.0
+Version: 3.5.0
Release: 1%{?dist}
Summary: %{namespace} Json-Server is a JSON-RPC server implementation
@@ -47,7 +47,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.11
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "ext-json": "*",
-# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-coding-standard": "^2.3",
# "phpunit/phpunit": "^9.5.11",
# "psalm/plugin-phpunit": "^0.16.1",
# "vimeo/psalm": "^4.18.0"
@@ -66,7 +66,7 @@ BuildRequires: phpunit9 >= 9.5.11
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-http": "^2.15.1",
# "laminas/laminas-json": "^3.3.0",
# "laminas/laminas-server": "^2.11.0",
@@ -184,6 +184,9 @@ exit $ret
%changelog
+* Fri Feb 4 2022 Remi Collet <remi@remirepo.net> - 3.5.0-1
+- update to 3.5.0
+
* Mon Jan 10 2022 Remi Collet <remi@remirepo.net> - 3.4.0-1
- update to 3.4.0
- raise dependency on laminas-http 2.15.1