summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-10 14:50:41 +0100
committerRemi Collet <remi@remirepo.net>2020-01-10 14:50:41 +0100
commit1864fa30c0c8e2b8e65c0397fb67ddb7fee5ed2c (patch)
tree13ed528539134873457640e6ce41d723053a3382
parente11eb22244b4c6d8a0d756e0652ee73aa4a74b93 (diff)
switch to Laminas
-rw-r--r--composer.json62
-rw-r--r--php-laminas-json-server.spec132
2 files changed, 113 insertions, 81 deletions
diff --git a/composer.json b/composer.json
index 9d99e7b..a569100 100644
--- a/composer.json
+++ b/composer.json
@@ -1,55 +1,56 @@
{
- "name": "zendframework/zend-json-server",
- "description": "Zend Json-Server is a JSON-RPC server implementation.",
+ "name": "laminas/laminas-json-server",
+ "description": "Laminas Json-Server is a JSON-RPC server implementation.",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zendframework",
+ "laminas",
"json",
"server",
"json-server"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-json-server/",
- "issues": "https://github.com/zendframework/zend-json-server/issues",
- "source": "https://github.com/zendframework/zend-json-server",
- "rss": "https://github.com/zendframework/zend-json-server/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-json-server/",
+ "issues": "https://github.com/laminas/laminas-json-server/issues",
+ "source": "https://github.com/laminas/laminas-json-server",
+ "rss": "https://github.com/laminas/laminas-json-server/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.2.x-dev",
+ "dev-develop": "3.3.x-dev"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-http": "^2.7",
- "zendframework/zend-json": "^2.6.1 || ^3.0",
- "zendframework/zend-server": "^2.7"
+ "laminas/laminas-http": "^2.7",
+ "laminas/laminas-json": "^2.6.1 || ^3.0",
+ "laminas/laminas-server": "^2.7",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
- "zendframework/zend-coding-standard": "~1.0.0"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
+ },
+ "conflict": {
+ "laminas/laminas-stdlib": "<3.2.1"
},
"autoload": {
"psr-4": {
- "Zend\\Json\\Server\\": "src/"
+ "Laminas\\Json\\Server\\": "src/"
}
},
- "conflict": {
- "zendframework/zend-stdlib": "<3.2.1"
- },
"autoload-dev": {
"files": [
"test/TestAsset/FooFunc.php"
],
"psr-4": {
- "ZendTest\\Json\\Server\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "3.2.x-dev",
- "dev-develop": "3.3.x-dev"
+ "LaminasTest\\Json\\Server\\": "test/"
}
},
"scripts": {
@@ -61,5 +62,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-json-server": "self.version"
}
}
diff --git a/php-laminas-json-server.spec b/php-laminas-json-server.spec
index 74dd66e..c89f1e3 100644
--- a/php-laminas-json-server.spec
+++ b/php-laminas-json-server.spec
@@ -1,31 +1,34 @@
-# remirepo/Fedora spec file for php-zendframework-zend-json-server
+# remirepo/Fedora spec file for php-laminas-json-server
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit c87b943237b87fca1f06c5a80389ba42ab69bc8b
+%global gh_commit f3e9c1488dd7588d3fe808be5cf53999166fb29d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-json-server
+%global gh_owner laminas
+%global gh_project laminas-json-server
+%global zf_name zend-json-server
%global php_home %{_datadir}/php
-%global library Server
+%global namespace Laminas
+%global library Json
+%global subproj Server
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
%else
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 3.2.0
Release: 1%{?dist}
-Summary: Zend Json-Server is a JSON-RPC server implementation
+Summary: %{namespace} Json-Server is a JSON-RPC server implementation
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -36,68 +39,68 @@ BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
-# "zendframework/zend-coding-standard": "~1.0.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.7 with php-autoloader(%{gh_owner}/zend-http) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 3.0 with php-autoloader(%{gh_owner}/zend-json) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-server) >= 2.7 with php-autoloader(%{gh_owner}/zend-server) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.7 with php-autoloader(%{gh_owner}/laminas-server) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2"
# remirepo:10
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 3.0
-BuildRequires: php-autoloader(%{gh_owner}/zend-server) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-server) >= 2.7
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-http
+BuildRequires: php-laminas-json
+BuildRequires: php-laminas-server
+BuildRequires: php-laminas-zendframework-bridge
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-http": "^2.7",
-# "zendframework/zend-json": "^2.6.1 || ^3.0",
-# "zendframework/zend-server": "^2.7"
+# "laminas/laminas-http": "^2.7",
+# "laminas/laminas-json": "^2.6.1 || ^3.0",
+# "laminas/laminas-server": "^2.7",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
-# Require zend-json 3.0.0 as conflicts with previous
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-http) >= 2.7 with php-autoloader(%{gh_owner}/zend-http) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-json) >= 3.0 with php-autoloader(%{gh_owner}/zend-json) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-server) >= 2.7 with php-autoloader(%{gh_owner}/zend-server) < 4)
-# remirepo:8
+Requires: (php-autoloader(%{gh_owner}/laminas-http) >= 2.7 with php-autoloader(%{gh_owner}/laminas-http) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-json) >= 3.0 with php-autoloader(%{gh_owner}/laminas-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-server) >= 2.7 with php-autoloader(%{gh_owner}/laminas-server) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:6
%else
-Requires: php-autoloader(%{gh_owner}/zend-http) < 3
-Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
-Requires: php-autoloader(%{gh_owner}/zend-json) < 4
-Requires: php-autoloader(%{gh_owner}/zend-json) >= 3.0
-Requires: php-autoloader(%{gh_owner}/zend-server) < 4
-Requires: php-autoloader(%{gh_owner}/zend-server) >= 2.7
+Requires: php-laminas-http
+Requires: php-laminas-json
+Requires: php-laminas-server
+Requires: php-laminas-zendframework-bridge
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 3.0.0
+# From phpcompatinfo report for version 3.2.0
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 3.2.0-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
Provides a JSON-RPC server implementation.
-* File issues at https://github.com/zendframework/zend-json-server/issues
-* Documentation is at http://framework.zend.com/manual/current/en/index.html#zend-json-server
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -111,16 +114,30 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Json/autoload.php',
- '%{php_home}/Zend/Http/autoload.php',
- '%{php_home}/Zend/Server/autoload.php',
+ '%{php_home}/%{namespace}/Json/autoload.php',
+ '%{php_home}/%{namespace}/Http/autoload.php',
+ '%{php_home}/%{namespace}/Server/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(dirname(__DIR__))) . '/%{namespace}/%{library}/%{subproj}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/Json
-cp -pr src %{buildroot}%{php_home}/Zend/Json/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/%{library}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}/%{subproj}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/%{subproj}/autoload.php
%check
@@ -128,13 +145,20 @@ cp -pr src %{buildroot}%{php_home}/Zend/Json/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/Json/%{library}/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\Json\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/%{subproj}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\%{subproj}\\', dirname(__DIR__) . '/test');
require_once __DIR__ . '/../test/TestAsset/FooFunc.php';
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/%{subproj}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\%{subproj}\\Response") ? 0 : 1);
+'
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
@@ -152,10 +176,14 @@ exit $ret
%license LICENSE
%doc *.md
%doc composer.json
-%{php_home}/Zend/Json/%{library}
+%{php_home}/Zend/%{library}/%{subproj}
+%{php_home}/%{namespace}/%{library}/%{subproj}
%changelog
+* Fri Jan 10 2020 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- switch to Laminas
+
* Fri Oct 18 2019 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0 (no change)