summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-16 12:16:03 +0200
committerRemi Collet <remi@php.net>2022-06-16 12:16:03 +0200
commitfcd591d4ac6939d6c54fb4a5ecee268c6381e919 (patch)
treec0eaf02f104029ccd15ba76340bdf4acab00e407
parentb7c967540aa4ed05c5aff8eaa88854d15481d661 (diff)
update to 2.17.0
raise dependency on zend-servicemanager 3.12
-rw-r--r--composer.json2
-rw-r--r--php-laminas-inputfilter.spec14
2 files changed, 10 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 6d8ae2c..a881ba1 100644
--- a/composer.json
+++ b/composer.json
@@ -33,7 +33,7 @@
"require": {
"php": "^7.4 || ~8.0.0 || ~8.1.0",
"laminas/laminas-filter": "^2.13",
- "laminas/laminas-servicemanager": "^3.3.1",
+ "laminas/laminas-servicemanager": "^3.12.0",
"laminas/laminas-stdlib": "^3.0",
"laminas/laminas-validator": "^2.15"
},
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index 1608d33..742367c 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 61381caf7d6423bbe15aecca60d8336100977a88
+%global gh_commit a6e8bc751c321bae1b3f8e235eeb4871256a6009
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.16.0
+Version: 2.17.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -39,7 +39,7 @@ BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -75,7 +75,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^7.4 || ~8.0.0 || ~8.1.0",
# "laminas/laminas-filter": "^2.13",
-# "laminas/laminas-servicemanager": "^3.3.1",
+# "laminas/laminas-servicemanager": "^3.12.0",
# "laminas/laminas-stdlib": "^3.0",
# "laminas/laminas-validator": "^2.15"
Requires: php(language) >= 7.3
@@ -83,7 +83,7 @@ Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.13 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.12.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -206,6 +206,10 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+- raise dependency on zend-servicemanager 3.12
+
* Fri Jun 10 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
- update to 2.16.0