summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-01 11:28:21 +0100
committerRemi Collet <remi@remirepo.net>2020-12-01 11:28:21 +0100
commitb69132b4324b3ea5ce64ca151d5dde472f83bfab (patch)
treef7156c1fd27b2d5cd6ca29bdba329a6b571f7559
parent1b69f7b9f0b21221740a4ac644a3e8181cffec7b (diff)
update to 2.11.0 (no change)
raise dependency on PHP 7.3 switch to phpunit9 with phpspec/prophecy-phpunit
-rw-r--r--composer.json15
-rw-r--r--php-laminas-inputfilter.spec43
2 files changed, 33 insertions, 25 deletions
diff --git a/composer.json b/composer.json
index fe92618..bcc5e4d 100644
--- a/composer.json
+++ b/composer.json
@@ -19,26 +19,23 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "2.10.x-dev",
- "dev-develop": "2.11.x-dev"
- },
"laminas": {
"component": "Laminas\\InputFilter",
"config-provider": "Laminas\\InputFilter\\ConfigProvider"
}
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-filter": "^2.9.1",
- "laminas/laminas-servicemanager": "^2.7.10 || ^3.3.1",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "laminas/laminas-servicemanager": "^3.3.1",
+ "laminas/laminas-stdlib": "^3.0",
"laminas/laminas-validator": "^2.11",
"laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.15",
+ "phpspec/prophecy-phpunit": "^2.0",
+ "phpunit/phpunit": "^9.4.2",
"psr/http-message": "^1.0"
},
"suggest": {
@@ -65,6 +62,6 @@
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
"replace": {
- "zendframework/zend-inputfilter": "self.version"
+ "zendframework/zend-inputfilter": "^2.10.1"
}
}
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index e74a362..091c9bb 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit b29ce8f512c966468eee37ea4873ae5fb545d00a
+%global gh_commit 34ed067ae366a2171d6d174a04002e4eb17c166d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.10.1
-Release: 2%{?dist}
+Version: 2.11.0
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-spl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -45,10 +45,12 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.11
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.15",
+# "phpspec/prophecy-phpunit": "^2.0",
+# "phpunit/phpunit": "^9.4.2",
# "psr/http-message": "^1.0"
-BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
-# remirepo:10
+BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
+# remirepo:9
%else
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-servicemanager
@@ -56,20 +58,21 @@ BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-psr-http-message
+BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit7 >= 7.5
+BuildRequires: phpunit9 >= 9.4.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-filter": "^2.9.1",
-# "laminas/laminas-servicemanager": "^2.7.10 || ^3.3.1",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-servicemanager": "^3.3.1",
+# "laminas/laminas-stdlib": "^3.0",
# "laminas/laminas-validator": "^2.11",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -96,8 +99,8 @@ Requires: php-spl
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.10.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.10.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -158,6 +161,9 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Prophecy/PhpUnit/autoload.php',
+]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -169,9 +175,9 @@ exit (class_exists("\\Zend\\%{library}\\Input") ? 0 : 1);
: upstream test suite
ret=0
-for cmd in php php72 php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{_bindir}/phpunit7 \
+ $cmd %{_bindir}/phpunit9 \
--filter '^((?!(testProvidesExpectedConfiguration)).)*$' \
--verbose || ret=1
fi
@@ -192,6 +198,11 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Tue Dec 1 2020 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0 (no change)
+- raise dependency on PHP 7.3
+- switch to phpunit9 with phpspec/prophecy-phpunit
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.10.1-2
- cleanup