summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-21 10:36:08 +0200
committerRemi Collet <remi@php.net>2022-07-21 10:36:08 +0200
commit988a9b769d5e4b6fb6688c8f8e45510f80c18887 (patch)
treeecbfe1488d5257acc0eb64071c233e9b42a788bb
parentee11a80488019a46fe80170fadc440c58b4f478c (diff)
update to 2.19.0
-rw-r--r--composer.json10
-rw-r--r--php-laminas-inputfilter.spec26
2 files changed, 15 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index a881ba1..d77041e 100644
--- a/composer.json
+++ b/composer.json
@@ -38,14 +38,12 @@
"laminas/laminas-validator": "^2.15"
},
"require-dev": {
- "laminas/laminas-coding-standard": "~2.2.1",
+ "laminas/laminas-coding-standard": "~2.3.0",
"laminas/laminas-db": "^2.13.4",
- "phpspec/prophecy": "^1.14",
- "phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.5.5",
- "psalm/plugin-phpunit": "^0.15.1",
+ "phpunit/phpunit": "^9.5.21",
+ "psalm/plugin-phpunit": "^0.17.0",
"psr/http-message": "^1.0",
- "vimeo/psalm": "^4.6"
+ "vimeo/psalm": "^4.24.0"
},
"suggest": {
"psr/http-message-implementation": "PSR-7 is required if you wish to validate PSR-7 UploadedFileInterface payloads"
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index a83d200..b52d306 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9b0c514b5807c964cd1121bb1f31bb894a923219
+%global gh_commit f570c504bbecf81eda13e2cee45c1e945d07f1ec
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.18.1
+Version: 2.19.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -44,19 +44,15 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.2.1",
+# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-db": "^2.13.4",
-# "phpspec/prophecy": "^1.14",
-# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.4.2",
-# "psalm/plugin-phpunit": "^0.15.1",
+# "phpunit/phpunit": "^9.5.21",
+# "psalm/plugin-phpunit": "^0.17.0",
# "psr/http-message": "^1.0",
-# "vimeo/psalm": "^4.6"
+# "vimeo/psalm": "^4.24.0"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.13.4 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
-BuildRequires: (php-composer(phpspec/prophecy) >= 1.14 with php-composer(phpspec/prophecy) < 2)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:10
+# remirepo:9
%else
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-servicemanager
@@ -65,9 +61,8 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-db
BuildRequires: php-psr-http-message
-BuildRequires: php-phpspec-prophecy-phpunit
%endif
-BuildRequires: phpunit9 >= 9.4.2
+BuildRequires: phpunit9 >= 9.5.21
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -169,8 +164,6 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/%{namespace}/Db/autoload.php',
- '%{php_home}/Prophecy/autoload.php',
- '%{php_home}/Prophecy/PhpUnit/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -206,6 +199,9 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Thu Jul 21 2022 Remi Collet <remi@remirepo.net> - 2.19.0-1
+- update to 2.19.0
+
* Wed Jul 20 2022 Remi Collet <remi@remirepo.net> - 2.18.1-1
- update to 2.18.1