summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-17 10:02:25 +0100
committerRemi Collet <remi@remirepo.net>2021-03-17 10:02:25 +0100
commit53722cb7d4ed76dc50f6e6cf76c3b6dcd07dfc38 (patch)
tree8cc640adbbdd268958fce6853f4a508791b8d1ea
parent2947b28670b7064c3c3a4cffccfcfa19fb6992ad (diff)
update to 2.12.0 (no change)
-rw-r--r--composer.json8
-rw-r--r--php-laminas-inputfilter.spec16
2 files changed, 18 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index bcc5e4d..2497bc2 100644
--- a/composer.json
+++ b/composer.json
@@ -34,9 +34,12 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-db": "^2.12",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.4.2",
- "psr/http-message": "^1.0"
+ "psalm/plugin-phpunit": "^0.15.1",
+ "psr/http-message": "^1.0",
+ "vimeo/psalm": "^4.6"
},
"suggest": {
"psr/http-message-implementation": "PSR-7 is required if you wish to validate PSR-7 UploadedFileInterface payloads"
@@ -59,7 +62,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"replace": {
"zendframework/zend-inputfilter": "^2.10.1"
diff --git a/php-laminas-inputfilter.spec b/php-laminas-inputfilter.spec
index 791866a..c6f930c 100644
--- a/php-laminas-inputfilter.spec
+++ b/php-laminas-inputfilter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d44ed39a2f929742a7b204ffac2fa516aef84aab
+%global gh_commit b6ab28b425e626b12488fec243e02d36d8dffeff
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-inputfilter
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.11.1
+Version: 2.12.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -45,18 +45,23 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.11
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-db": "^2.12",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.4.2",
-# "psr/http-message": "^1.0"
+# "psalm/plugin-phpunit": "^0.15.1",
+# "psr/http-message": "^1.0",
+# "vimeo/psalm": "^4.6"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-db) >= 2.12 with php-autoloader(%{gh_owner}/laminas-db) < 3)
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-# remirepo:9
+# remirepo:10
%else
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-servicemanager
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-db
BuildRequires: php-psr-http-message
BuildRequires: php-phpspec-prophecy-phpunit
%endif
@@ -198,6 +203,9 @@ exit $ret
%{php_home}/%{namespace}/%{library}
%changelog
+* Wed Mar 17 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0 (no change)
+
* Tue Mar 16 2021 Remi Collet <remi@remirepo.net> - 2.11.1-1
- update to 2.11.1 (no change)