summaryrefslogtreecommitdiffstats
path: root/php-laminas-i18n.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-26 07:40:23 +0100
committerRemi Collet <remi@remirepo.net>2020-10-26 07:40:23 +0100
commitea3167fcb7d14e0b45d3441f025a59031205fd21 (patch)
tree3b910c47b565099bb6bb76a19e3f3ba0d303e107 /php-laminas-i18n.spec
parent1ae5f1a04559e2b7880c1662df390c1844ed1629 (diff)
update to 2.11.0
raise dependency on PHP 7.3
Diffstat (limited to 'php-laminas-i18n.spec')
-rw-r--r--php-laminas-i18n.spec30
1 files changed, 17 insertions, 13 deletions
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index 0fa31fc..414723f 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -8,7 +8,7 @@
#
# When buid without config, filter, validator an view
%global bootstrap 0
-%global gh_commit 94ff957a1366f5be94f3d3a9b89b50386649e3ae
+%global gh_commit 85678f444b6dcb48e8a04591779e11c24e5bb901
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.10.3
+Version: 2.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -31,7 +31,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-intl
@@ -43,17 +43,17 @@ BuildRequires: php-spl
# "laminas/laminas-config": "^2.6",
# "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
# "laminas/laminas-filter": "^2.6.1",
-# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-servicemanager": "^3.2.1",
# "laminas/laminas-validator": "^2.6",
# "laminas/laminas-view": "^2.6.3",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16"
+# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
%if ! %{bootstrap}
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.5 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
@@ -74,18 +74,18 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-view
%endif
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.16
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "ext-intl": "*",
# "laminas/laminas-stdlib": "^2.7 || ^3.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
Requires: php-intl
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -126,7 +126,7 @@ Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
Obsoletes: php-zendframework-%{zf_name} < 2.10.2
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -216,10 +216,10 @@ rm -rf test/Validator/
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} \
+ $1 ${2:-%{_bindir}/phpunit9} \
%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
--filter '^((?!(testSettersProvideDefaults|testBasic)).)*$' \
%endif
@@ -243,6 +243,10 @@ exit $ret
%changelog
+* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- raise dependency on PHP 7.3
+
* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 2.10.3-1
- update to 2.10.3 (no change)