summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-29 09:30:47 +0100
committerRemi Collet <remi@php.net>2021-11-29 09:30:47 +0100
commitc6bb11f4b6ab9fa52647529910143d790e00e26e (patch)
treee1971ff67210bdc6365a52ef091a81719dc46c67
parent9729a3cc3a0fb15958c0ae92ccb01cded7e0dcda (diff)
update to 2.12.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader
-rw-r--r--composer.json29
-rw-r--r--php-laminas-i18n.spec52
2 files changed, 46 insertions, 35 deletions
diff --git a/composer.json b/composer.json
index 7e3f4cd..82631cc 100644
--- a/composer.json
+++ b/composer.json
@@ -25,32 +25,33 @@
}
},
"require": {
- "php": "^7.3 || ~8.0.0",
+ "php": "^7.3 || ~8.0.0 || ~8.1.0",
"ext-intl": "*",
- "laminas/laminas-stdlib": "^2.7 || ^3.0",
- "laminas/laminas-zendframework-bridge": "^1.0"
+ "laminas/laminas-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "laminas/laminas-cache": "^2.6.1",
+ "laminas/laminas-cache": "^3.1.2",
+ "laminas/laminas-cache-storage-adapter-memory": "^2.0.0",
+ "laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
"laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-config": "^2.6",
- "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
- "laminas/laminas-filter": "^2.6.1",
- "laminas/laminas-servicemanager": "^3.2.1",
- "laminas/laminas-validator": "^2.6",
- "laminas/laminas-view": "^2.6.3",
+ "laminas/laminas-config": "^3.4.0",
+ "laminas/laminas-eventmanager": "^3.4.0",
+ "laminas/laminas-filter": "^2.10.0",
+ "laminas/laminas-servicemanager": "^3.7.0",
+ "laminas/laminas-validator": "^2.14.0",
+ "laminas/laminas-view": "^2.12.0",
"phpunit/phpunit": "^9.3"
},
"conflict": {
"phpspec/prophecy": "<1.9.0"
},
"suggest": {
- "laminas/laminas-cache": "Laminas\\Cache component",
- "laminas/laminas-config": "Laminas\\Config component",
+ "laminas/laminas-cache": "You should install this package to cache the translations",
+ "laminas/laminas-config": "You should install this package to use the INI translation format",
"laminas/laminas-eventmanager": "You should install this package to use the events in the translator",
"laminas/laminas-filter": "You should install this package to use the provided filters",
- "laminas/laminas-i18n-resources": "Translation resources",
- "laminas/laminas-servicemanager": "Laminas\\ServiceManager component",
+ "laminas/laminas-i18n-resources": "This package provides validator and captcha translations",
+ "laminas/laminas-servicemanager": "You should install this package to use the translator",
"laminas/laminas-validator": "You should install this package to use the provided validators",
"laminas/laminas-view": "You should install this package to use the provided view helpers"
},
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index f1f33d3..da14ca8 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -8,7 +8,7 @@
#
# When buid without config, filter, validator an view
%global bootstrap 0
-%global gh_commit 78adb53ebf6c0bc63f92273fd7809dabc554f786
+%global gh_commit 78234f2701ec6252bd99f08e517d2de202716b20
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.11.2
+Version: 2.12.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -38,27 +38,30 @@ BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-cache": "^2.6.1",
+# "laminas/laminas-cache": "^3.1.2",
+# "laminas/laminas-cache-storage-adapter-memory": "^2.0.0",
+# "laminas/laminas-cache-storage-deprecated-factory": "^1.0.0",
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^2.6",
-# "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
-# "laminas/laminas-filter": "^2.6.1",
-# "laminas/laminas-servicemanager": "^3.2.1",
-# "laminas/laminas-validator": "^2.6",
-# "laminas/laminas-view": "^2.6.3",
+# "laminas/laminas-config": "^3.4.0",
+# "laminas/laminas-eventmanager": "^3.4.0",
+# "laminas/laminas-filter": "^2.10.0",
+# "laminas/laminas-servicemanager": "^3.7.0",
+# "laminas/laminas-validator": "^2.14.0",
+# "laminas/laminas-view": "^2.12.0",
# "phpunit/phpunit": "^9.3"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# ignore version as cache v3 not available
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.4 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
%if ! %{bootstrap}
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.5 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.6.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.4 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.10 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.14 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.12 with php-autoloader(%{gh_owner}/laminas-view) < 3)
%endif
# remirepo:13
%else
@@ -68,7 +71,7 @@ BuildRequires: php-laminas-cache
BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-servicemanager
%if ! %{bootstrap}
-BuildRequires: php-laminas-config
+BuildRequires: php-laminas-config3
BuildRequires: php-laminas-filter
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-view
@@ -81,10 +84,9 @@ BuildRequires: phpunit9 >= 9.3
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
+# "php": "^7.3 || ~8.0.0 || ~8.1.0",
# "ext-intl": "*",
-# "laminas/laminas-stdlib": "^2.7 || ^3.0",
-# "laminas/laminas-zendframework-bridge": "^1.0"
+# "laminas/laminas-stdlib": "^2.7 || ^3.0"
Requires: php(language) >= 7.3
Requires: php-intl
# remirepo:1
@@ -162,7 +164,7 @@ cat << 'EOF' | tee -a src/autoload.php
]);
\Fedora\Autoloader\Dependencies::optional([
'%{php_home}/%{namespace}/Cache/autoload.php',
- '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/Config3/autoload.php',
'%{php_home}/%{namespace}/EventManager/autoload.php',
'%{php_home}/%{namespace}/Filter/autoload.php',
'%{php_home}/%{namespace}/ServiceManager/autoload.php',
@@ -216,7 +218,7 @@ rm -rf test/Validator/
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -240,6 +242,14 @@ exit $ret
%changelog
+* Mon Nov 29 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+
+* Wed Oct 13 2021 Remi Collet <remi@remirepo.net> - 2.11.3-1
+- update to 2.11.3 (no change)
+
* Thu Sep 2 2021 Remi Collet <remi@remirepo.net> - 2.11.2-1
- update to 2.11.2