summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-09 10:18:42 +0100
committerRemi Collet <remi@remirepo.net>2020-01-09 10:18:42 +0100
commit4ced74c26c0672a94f668b92babe9cf34c9b1fe3 (patch)
tree1b570d6cb4705946ae069eb87468a33e83225ba5
parent059ba2f1e57afba7c1ed98fc80ebb8d1210ec6a6 (diff)
switch to Laminas
-rw-r--r--composer.json88
-rw-r--r--php-laminas-i18n.spec229
2 files changed, 174 insertions, 143 deletions
diff --git a/composer.json b/composer.json
index 2e63518..61758d4 100644
--- a/composer.json
+++ b/composer.json
@@ -1,70 +1,71 @@
{
- "name": "zendframework/zend-i18n",
+ "name": "laminas/laminas-i18n",
"description": "Provide translations for your application, and filter and validate internationalized values",
"license": "BSD-3-Clause",
"keywords": [
- "zendframework",
- "zf",
+ "laminas",
"i18n"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-i18n/",
- "issues": "https://github.com/zendframework/zend-i18n/issues",
- "source": "https://github.com/zendframework/zend-i18n",
- "rss": "https://github.com/zendframework/zend-i18n/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-i18n/",
+ "issues": "https://github.com/laminas/laminas-i18n/issues",
+ "source": "https://github.com/laminas/laminas-i18n",
+ "rss": "https://github.com/laminas/laminas-i18n/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.10.x-dev",
+ "dev-develop": "2.11.x-dev"
+ },
+ "laminas": {
+ "component": "Laminas\\I18n",
+ "config-provider": "Laminas\\I18n\\ConfigProvider"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
"ext-intl": "*",
- "zendframework/zend-stdlib": "^2.7 || ^3.0"
+ "laminas/laminas-stdlib": "^2.7 || ^3.0",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
- "zendframework/zend-cache": "^2.6.1",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-config": "^2.6",
- "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
- "zendframework/zend-filter": "^2.6.1",
- "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-validator": "^2.6",
- "zendframework/zend-view": "^2.6.3"
+ "laminas/laminas-cache": "^2.6.1",
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-config": "^2.6",
+ "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+ "laminas/laminas-filter": "^2.6.1",
+ "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+ "laminas/laminas-validator": "^2.6",
+ "laminas/laminas-view": "^2.6.3",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16"
},
"conflict": {
"phpspec/prophecy": "<1.9.0"
},
"suggest": {
- "zendframework/zend-cache": "Zend\\Cache component",
- "zendframework/zend-config": "Zend\\Config component",
- "zendframework/zend-eventmanager": "You should install this package to use the events in the translator",
- "zendframework/zend-filter": "You should install this package to use the provided filters",
- "zendframework/zend-i18n-resources": "Translation resources",
- "zendframework/zend-servicemanager": "Zend\\ServiceManager component",
- "zendframework/zend-validator": "You should install this package to use the provided validators",
- "zendframework/zend-view": "You should install this package to use the provided view helpers"
+ "laminas/laminas-cache": "Laminas\\Cache component",
+ "laminas/laminas-config": "Laminas\\Config component",
+ "laminas/laminas-eventmanager": "You should install this package to use the events in the translator",
+ "laminas/laminas-filter": "You should install this package to use the provided filters",
+ "laminas/laminas-i18n-resources": "Translation resources",
+ "laminas/laminas-servicemanager": "Laminas\\ServiceManager component",
+ "laminas/laminas-validator": "You should install this package to use the provided validators",
+ "laminas/laminas-view": "You should install this package to use the provided view helpers"
},
"autoload": {
"psr-4": {
- "Zend\\I18n\\": "src/"
+ "Laminas\\I18n\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\I18n\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.10.x-dev",
- "dev-develop": "2.11.x-dev"
- },
- "zf": {
- "component": "Zend\\I18n",
- "config-provider": "Zend\\I18n\\ConfigProvider"
+ "LaminasTest\\I18n\\": "test/"
}
},
"scripts": {
@@ -76,5 +77,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-i18n": "self.version"
}
}
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index 283e404..4a0e3ff 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-i18n
+# remirepo/Fedora spec file for php-laminas-i18n
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -6,26 +6,25 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit 84038e6a1838b611dcc491b1c40321fa4c3a123c
+# When buid without config, filter, validator an view
+%global bootstrap 1
+%global gh_commit 815be447f1c77f70a86bf24d00087fcb975b39ff
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-i18n
+%global gh_owner laminas
+%global gh_project laminas-i18n
+%global zf_name zend-i18n
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library I18n
-%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
-%else
%global with_tests 0%{!?_without_tests:1}
-%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.10.1
-Release: 2%{?dist}
-Summary: Zend Framework %{library} component
+Release: 1%{?dist}
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -39,88 +38,82 @@ BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16",
-# "zendframework/zend-cache": "^2.6.1",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-config": "^2.6",
-# "zendframework/zend-eventmanager": "^2.6.2 || ^3.0",
-# "zendframework/zend-filter": "^2.6.1",
-# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-validator": "^2.6",
-# "zendframework/zend-view": "^2.6.3"
+# "laminas/laminas-cache": "^2.6.1",
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-config": "^2.6",
+# "laminas/laminas-eventmanager": "^2.6.2 || ^3.0",
+# "laminas/laminas-filter": "^2.6.1",
+# "laminas/laminas-servicemanager": "^2.7.5 || ^3.0.3",
+# "laminas/laminas-validator": "^2.6",
+# "laminas/laminas-view": "^2.6.3",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.16"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-composer(%{gh_owner}/zend-cache) >= 2.6.1 with php-composer(%{gh_owner}/zend-cache) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-config) >= 2.6 with php-composer(%{gh_owner}/zend-config) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2 with php-composer(%{gh_owner}/zend-eventmanager) < 4)
-BuildRequires: (php-composer(%{gh_owner}/zend-filter) >= 2.5 with php-composer(%{gh_owner}/zend-filter) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5 with php-composer(%{gh_owner}/zend-servicemanager) < 4)
-BuildRequires: (php-composer(%{gh_owner}/zend-validator) >= 2.6 with php-composer(%{gh_owner}/zend-validator) < 3)
-BuildRequires: (php-composer(%{gh_owner}/zend-view) >= 2.6.3 with php-composer(%{gh_owner}/zend-view) < 3)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5.16
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.0 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.0.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+%if ! %{bootstrap}
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.5 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.6 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.6.3 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+%endif
# remirepo:20
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-BuildRequires: php-composer(%{gh_owner}/zend-cache) < 3
-BuildRequires: php-composer(%{gh_owner}/zend-cache) >= 2.6.1
-BuildRequires: php-composer(%{gh_owner}/zend-config) < 3
-BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) < 4
-BuildRequires: php-composer(%{gh_owner}/zend-eventmanager) >= 2.6.2
-BuildRequires: php-composer(%{gh_owner}/zend-filter) < 3
-BuildRequires: php-composer(%{gh_owner}/zend-filter) >= 2.5
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) < 4
-BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.6
-BuildRequires: php-composer(%{gh_owner}/zend-view) < 3
-BuildRequires: php-composer(%{gh_owner}/zend-view) >= 2.6.3
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.14
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-cache
+BuildRequires: php-laminas-eventmanager
+BuildRequires: php-laminas-servicemanager
+%if ! %{bootstrap}
+BuildRequires: php-laminas-config
+BuildRequires: php-laminas-filter
+BuildRequires: php-laminas-validator
+BuildRequires: php-laminas-view
%endif
-# Autoloader
-BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.5.16
+%endif
+# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "ext-intl": "*",
-# "zendframework/zend-stdlib": "^2.7 || ^3.0"
+# "laminas/laminas-stdlib": "^2.7 || ^3.0",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
Requires: php-intl
-%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-# remirepo:4
-%else
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
-%endif
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
-# "zendframework/zend-cache": "Zend\\Cache component",
-# "zendframework/zend-config": "Zend\\Config component",
-# "zendframework/zend-eventmanager": "You should install this package to use the events in the translator",
-# "zendframework/zend-filter": "You should install this package to use the provided filters",
-# "zendframework/zend-i18n-resources": "Translation resources",
-# "zendframework/zend-servicemanager": "Zend\\ServiceManager component",
-# "zendframework/zend-validator": "You should install this package to use the provided validators",
-# "zendframework/zend-view": "You should install this package to use the provided view helpers",
-# "zendframework/zend-resources": "Translation resources"
-Suggests: php-composer(%{gh_owner}/zend-cache)
-Suggests: php-composer(%{gh_owner}/zend-config)
-Suggests: php-composer(%{gh_owner}/zend-eventmanager)
-Suggests: php-composer(%{gh_owner}/zend-filter)
-Suggests: php-composer(%{gh_owner}/zend-i18n-resources)
-Suggests: php-composer(%{gh_owner}/zend-servicemanager)
-Suggests: php-composer(%{gh_owner}/zend-validator)
-Suggests: php-composer(%{gh_owner}/zend-view)
+# "laminas/laminas-cache": "Laminas\\Cache component",
+# "laminas/laminas-config": "Laminas\\Config component",
+# "laminas/laminas-eventmanager": "You should install this package to use the events in the translator",
+# "laminas/laminas-filter": "You should install this package to use the provided filters",
+# "laminas/laminas-i18n-resources": "Translation resources",
+# "laminas/laminas-servicemanager": "Laminas\\ServiceManager component",
+# "laminas/laminas-validator": "You should install this package to use the provided validators",
+# "laminas/laminas-view": "You should install this package to use the provided view helpers"
+Suggests: php-autoloader(%{gh_owner}/laminas-cache)
+Suggests: php-autoloader(%{gh_owner}/laminas-config)
+Suggests: php-autoloader(%{gh_owner}/laminas-eventmanager)
+Suggests: php-autoloader(%{gh_owner}/laminas-filter)
+Suggests: php-autoloader(%{gh_owner}/laminas-i18n-resources)
+Suggests: php-autoloader(%{gh_owner}/laminas-servicemanager)
+Suggests: php-autoloader(%{gh_owner}/laminas-validator)
+Suggests: php-autoloader(%{gh_owner}/laminas-view)
+# remirepo:3
+%else
+Requires: php-laminas-stdlib
+Requires: php-laminas-zendframework-bridge
%endif
-# From phpcompatinfo report for version 2.5.1
+# From phpcompatinfo report for version 2.10.1
Requires: php-ctype
Requires: php-date
Requires: php-pcre
@@ -128,14 +121,17 @@ Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.10.1-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\I18n comes with a complete translation suite which supports all major
+%{namespace}\I18n comes with a complete translation suite which supports all major
formats and includes popular features like plural translations and text
domains. The Translator component is mostly dependency free, except for
the fallback to a default locale, where it relies on the Intl PHP extension.
@@ -144,7 +140,7 @@ The translator itself is initialized without any parameters, as any
configuration to it is optional. A translator without any translations
will actually do nothing but just return the given message IDs.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -156,26 +152,41 @@ mv LICENSE.md LICENSE
%build
: Create autoloader
phpab --template fedora --output src/autoload.php src
+
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
]);
\Fedora\Autoloader\Dependencies::optional([
- '%{php_home}/Zend/Cache/autoload.php',
- '%{php_home}/Zend/Config/autoload.php',
- '%{php_home}/Zend/EventManager/autoload.php',
- '%{php_home}/Zend/Filter/autoload.php',
- '%{php_home}/Zend/ServiceManager/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
- '%{php_home}/Zend/View/autoload.php',
- '%{php_home}/Zend/I18n/Translator/Resources.php',
+ '%{php_home}/%{namespace}/Cache/autoload.php',
+ '%{php_home}/%{namespace}/Config/autoload.php',
+ '%{php_home}/%{namespace}/EventManager/autoload.php',
+ '%{php_home}/%{namespace}/Filter/autoload.php',
+ '%{php_home}/%{namespace}/ServiceManager/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
+ '%{php_home}/%{namespace}/View/autoload.php',
+ '%{php_home}/%{namespace}/I18n/Translator/Resources.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -183,16 +194,26 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
-# For BR without new autoloader
-\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/autoload.php',
-]);
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+return (class_exists("\\Zend\\%{library}\\ConfigProvider") ? 0 : 1);
+'
+
+%if %{bootstrap}
+rm -rf test/Filter/
+rm -rf test/Translator/Loader/IniTest.php
+rm -rf test/View/
+rm -rf test/Validator/
+%endif
+
+: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} \
@@ -209,14 +230,20 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Thu Jan 9 2020 Remi Collet <remi@remirepo.net> - 2.10.1-1
+- switch to Laminas
+- boostrap build without config, filter, validator and view
+
* Fri Dec 13 2019 Remi Collet <remi@remirepo.net> - 2.10.1-2
- update to 2.10.1