summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-28 16:56:55 +0200
committerRemi Collet <remi@php.net>2023-03-28 16:56:55 +0200
commit0cba22a82938b202607bc2b9b8f973ca1b9f2b8c (patch)
treeb29b72222564abef92b76a6e666a1290e0162e77
parentfb4470c18f80ccbbd068066d082edc4d93920e90 (diff)
update to 2.21.0
-rw-r--r--composer.json20
-rw-r--r--php-laminas-i18n.spec43
2 files changed, 33 insertions, 30 deletions
diff --git a/composer.json b/composer.json
index b8e41d6..2a704f9 100644
--- a/composer.json
+++ b/composer.json
@@ -38,18 +38,18 @@
"laminas/laminas-stdlib": "^2.7 || ^3.0"
},
"require-dev": {
- "laminas/laminas-cache": "^3.6",
- "laminas/laminas-cache-storage-adapter-memory": "^2.1",
+ "laminas/laminas-cache": "^3.8",
+ "laminas/laminas-cache-storage-adapter-memory": "^2.2.0",
"laminas/laminas-cache-storage-deprecated-factory": "^1.0.1",
"laminas/laminas-coding-standard": "~2.4.0",
- "laminas/laminas-config": "^3.7",
- "laminas/laminas-eventmanager": "^3.5.0",
- "laminas/laminas-filter": "^2.21",
- "laminas/laminas-validator": "^2.25",
- "laminas/laminas-view": "^2.23",
- "phpunit/phpunit": "^9.5.25",
- "psalm/plugin-phpunit": "^0.17.0",
- "vimeo/psalm": "^4.28"
+ "laminas/laminas-config": "^3.8.0",
+ "laminas/laminas-eventmanager": "^3.7",
+ "laminas/laminas-filter": "^2.28.1",
+ "laminas/laminas-validator": "^2.28",
+ "laminas/laminas-view": "^2.25",
+ "phpunit/phpunit": "^9.5.26",
+ "psalm/plugin-phpunit": "^0.18.3",
+ "vimeo/psalm": "^5.0.0"
},
"conflict": {
"laminas/laminas-view": "<2.20.0",
diff --git a/php-laminas-i18n.spec b/php-laminas-i18n.spec
index 7abd9bb..24d22a6 100644
--- a/php-laminas-i18n.spec
+++ b/php-laminas-i18n.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-i18n
#
-# Copyright (c) 2015-2022 Remi Collet
+# Copyright (c) 2015-2023 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
# When buid without config, filter, validator an view
%global bootstrap 0
-%global gh_commit ebabca3a6398fc872127bc69a51bda5afc720d67
+%global gh_commit fbd2d0373aaced4769cba2bf3d1425d55f68abb1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n
@@ -19,11 +19,11 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.19.0
+Version: 2.21.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
-License: BSD
+License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -38,31 +38,31 @@ BuildRequires: php-intl
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "laminas/laminas-cache": "^3.6",
-# "laminas/laminas-cache-storage-adapter-memory": "^2.1",
+# "laminas/laminas-cache": "^3.8",
+# "laminas/laminas-cache-storage-adapter-memory": "^2.2.0",
# "laminas/laminas-cache-storage-deprecated-factory": "^1.0.1",
# "laminas/laminas-coding-standard": "~2.4.0",
-# "laminas/laminas-config": "^3.7",
-# "laminas/laminas-eventmanager": "^3.5.0",
-# "laminas/laminas-filter": "^2.21",
-# "laminas/laminas-validator": "^2.25",
-# "laminas/laminas-view": "^2.23",
-# "phpunit/phpunit": "^9.5.25",
-# "psalm/plugin-phpunit": "^0.17.0",
-# "vimeo/psalm": "^4.28"
+# "laminas/laminas-config": "^3.8.0",
+# "laminas/laminas-eventmanager": "^3.7",
+# "laminas/laminas-filter": "^2.28.1",
+# "laminas/laminas-validator": "^2.28",
+# "laminas/laminas-view": "^2.25",
+# "phpunit/phpunit": "^9.5.26",
+# "psalm/plugin-phpunit": "^0.18.3",
+# "vimeo/psalm": "^5.0"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.0 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# ignore version as cache v3 not available
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.5 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.7 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.14 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
%if ! %{bootstrap}
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.7 with php-autoloader(%{gh_owner}/laminas-config) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.21 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.25 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.23 with php-autoloader(%{gh_owner}/laminas-view) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 3.8 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-filter) >= 2.28.1 with php-autoloader(%{gh_owner}/laminas-filter) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.28 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-view) >= 2.25 with php-autoloader(%{gh_owner}/laminas-view) < 3)
%endif
# remirepo:13
%else
@@ -79,7 +79,7 @@ BuildRequires: php-laminas-view
%endif
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.25
+BuildRequires: phpunit9 >= 9.5.26
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -247,6 +247,9 @@ exit $ret
%changelog
+* Mon Dec 5 2022 Remi Collet <remi@remirepo.net> - 2.21.0-1
+- update to 2.21.0
+
* Tue Oct 11 2022 Remi Collet <remi@remirepo.net> - 2.19.0-1
- update to 2.19.0 (no change)