summaryrefslogtreecommitdiffstats
path: root/php-laminas-i18n-resources.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-16 08:32:52 +0200
committerRemi Collet <remi@remirepo.net>2021-04-16 08:32:52 +0200
commitfd50f79720e5d0f825d6782b4d8d9837c129ee57 (patch)
tree8dcee1252cdbc8a7e3a30087067e413108834b8e /php-laminas-i18n-resources.spec
parent4cefb3412987543231953f9d8e5121401545d8e4 (diff)
update to 2.7.0 (no change)
raise dependency on PHP 7.3 switch to phpunit9
Diffstat (limited to 'php-laminas-i18n-resources.spec')
-rw-r--r--php-laminas-i18n-resources.spec46
1 files changed, 24 insertions, 22 deletions
diff --git a/php-laminas-i18n-resources.spec b/php-laminas-i18n-resources.spec
index 37f2a54..1188962 100644
--- a/php-laminas-i18n-resources.spec
+++ b/php-laminas-i18n-resources.spec
@@ -1,13 +1,15 @@
# remirepo/Fedora spec file for php-laminas-i18n-resources
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit 7585cd3a4f9656814425b35689919a220c73834b
+
+%bcond_without tests
+
+%global gh_commit fc0211052aa7576bc960b30194c87f6f60a0089c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-i18n-resources
@@ -15,15 +17,10 @@
%global php_home %{_datadir}/php
%global namespace Laminas
%global library Translator
-%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
-%else
-%global with_tests 0%{!?_without_tests:1}
-%endif
Name: php-%{gh_project}
-Version: 2.6.1
-Release: 2%{?dist}
+Version: 2.7.0
+Release: 1%{?dist}
Summary: Laminas Framework %{library} component
License: BSD
@@ -33,8 +30,8 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
-%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+%if %{with tests}
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -44,17 +41,17 @@ BuildRequires: php-laminas-zendframework-bridge
%endif
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5"
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+# "phpunit/phpunit": "^9.5"
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.5
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-composer(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -68,8 +65,8 @@ Requires: php-composer(fedora/autoloader)
# None
# Compatibily ensure by the bridge
-Obsoletes: php-zendframework-%{zf_name} < 2.6.1-99
-Provides: php-zendframework-%{zf_name} = %{version}-99
+Obsoletes: php-zendframework-%{zf_name} < 2.6.2
+Provides: php-zendframework-%{zf_name} = %{version}
Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
@@ -116,7 +113,7 @@ cp -pr zf.php %{buildroot}%{php_home}/Zend/I18n/%{library}/autoload.php
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat << EOF | tee vendor/autoload.php
<?php
@@ -124,10 +121,10 @@ require_once '%{buildroot}%{php_home}/%{namespace}/I18n/%{library}/autoload.php'
EOF
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --verbose || ret=1
fi
done
@@ -157,6 +154,11 @@ exit $ret
%changelog
+* Fri Apr 16 2021 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- update to 2.7.0 (no change)
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Fri Jan 17 2020 Remi Collet <remi@remirepo.net> - 2.6.1-2
- cleanup