summaryrefslogtreecommitdiffstats
path: root/php-laminas-hydrator4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-14 15:39:53 +0200
committerRemi Collet <remi@php.net>2022-10-14 15:39:53 +0200
commit4f08f5c49cf8b249d451bd88443089530bd6c8c9 (patch)
treee75ef256541f4ea2d421512022c1ed2c9acf5766 /php-laminas-hydrator4.spec
parent28e4018b2dda2f221028652b411e170396db104d (diff)
update to 4.6.0
raise dependency on PHP 8.0
Diffstat (limited to 'php-laminas-hydrator4.spec')
-rw-r--r--php-laminas-hydrator4.spec44
1 files changed, 22 insertions, 22 deletions
diff --git a/php-laminas-hydrator4.spec b/php-laminas-hydrator4.spec
index 13c343a..a4843be 100644
--- a/php-laminas-hydrator4.spec
+++ b/php-laminas-hydrator4.spec
@@ -12,7 +12,7 @@
%bcond_without tests
-%global gh_commit bc849d46fb44e96dd93f7479e21266185ad3def3
+%global gh_commit 195c461129a75255e5f115b93bc3290cea43ef5e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-hydrator
@@ -22,7 +22,7 @@
%global major 4
Name: php-%{gh_project}%{major}
-Version: 4.5.0
+Version: 4.6.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component version %{major}
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with tests}
-BuildRequires: php(language) >= 7.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-date
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -43,22 +43,20 @@ BuildRequires: php-spl
BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-composer(webmozart/assert) >= 1.10 with php-composer(webmozart/assert) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~2.3.0",
-# "laminas/laminas-eventmanager": "^3.5.0",
-# "laminas/laminas-modulemanager": "^2.11.0",
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "laminas/laminas-eventmanager": "^3.6",
+# "laminas/laminas-modulemanager": "^2.12",
# "laminas/laminas-serializer": "^2.13.0",
-# "laminas/laminas-servicemanager": "^3.14.0",
-# "phpbench/phpbench": "^1.2.5",
-# "phpunit/phpunit": "~9.5.21",
+# "laminas/laminas-servicemanager": "^3.19",
+# "phpbench/phpbench": "^1.2.6",
+# "phpunit/phpunit": "~9.5.25",
# "psalm/plugin-phpunit": "^0.17.0",
-# "psr/cache": "1.0.1",
-# "vimeo/psalm": "^4.24.0"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.5 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.11 with php-autoloader(%{gh_owner}/laminas-modulemanager) < 3)
+# "vimeo/psalm": "^4.29"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-eventmanager) >= 3.6 with php-autoloader(%{gh_owner}/laminas-eventmanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-modulemanager) >= 2.12 with php-autoloader(%{gh_owner}/laminas-modulemanager) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-serializer) >= 2.13 with php-autoloader(%{gh_owner}/laminas-serializer) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.14 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-composer(psr/cache) >= 1.0.1 with php-composer(psr/cache) < 2)
-# remirepo:9
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.19 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+# remirepo:8
%else
BuildRequires: php-laminas-stdlib
BuildRequires: php-webmozart-assert
@@ -66,19 +64,18 @@ BuildRequires: php-laminas-eventmanager
BuildRequires: php-laminas-modulemanager
BuildRequires: php-laminas-serializer
BuildRequires: php-laminas-servicemanager
-BuildRequires: php-psr-cache
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.5.21
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-stdlib": "^3.3",
# "webmozart/assert": "^1.10"
-Requires: php(language) >= 7.4
+Requires: php(language) >= 8.0
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
@@ -149,7 +146,6 @@ cat << 'EOF' | tee vendor/autoload.php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}%{major}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
'%{php_home}/%{namespace}/ModuleManager/autoload.php',
- '%{php_home}//Psr/Cache/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Bench\\%{library}\\', dirname(__DIR__) . '/benchmark');
@@ -157,7 +153,7 @@ EOF
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} -d memory_limit=1G || ret=1
@@ -179,6 +175,10 @@ exit $ret
%changelog
+* Fri Oct 14 2022 Remi Collet <remi@remirepo.net> - 4.6.0-1
+- update to 4.6.0
+- raise dependency on PHP 8.0
+
* Thu Jul 14 2022 Remi Collet <remi@remirepo.net> - 4.5.0-1
- update to 4.5.0