summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-laminas-hydrator-php8.patch12
-rw-r--r--php-laminas-hydrator.spec12
2 files changed, 21 insertions, 3 deletions
diff --git a/php-laminas-hydrator-php8.patch b/php-laminas-hydrator-php8.patch
new file mode 100644
index 0000000..c861f2d
--- /dev/null
+++ b/php-laminas-hydrator-php8.patch
@@ -0,0 +1,12 @@
+diff -up ./src/ArraySerializable.php.php8 ./src/ArraySerializable.php
+--- ./src/ArraySerializable.php.php8 2021-03-25 13:59:16.746513687 +0100
++++ ./src/ArraySerializable.php 2021-03-25 13:59:20.978497492 +0100
+@@ -70,7 +70,7 @@ class ArraySerializable extends Abstract
+ // Ensure any previously populated values not in the replacement
+ // remain following population.
+ if (is_callable([$object, 'getArrayCopy'])) {
+- $original = $object->getArrayCopy($object);
++ $original = $object->getArrayCopy();
+ $replacement = array_merge($original, $replacement);
+ }
+ $object->exchangeArray($replacement);
diff --git a/php-laminas-hydrator.spec b/php-laminas-hydrator.spec
index 0c9bb9e..1ff5e69 100644
--- a/php-laminas-hydrator.spec
+++ b/php-laminas-hydrator.spec
@@ -1,6 +1,6 @@
# remirepo/Fedora spec file for php-laminas-hydrator
#
-# Copyright (c) 2016-2020 Remi Collet
+# Copyright (c) 2016-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -23,7 +23,7 @@
Name: php-%{gh_project}
Version: 2.4.2
-Release: 1%{?dist}
+Release: 5%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -31,6 +31,8 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: %{name}-php8.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -120,6 +122,7 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
mv LICENSE.md LICENSE
@@ -178,7 +181,7 @@ exit (class_exists("\\Zend\\%{library}\\Reflection") ? 0 : 1);
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} -d memory_limit=1G || ret=1
@@ -201,6 +204,9 @@ exit $ret
%changelog
+* Thu Mar 25 2021 Remi Collet <remi@remirepo.net> - 2.4.2-5
+- add minimal patch for PHP 8
+
* Fri Jan 10 2020 Remi Collet <remi@remirepo.net> - 2.4.2-1
- switch to Laminas