summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-23 10:17:51 +0100
committerRemi Collet <remi@remirepo.net>2020-11-23 10:17:51 +0100
commit963ae6e0c0e367610bd5a28b34fe1db23915e902 (patch)
tree0eeb573ace62a8d51619a1cdea27a6b67ed4b2bd
parent15ececeec64fdffc344e91fd39cca78da4f893aa (diff)
update to 1.3.0 (no change)
raise dependency on PHP 7.3 raise dependency on laminas-diactoros 2.1.1 switch to phpunit9
-rw-r--r--composer.json10
-rw-r--r--php-laminas-httphandlerrunner.spec37
2 files changed, 23 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 7acc0a5..e056414 100644
--- a/composer.json
+++ b/composer.json
@@ -22,16 +22,12 @@
"sort-packages": true
},
"extra": {
- "branch-alias": {
- "dev-master": "1.2.x-dev",
- "dev-develop": "1.3.x-dev"
- },
"laminas": {
"config-provider": "Laminas\\HttpHandlerRunner\\ConfigProvider"
}
},
"require": {
- "php": "^7.1",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-zendframework-bridge": "^1.0",
"psr/http-message": "^1.0",
"psr/http-message-implementation": "^1.0",
@@ -39,8 +35,8 @@
},
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
- "laminas/laminas-diactoros": "^1.7 || ^2.1.1",
- "phpunit/phpunit": "^7.0.2"
+ "laminas/laminas-diactoros": "^2.1.1",
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"psr-4": {
diff --git a/php-laminas-httphandlerrunner.spec b/php-laminas-httphandlerrunner.spec
index 7836e31..e147a32 100644
--- a/php-laminas-httphandlerrunner.spec
+++ b/php-laminas-httphandlerrunner.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e1a5dad040e0043135e8095ee27d1fbf6fb640e1
+%global gh_commit e8f850bd12cb82b268ff235fe74b2df906e8bfe8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-httphandlerrunner
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 1.2.0
+Version: 1.3.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -42,18 +42,18 @@ BuildRequires: (php-composer(psr/http-message) >= 1.0
BuildRequires: (php-composer(psr/http-server-handler) >= 1.0 with php-composer(psr/http-server-handler) < 2)
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-diactoros": "^1.7 || ^2.1.1",
-# "phpunit/phpunit": "^7.0.2"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-diactoros) >= 1.7 with php-autoloader(%{gh_owner}/laminas-diactoros) < 3)
+# "laminas/laminas-diactoros": "^2.1.1",
+# "phpunit/phpunit": "^9.3"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-diactoros) >= 2.1.1 with php-autoloader(%{gh_owner}/laminas-diactoros) < 3)
# remirepo:6
%else
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-psr-http-message
BuildRequires: php-psr-http-server-handler
-BuildRequires: php-laminas-diactoros
+BuildRequires: php-laminas-diactoros2
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.0.2
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
BuildRequires: php-pcre
BuildRequires: php-spl
%endif
@@ -61,12 +61,12 @@ BuildRequires: php-spl
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.1",
+# "php": "^7.3 || ~8.0.0",
# "laminas/laminas-zendframework-bridge": "^1.0",
# "psr/http-message": "^1.0",
# "psr/http-message-implementation": "^1.0",
# "psr/http-server-handler": "^1.0"
-Requires: php(language) >= 7.1
+Requires: php(language) >= 7.3
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
@@ -147,10 +147,7 @@ cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- [
- '%{php_home}/%{namespace}/Diactoros2/autoload.php',
- '%{php_home}/%{namespace}/Diactoros/autoload.php',
- ],
+ '%{php_home}/%{namespace}/Diactoros2/autoload.php',
]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -166,10 +163,10 @@ rm -r test/Emitter/
: upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} || ret=1
fi
done
exit $ret
@@ -189,6 +186,12 @@ exit $ret
%changelog
+* Mon Nov 23 2020 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0 (no change)
+- raise dependency on PHP 7.3
+- raise dependency on laminas-diactoros 2.1.1
+- switch to phpunit9
+
* Thu Jun 4 2020 Remi Collet <remi@remirepo.net> - 1.2.0-1
- update to 1.2.0