summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-laminas-http.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/php-laminas-http.spec b/php-laminas-http.spec
index 50bb719..56387d8 100644
--- a/php-laminas-http.spec
+++ b/php-laminas-http.spec
@@ -185,6 +185,13 @@ require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
exit (class_exists("\\Zend\\%{library}\\Client") ? 0 : 1);
'
+BIT=$(php -r 'echo PHP_INT_SIZE;')
+if [ $BIT -lt 8 ]; then
+FILTER='^((?!(testStreamCompression|testSetCookieSetExpiresWithStringDateBiggerThen2038)).)*$'
+else
+FILTER='^((?!(testStreamCompression)).)*$'
+fi
+
: upstream test suite
# testStreamCompression: online test
ret=0
@@ -192,7 +199,7 @@ for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
- --filter '^((?!(testStreamCompression)).)*$' \
+ --filter $FILTER \
|| ret=1
fi
done