summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-03 12:11:30 +0100
committerRemi Collet <remi@php.net>2021-12-03 12:11:30 +0100
commitffb00813c48a632f39cdfff7284a1a90fdbcdedc (patch)
treee74e5cf26c6287b999c0b3224a917c73738585d4
parent834a494a68d3d991e3e0243089aaf754583e8ba9 (diff)
update to 2.15.1
-rw-r--r--composer.json1
-rw-r--r--php-laminas-http.spec14
2 files changed, 10 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 642144a..aa7c016 100644
--- a/composer.json
+++ b/composer.json
@@ -27,6 +27,7 @@
"laminas/laminas-validator": "^2.15"
},
"require-dev": {
+ "ext-curl": "*",
"laminas/laminas-coding-standard": "~2.2.1",
"phpunit/phpunit": "^9.5.5"
},
diff --git a/php-laminas-http.spec b/php-laminas-http.spec
index 56387d8..ef9a9f2 100644
--- a/php-laminas-http.spec
+++ b/php-laminas-http.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e1f3420ab35e21ea135913d213b8d570e5e7b513
+%global gh_commit 261f079c3dffcf6f123484db43c40e44c4bf1c79
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-http
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.15.0
+Version: 2.15.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -51,6 +51,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.
BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
+# "ext-curl": "*",
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-config": "^3.1 || ^2.6",
# "phpunit/phpunit": "^9.3"
@@ -187,15 +188,15 @@ exit (class_exists("\\Zend\\%{library}\\Client") ? 0 : 1);
BIT=$(php -r 'echo PHP_INT_SIZE;')
if [ $BIT -lt 8 ]; then
-FILTER='^((?!(testStreamCompression|testSetCookieSetExpiresWithStringDateBiggerThen2038)).)*$'
+FILTER='^((?!(testWriteCanHandleFloatHttpVersion|testWriteCanHandleStringHttpVersion|testStreamCompression|testSetCookieSetExpiresWithStringDateBiggerThen2038)).)*$'
else
-FILTER='^((?!(testStreamCompression)).)*$'
+FILTER='^((?!(testWriteCanHandleFloatHttpVersion|testWriteCanHandleStringHttpVersion|testStreamCompression)).)*$'
fi
: upstream test suite
# testStreamCompression: online test
ret=0
-for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -220,6 +221,9 @@ exit $ret
%changelog
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 2.15.1-1
+- update to 2.15.1
+
* Fri Sep 10 2021 Remi Collet <remi@remirepo.net> - 2.15.0-1
- update to 2.15.0
- keep compatibility using laminas-zendframework-bridge