summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-07 08:06:00 +0100
committerRemi Collet <remi@remirepo.net>2021-01-07 08:06:00 +0100
commitdc70d67214e423a9bcb668548315b021dd4b7702 (patch)
tree0aedfdf6d443a873029391c008aa386b19e9e3f4
parent3b2796c77abcfd576581936564dcb7c0e46a1fe5 (diff)
update to 2.14.2
raise dependency on PHP 7.3 switch to phpunit9
-rw-r--r--composer.json4
-rw-r--r--php-laminas-http.spec27
2 files changed, 18 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index bab6e8a..7ee29fe 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"sort-packages": true
},
"require": {
- "php": "^5.6 || ^7.0",
+ "php": "^7.3 || ~8.0.0",
"laminas/laminas-loader": "^2.5.1",
"laminas/laminas-stdlib": "^3.2.1",
"laminas/laminas-uri": "^2.5.2",
@@ -30,7 +30,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "~1.0.0",
"laminas/laminas-config": "^3.1 || ^2.6",
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3"
+ "phpunit/phpunit": "^9.3"
},
"suggest": {
"paragonie/certainty": "For automated management of cacert.pem"
diff --git a/php-laminas-http.spec b/php-laminas-http.spec
index 05cd718..ad3f199 100644
--- a/php-laminas-http.spec
+++ b/php-laminas-http.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-laminas-http
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 33b7942f51ce905ce9bfc8bf28badc501d3904b5
+%global gh_commit 298f732e1acb031db70ea4fd2133a283b2a4a65e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-http
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.13.0
+Version: 2.14.2
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.6
+BuildRequires: php(language) >= 7.3
BuildRequires: php-ctype
BuildRequires: php-curl
BuildRequires: php-date
@@ -53,7 +53,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~1.0.0",
# "laminas/laminas-config": "^3.1 || ^2.6",
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3"
+# "phpunit/phpunit": "^9.3"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 4)
# remirepo:8
%else
@@ -64,20 +64,20 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
BuildRequires: php-laminas-config
%endif
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9 >= 9.3
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^5.6 || ^7.0",
+# "php": "^7.3 || ^8.0",
# "laminas/laminas-loader": "^2.5.1",
# "laminas/laminas-stdlib": "^3.2.1",
# "laminas/laminas-uri": "^2.5.2",
# "laminas/laminas-validator": "^2.10.1",
# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 5.6
+Requires: php(language) >= 7.3
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -189,10 +189,10 @@ exit (class_exists("\\Zend\\%{library}\\Client") ? 0 : 1);
: upstream test suite
# testStreamCompression: online test
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} \
+ $1 ${2:-%{_bindir}/phpunit9} \
--filter '^((?!(testStreamCompression)).)*$' \
|| ret=1
fi
@@ -214,6 +214,11 @@ exit $ret
%changelog
+* Thu Jan 7 2021 Remi Collet <remi@remirepo.net> - 2.14.2-1
+- update to 2.14.2
+- raise dependency on PHP 7.3
+- switch to phpunit9
+
* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 2.13.0-1
- update to 2.13.0