summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-10 11:17:14 +0100
committerRemi Collet <remi@remirepo.net>2020-01-10 11:17:14 +0100
commit738202109425b7d761cb12b9423b715d6f76b412 (patch)
treeed6ceccc5fa293fcdaebfb6e7182863ada579ccb
parentf5ed62aa5472fa846c2a663346b39bf013aab80f (diff)
switch to Laminas
-rw-r--r--composer.json59
-rw-r--r--php-laminas-http.spec156
2 files changed, 123 insertions, 92 deletions
diff --git a/composer.json b/composer.json
index 9574aab..a82627c 100644
--- a/composer.json
+++ b/composer.json
@@ -1,54 +1,54 @@
{
- "name": "zendframework/zend-http",
+ "name": "laminas/laminas-http",
"description": "Provides an easy interface for performing Hyper-Text Transfer Protocol (HTTP) requests",
"license": "BSD-3-Clause",
"keywords": [
- "zf",
- "zend",
- "zendframework",
+ "laminas",
"http",
"HTTP client"
],
+ "homepage": "https://laminas.dev",
"support": {
- "docs": "https://docs.zendframework.com/zend-http/",
- "issues": "https://github.com/zendframework/zend-http/issues",
- "source": "https://github.com/zendframework/zend-http",
- "rss": "https://github.com/zendframework/zend-http/releases.atom",
- "chat": "https://zendframework-slack.herokuapp.com",
- "forum": "https://discourse.zendframework.com/c/questions/components"
+ "docs": "https://docs.laminas.dev/laminas-http/",
+ "issues": "https://github.com/laminas/laminas-http/issues",
+ "source": "https://github.com/laminas/laminas-http",
+ "rss": "https://github.com/laminas/laminas-http/releases.atom",
+ "chat": "https://laminas.dev/chat",
+ "forum": "https://discourse.laminas.dev"
+ },
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.11.x-dev",
+ "dev-develop": "2.12.x-dev"
+ }
},
"require": {
"php": "^5.6 || ^7.0",
- "zendframework/zend-loader": "^2.5.1",
- "zendframework/zend-stdlib": "^3.2.1",
- "zendframework/zend-uri": "^2.5.2",
- "zendframework/zend-validator": "^2.10.1"
+ "laminas/laminas-loader": "^2.5.1",
+ "laminas/laminas-stdlib": "^3.2.1",
+ "laminas/laminas-uri": "^2.5.2",
+ "laminas/laminas-validator": "^2.10.1",
+ "laminas/laminas-zendframework-bridge": "^1.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3",
- "zendframework/zend-coding-standard": "~1.0.0",
- "zendframework/zend-config": "^3.1 || ^2.6"
+ "laminas/laminas-coding-standard": "~1.0.0",
+ "laminas/laminas-config": "^3.1 || ^2.6",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3"
},
"suggest": {
"paragonie/certainty": "For automated management of cacert.pem"
},
"autoload": {
"psr-4": {
- "Zend\\Http\\": "src/"
+ "Laminas\\Http\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
- "ZendTest\\Http\\": "test/"
- }
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "2.11.x-dev",
- "dev-develop": "2.12.x-dev"
+ "LaminasTest\\Http\\": "test/"
}
},
"scripts": {
@@ -60,5 +60,8 @@
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ },
+ "replace": {
+ "zendframework/zend-http": "self.version"
}
}
diff --git a/php-laminas-http.spec b/php-laminas-http.spec
index 5624a32..9c3fc5d 100644
--- a/php-laminas-http.spec
+++ b/php-laminas-http.spec
@@ -1,4 +1,4 @@
-# remirepo/Fedora spec file for php-zendframework-zend-http
+# remirepo/Fedora spec file for php-laminas-http
#
# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,13 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e15e0ce45a2a4f642cd0b7b4f4d4d0366b729a1a
+%global gh_commit 8c66963b933c80da59433da56a44dfa979f3ec88
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner zendframework
-%global gh_project zend-http
+%global gh_owner laminas
+%global gh_project laminas-http
+%global zf_name zend-http
%global php_home %{_datadir}/php
+%global namespace Laminas
%global library Http
%if %{bootstrap}
%global with_tests 0%{?_with_tests:1}
@@ -19,13 +21,13 @@
%global with_tests 0%{!?_without_tests:1}
%endif
-Name: php-%{gh_owner}-%{gh_project}
+Name: php-%{gh_project}
Version: 2.11.2
Release: 1%{?dist}
-Summary: Zend Framework %{library} component
+Summary: %{namespace} Framework %{library} component
License: BSD
-URL: https://zendframework.github.io/%{gh_project}/
+URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -41,67 +43,61 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-zlib
-# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3",
-# "zendframework/zend-coding-standard": "~1.0.0",
-# "zendframework/zend-config": "^3.1 || ^2.6"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1 with php-autoloader(%{gh_owner}/zend-loader) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-BuildRequires: (php-autoloader(%{gh_owner}/zend-config) >= 2.6 with php-autoloader(%{gh_owner}/zend-config) < 4)
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.1.2
-# remirepo:14
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5.1 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# From composer, "require-dev": {
+# "laminas/laminas-coding-standard": "~1.0.0",
+# "laminas/laminas-config": "^3.1 || ^2.6",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.3"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 4)
+# remirepo:8
%else
-BuildRequires: php-autoloader(%{gh_owner}/zend-loader) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-uri) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) < 4
-BuildRequires: php-autoloader(%{gh_owner}/zend-config) >= 2.6
-%global phpunit %{_bindir}/phpunit6
-BuildRequires: phpunit6 >= 6.5.8
+BuildRequires: php-laminas-loader
+BuildRequires: php-laminas-stdlib
+BuildRequires: php-laminas-uri
+BuildRequires: php-laminas-validator
+BuildRequires: php-laminas-zendframework-bridge
+BuildRequires: php-laminas-config
%endif
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "zendframework/zend-loader": "^2.5.1",
-# "zendframework/zend-stdlib": "^3.2.1",
-# "zendframework/zend-uri": "^2.5.2",
-# "zendframework/zend-validator": "^2.10.1"
+# "laminas/laminas-loader": "^2.5.1",
+# "laminas/laminas-stdlib": "^3.2.1",
+# "laminas/laminas-uri": "^2.5.2",
+# "laminas/laminas-validator": "^2.10.1",
+# "laminas/laminas-zendframework-bridge": "^1.0"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1 with php-autoloader(%{gh_owner}/zend-loader) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
-Requires: (php-autoloader(%{gh_owner}/zend-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-uri) < 3)
-Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
-# remirepo:10
+Requires: (php-autoloader(%{gh_owner}/laminas-loader) >= 2.5.1 with php-autoloader(%{gh_owner}/laminas-loader) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.5.2 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/laminas-validator) < 3)
+Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
+# remirepo:7
%else
-Requires: php-autoloader(%{gh_owner}/zend-loader) < 3
-Requires: php-autoloader(%{gh_owner}/zend-loader) >= 2.5.1
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
-Requires: php-autoloader(%{gh_owner}/zend-uri) < 3
-Requires: php-autoloader(%{gh_owner}/zend-uri) >= 2.5
-Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
-Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+Requires: php-laminas-loader
+Requires: php-laminas-stdlib
+Requires: php-laminas-uri
+Requires: php-laminas-validator
+Requires: php-laminas-zendframework-bridge
%endif
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
-# From phpcompatinfo report for version 2.8.0
+# From phpcompatinfo report for version 2.11.2
Requires: php-ctype
Requires: php-curl
Requires: php-date
@@ -111,19 +107,25 @@ Requires: php-pcre
Requires: php-spl
Requires: php-zlib
-Obsoletes: php-ZendFramework2-%{library} < 2.5
-Provides: php-ZendFramework2-%{library} = %{version}
-Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+# remirepo:2
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+# Compatibily ensure by the bridge
+Obsoletes: php-zendframework-%{zf_name} < 2.11.2-99
+Provides: php-zendframework-%{zf_name} = %{version}-99
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-composer(zendframework/%{zf_name}) = %{version}
Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(zendframework/%{zf_name}) = %{version}
%description
-Zend\Http is a primary foundational component of Zend Framework.
+%{namespace}\Http is a primary foundational component of %{namespace} Framework.
Since much of what PHP does is web-based, specifically HTTP,
it makes sense to have a performant, extensible, concise and
consistent API to do all things HTTP.
-Documentation: https://zendframework.github.io/%{gh_project}/
+Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
@@ -136,17 +138,31 @@ mv LICENSE.md LICENSE
phpab --template fedora --output src/autoload.php src
cat << 'EOF' | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Loader/autoload.php',
- '%{php_home}/Zend/Stdlib/autoload.php',
- '%{php_home}/Zend/Uri/autoload.php',
- '%{php_home}/Zend/Validator/autoload.php',
+ '%{php_home}/%{namespace}/Loader/autoload.php',
+ '%{php_home}/%{namespace}/Stdlib/autoload.php',
+ '%{php_home}/%{namespace}/Uri/autoload.php',
+ '%{php_home}/%{namespace}/Validator/autoload.php',
+]);
+EOF
+
+cat << 'EOF' | tee zf.php
+<?php
+require_once '%{php_home}/Fedora/Autoloader/autoload.php';
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/%{namespace}/ZendFrameworkBridge/autoload.php',
+ dirname(dirname(__DIR__)) . '/%{namespace}/%{library}/autoload.php',
]);
EOF
%install
-mkdir -p %{buildroot}%{php_home}/Zend/
-cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+: Laminas library
+mkdir -p %{buildroot}%{php_home}/%{namespace}/
+cp -pr src %{buildroot}%{php_home}/%{namespace}/%{library}
+
+: Zend equiv
+mkdir -p %{buildroot}%{php_home}/Zend/%{library}
+cp -pr zf.php %{buildroot}%{php_home}/Zend/%{library}/autoload.php
%check
@@ -154,16 +170,23 @@ cp -pr src %{buildroot}%{php_home}/Zend/%{library}
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
-require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Zend/Config/autoload.php',
+ '%{php_home}/%{namespace}/Config/autoload.php',
]);
-\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
+: check compat autoloader
+php -r '
+require "%{buildroot}%{php_home}/Zend/%{library}/autoload.php";
+exit (class_exists("\\Zend\\%{library}\\Client") ? 0 : 1);
+'
+
+: upstream test suite
# testStreamCompression: online test
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit7} \
@@ -178,14 +201,19 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
%{php_home}/Zend/%{library}
+%{php_home}/%{namespace}/%{library}
%changelog
+* Fri Jan 10 2020 Remi Collet <remi@remirepo.net> - 2.11.2-1
+- switch to Laminas
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 2.11.2-1
- update to 2.11.2