summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-17 14:00:35 +0200
committerRemi Collet <remi@php.net>2022-10-17 14:00:35 +0200
commit3bdee7c4b9697ab1afe7fda7ff1f021335eb0a9e (patch)
treeaccc3438b3506df20a93d1b246f0172e252f88a7
parent72c59c9dc7f509fa8634b479dc06b3526c574b40 (diff)
update to 2.17.0
raise dependency on PHP 8.0
-rw-r--r--composer.json6
-rw-r--r--php-laminas-http.spec37
2 files changed, 19 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index bc44f89..493c6de 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,7 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ~8.0.0 || ~8.1.0",
+ "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
"laminas/laminas-loader": "^2.8",
"laminas/laminas-stdlib": "^3.6",
"laminas/laminas-uri": "^2.9.1",
@@ -31,8 +31,8 @@
},
"require-dev": {
"ext-curl": "*",
- "laminas/laminas-coding-standard": "~2.2.1",
- "phpunit/phpunit": "^9.5.5"
+ "laminas/laminas-coding-standard": "~2.4.0",
+ "phpunit/phpunit": "^9.5.25"
},
"suggest": {
"paragonie/certainty": "For automated management of cacert.pem"
diff --git a/php-laminas-http.spec b/php-laminas-http.spec
index ebf3185..877316f 100644
--- a/php-laminas-http.spec
+++ b/php-laminas-http.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 7300482d3e570e81b6a6ecf6b28da1b12334bf63
+%global gh_commit ac4588d698c93b56bb7c0608d9a7537a3f057239
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-http
@@ -22,7 +22,7 @@
%endif
Name: php-%{gh_project}
-Version: 2.16.0
+Version: 2.17.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -34,7 +34,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-ctype
BuildRequires: php-curl
BuildRequires: php-date
@@ -52,32 +52,29 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-validator) >= 2.15
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
# "ext-curl": "*",
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-config": "^3.1 || ^2.6",
-# "phpunit/phpunit": "^9.3"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-config) >= 2.6 with php-autoloader(%{gh_owner}/laminas-config) < 4)
-# remirepo:8
+# "laminas/laminas-coding-standard": "~2.4.0",
+# "phpunit/phpunit": "^9.5.25"
+# remirepo:7
%else
BuildRequires: php-laminas-loader
BuildRequires: php-laminas-stdlib
BuildRequires: php-laminas-uri
BuildRequires: php-laminas-validator
BuildRequires: php-laminas-zendframework-bridge
-BuildRequires: php-laminas-config
%endif
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.25
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0 || ~8.1.0",
+# "php": "~8.0.0 || ~8.1.0 || ~8.2.0",
# "laminas/laminas-loader": "^2.8",
# "laminas/laminas-stdlib": "^3.6",
# "laminas/laminas-uri": "^2.9.1",
# "laminas/laminas-validator": "^2.15"
-Requires: php(language) >= 7.3
+Requires: php(language) >= 8.0
%if ! %{bootstrap}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -171,12 +168,6 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{namespace}/%{library}/autoload.php';
-\Fedora\Autoloader\Dependencies::required([
- [
- '%{php_home}/%{namespace}/Config3/autoload.php',
- '%{php_home}/%{namespace}/Config/autoload.php',
- ],
-]);
\Fedora\Autoloader\Autoload::addPsr4('%{namespace}Test\\%{library}\\', dirname(__DIR__) . '/test');
EOF
@@ -188,15 +179,15 @@ exit (class_exists("\\Zend\\%{library}\\Client") ? 0 : 1);
BIT=$(php -r 'echo PHP_INT_SIZE;')
if [ $BIT -lt 8 ]; then
-FILTER='^((?!(testWriteCanHandleFloatHttpVersion|testWriteCanHandleStringHttpVersion|testStreamCompression|testSetCookieSetExpiresWithStringDateBiggerThen2038)).)*$'
+FILTER='^((?!(testWriteCanHandleFloatHttpVersion|testWriteCanHandleStringHttpVersion|testStreamCompression|testChunkedResponsePerformance|testSetCookieSetExpiresWithStringDateBiggerThen2038)).)*$'
else
-FILTER='^((?!(testWriteCanHandleFloatHttpVersion|testWriteCanHandleStringHttpVersion|testStreamCompression)).)*$'
+FILTER='^((?!(testWriteCanHandleFloatHttpVersion|testWriteCanHandleStringHttpVersion|testStreamCompression|testChunkedResponsePerformance)).)*$'
fi
: upstream test suite
# testStreamCompression: online test
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
+for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -221,6 +212,10 @@ exit $ret
%changelog
+* Mon Oct 17 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+- raise dependency on PHP 8.0
+
* Thu Aug 18 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
- update to 2.16.0