summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--55.patch45
-rw-r--r--composer.json2
-rw-r--r--php-laminas-form.spec17
3 files changed, 10 insertions, 54 deletions
diff --git a/55.patch b/55.patch
deleted file mode 100644
index 3c57ead..0000000
--- a/55.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 4dce426be17e4bbc7a7a7695707db2266949473f Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 16 Jan 2020 08:33:25 +0100
-Subject: [PATCH 1/2] Allow phpunit7
-
----
- composer.json | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/composer.json b/composer.json
-index a74efb71..0cd76f37 100644
---- a/composer.json
-+++ b/composer.json
-@@ -51,7 +51,7 @@
- "laminas/laminas-text": "^2.6",
- "laminas/laminas-validator": "^2.6",
- "laminas/laminas-view": "^2.6.2",
-- "phpunit/phpunit": "^5.7.23 || ^6.5.3"
-+ "phpunit/phpunit": "^5.7.23 || ^6.5.3 || ^7.5"
- },
- "suggest": {
- "laminas/laminas-captcha": "^2.7.1, required for using CAPTCHA form elements",
-
-From 0a5e011d6aeb98f45533e428ebb5a0e07d8db3bc Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 16 Jan 2020 08:34:01 +0100
-Subject: [PATCH 2/2] fix Using array_key_exists() on objects is deprecated
-
----
- src/Fieldset.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Fieldset.php b/src/Fieldset.php
-index f26a56dc..74ad2cbb 100644
---- a/src/Fieldset.php
-+++ b/src/Fieldset.php
-@@ -391,7 +391,7 @@ public function populateValues($data)
- }
-
- foreach ($this->iterator as $name => $elementOrFieldset) {
-- $valueExists = array_key_exists($name, $data);
-+ $valueExists = isset($data[$name]);
-
- if ($elementOrFieldset instanceof FieldsetInterface) {
- if ($valueExists && (is_array($data[$name]) || $data[$name] instanceof Traversable)) {
diff --git a/composer.json b/composer.json
index a74efb7..3073bfd 100644
--- a/composer.json
+++ b/composer.json
@@ -51,7 +51,7 @@
"laminas/laminas-text": "^2.6",
"laminas/laminas-validator": "^2.6",
"laminas/laminas-view": "^2.6.2",
- "phpunit/phpunit": "^5.7.23 || ^6.5.3"
+ "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
},
"suggest": {
"laminas/laminas-captcha": "^2.7.1, required for using CAPTCHA form elements",
diff --git a/php-laminas-form.spec b/php-laminas-form.spec
index 87a2151..02a8595 100644
--- a/php-laminas-form.spec
+++ b/php-laminas-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 012aae01366cb8c8fb64e39a887363ef82f388dd
+%global gh_commit 8b985f74bfe32910edb4ba9503877c4310228cd2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-form
@@ -22,8 +22,8 @@
%endif
Name: php-%{gh_project}
-Version: 2.14.3
-Release: 2%{?dist}
+Version: 2.14.4
+Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
License: BSD
@@ -31,8 +31,6 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/laminas/laminas-form/pull/55.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -64,7 +62,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "laminas/laminas-text": "^2.6",
# "laminas/laminas-validator": "^2.6",
# "laminas/laminas-view": "^2.6.2",
-# "phpunit/phpunit": "^5.7.23 || ^6.5.3"
+# "phpunit/phpunit": "^5.7.27 || ^6.5.14 || ^7.5.20"
BuildRequires: (php-composer(doctrine/annotations) >= 1.0 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.6.1 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-captcha) >= 2.7.1 with php-autoloader(%{gh_owner}/laminas-captcha) < 3)
@@ -99,7 +97,7 @@ BuildRequires: php-laminas-validator
BuildRequires: php-laminas-view
%endif
%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7 >= 7.5
+BuildRequires: phpunit7 >= 7.5.20
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -155,6 +153,7 @@ Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
+# remirepo:2
Obsoletes: php-ZendFramework2-%{library} < 2.5
Provides: php-ZendFramework2-%{library} = %{version}
# Compatibily ensure by the bridge
@@ -177,7 +176,6 @@ Documentation: https://docs.laminas.dev/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -279,6 +277,9 @@ exit $ret
%changelog
+* Thu Mar 19 2020 Remi Collet <remi@remirepo.net> - 2.14.4-1
+- update to 2.14.4
+
* Mon Jan 20 2020 Remi Collet <remi@remirepo.net> - 2.12.0-2
- allow laminas-hydrator v3