summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-05-25 10:46:19 +0200
committerRemi Collet <remi@remirepo.net>2021-05-25 10:46:19 +0200
commit8af4b5b63310b2742a23964cbaa464bf859f8fbc (patch)
tree2c002ca544f100b138e98cb587b200db07e0fa46
parent11e4479ee201295975ad67d2cbadc8eeb0bb82d2 (diff)
update to 2.17.0
-rw-r--r--composer.json54
-rw-r--r--php-laminas-form.spec9
2 files changed, 36 insertions, 27 deletions
diff --git a/composer.json b/composer.json
index d68845a..7313446 100644
--- a/composer.json
+++ b/composer.json
@@ -1,29 +1,12 @@
{
"name": "laminas/laminas-form",
"description": "Validate and display simple and complex forms, casting forms to business objects and vice versa",
- "license": "BSD-3-Clause",
"keywords": [
"laminas",
"form"
],
"homepage": "https://laminas.dev",
- "support": {
- "docs": "https://docs.laminas.dev/laminas-form/",
- "issues": "https://github.com/laminas/laminas-form/issues",
- "source": "https://github.com/laminas/laminas-form",
- "rss": "https://github.com/laminas/laminas-form/releases.atom",
- "chat": "https://laminas.dev/chat",
- "forum": "https://discourse.laminas.dev"
- },
- "config": {
- "sort-packages": true
- },
- "extra": {
- "laminas": {
- "component": "Laminas\\Form",
- "config-provider": "Laminas\\Form\\ConfigProvider"
- }
- },
+ "license": "BSD-3-Clause",
"require": {
"php": "^7.3 || ~8.0.0",
"laminas/laminas-hydrator": "^3.2 || ^4.0",
@@ -31,6 +14,9 @@
"laminas/laminas-stdlib": "^3.3",
"laminas/laminas-zendframework-bridge": "^1.1"
},
+ "replace": {
+ "zendframework/zend-form": "^2.14.3"
+ },
"conflict": {
"laminas/laminas-code": "<3.5.0 || >=4.0.0"
},
@@ -51,7 +37,9 @@
"laminas/laminas-validator": "^2.13.4",
"laminas/laminas-view": "^2.11.4",
"phpspec/prophecy-phpunit": "^2.0",
- "phpunit/phpunit": "^9.4.2"
+ "phpunit/phpunit": "^9.4.2",
+ "psalm/plugin-phpunit": "^0.15.1",
+ "vimeo/psalm": "^4.7"
},
"suggest": {
"laminas/laminas-captcha": "^2.9, required for using CAPTCHA form elements",
@@ -62,30 +50,46 @@
"laminas/laminas-servicemanager": "^3.4.1, required to use the form factories or provide services",
"laminas/laminas-view": "^2.11.4, required for using the laminas-form view helpers"
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "laminas": {
+ "component": "Laminas\\Form",
+ "config-provider": "Laminas\\Form\\ConfigProvider"
+ }
+ },
"autoload": {
"psr-4": {
"Laminas\\Form\\": "src/"
}
},
"autoload-dev": {
- "files": [
- "test/_autoload.php"
- ],
"psr-4": {
"LaminasTest\\Form\\": "test/"
- }
+ },
+ "files": [
+ "test/_autoload.php"
+ ]
},
"scripts": {
"check": [
"@cs-check",
+ "@static-analysis",
"@test"
],
"cs-check": "phpcs",
"cs-fix": "phpcbf",
+ "static-analysis": "psalm --shepherd --stats",
"test": "phpunit --colors=always",
"test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
},
- "replace": {
- "zendframework/zend-form": "^2.14.3"
+ "support": {
+ "issues": "https://github.com/laminas/laminas-form/issues",
+ "forum": "https://discourse.laminas.dev",
+ "chat": "https://laminas.dev/chat",
+ "source": "https://github.com/laminas/laminas-form",
+ "docs": "https://docs.laminas.dev/laminas-form/",
+ "rss": "https://github.com/laminas/laminas-form/releases.atom"
}
}
diff --git a/php-laminas-form.spec b/php-laminas-form.spec
index a28d175..61d94e8 100644
--- a/php-laminas-form.spec
+++ b/php-laminas-form.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 76fe85b3f126183fe965d60e32e2bf6c7c108d61
+%global gh_commit 2a18e6724739f3f1875d30a6bb8ecedb3da5242e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-form
@@ -19,7 +19,7 @@
%bcond_without tests
Name: php-%{gh_project}
-Version: 2.16.3
+Version: 2.17.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -62,6 +62,8 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.1
# "laminas/laminas-view": "^2.11.4",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.4.2"
+# "psalm/plugin-phpunit": "^0.15.1",
+# "vimeo/psalm": "^4.7"
BuildRequires: (php-composer(doctrine/annotations) >= 1.10.4 with php-composer(doctrine/annotations) < 2)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-cache) >= 2.9.0 with php-autoloader(%{gh_owner}/laminas-cache) < 3)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-captcha) >= 2.9.0 with php-autoloader(%{gh_owner}/laminas-captcha) < 3)
@@ -279,6 +281,9 @@ exit $ret
%changelog
+* Tue May 25 2021 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+
* Wed Apr 7 2021 Remi Collet <remi@remirepo.net> - 2.16.3-1
- update to 2.16.3 (no change)