summaryrefslogtreecommitdiffstats
path: root/php-laminas-filter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-laminas-filter.spec')
-rw-r--r--php-laminas-filter.spec7
1 files changed, 6 insertions, 1 deletions
diff --git a/php-laminas-filter.spec b/php-laminas-filter.spec
index 515be9e..c544ad3 100644
--- a/php-laminas-filter.spec
+++ b/php-laminas-filter.spec
@@ -202,11 +202,16 @@ exit (class_exists("\\Zend\\%{library}\\ToInt") ? 0 : 1);
'
: upstream test suite
+# Skip test failing with OpenSSL 3.0 (not available algo)
ret=0
for cmd in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmd; then
set $cmd
- $1 ${2:-%{_bindir}/phpunit9} || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} \
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9
+ --filter '^((?!(testGetSetEncryption|testBasicOpenssl|testEncryptionWithDecryptionWithPackagedKeys|testEncryptionWithDecryptionAndCompressionWithPackagedKeys)).)*$' \
+%endif
+ || ret=1
fi
done
exit $ret