summaryrefslogtreecommitdiffstats
path: root/php-laminas-filter.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-02 16:38:45 +0100
committerRemi Collet <remi@php.net>2021-12-02 16:38:45 +0100
commitf2c6177a0d6c99c9f45a8c34f18f47a49da11669 (patch)
tree5d0683199eda74ab9d3f5318c9bd307139d6d59e /php-laminas-filter.spec
parentc50242c00593c8a5326a4428e59240597fcce584 (diff)
update to 2.13.0
keep compatibility using laminas-zendframework-bridge as this is only used using compat autolader raise dependency on PHP 7.4 raise dependency on laminas-stdlib 3.6.1
Diffstat (limited to 'php-laminas-filter.spec')
-rw-r--r--php-laminas-filter.spec60
1 files changed, 33 insertions, 27 deletions
diff --git a/php-laminas-filter.spec b/php-laminas-filter.spec
index c544ad3..06dc959 100644
--- a/php-laminas-filter.spec
+++ b/php-laminas-filter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 0fc5dcd27dc22dba1a2544123684c67768fc5f88
+%global gh_commit 67d88c471cb7016f495aeb1d3fd03edaa9bd9e70
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-filter
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.12.0
+Version: 2.13.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -30,7 +30,7 @@ Source1: makesrc.sh
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 7.4
BuildRequires: php-date
BuildRequires: php-iconv
BuildRequires: php-mbstring
@@ -40,24 +40,24 @@ BuildRequires: php-spl
BuildRequires: php-zip
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "require-dev": {
-# "laminas/laminas-coding-standard": "~1.0.0",
-# "laminas/laminas-crypt": "^3.2.1",
-# "laminas/laminas-servicemanager": "^3.3",
-# "laminas/laminas-uri": "^2.6",
-# "pear/archive_tar": "^1.4.3",
-# "phpspec/prophecy-phpunit": "^2.0",
-# "phpunit/phpunit": "^9.3",
-# "psalm/plugin-phpunit": "^0.15.1",
-# "psr/http-factory": "^1.0",
-# "vimeo/psalm": "^4.6"
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.6 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
-BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0 with php-composer(phpspec/prophecy-phpunit) < 3)
-BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
+# "laminas/laminas-coding-standard": "~2.3.0",
+# "laminas/laminas-crypt": "^3.5.1",
+# "laminas/laminas-servicemanager": "^3.7.0",
+# "laminas/laminas-uri": "^2.9",
+# "pear/archive_tar": "^1.4.14",
+# "phpspec/prophecy-phpunit": "^2.0.1",
+# "phpunit/phpunit": "^9.5.10",
+# "psalm/plugin-phpunit": "^0.15.2",
+# "psr/http-factory": "^1.0.1",
+# "vimeo/psalm": "^4.13.1"
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.5.1 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
+BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0.1 with php-composer(phpspec/prophecy-phpunit) < 3)
+BuildRequires: (php-composer(psr/http-factory) >= 1.0.1 with php-composer(psr/http-factory) < 2)
# remirepo:9
%else
BuildRequires: php-laminas-stdlib
@@ -68,21 +68,20 @@ BuildRequires: php-laminas-uri
BuildRequires: php-phpspec-prophecy-phpunit
BuildRequires: php-psr-http-factory
%endif
-BuildRequires: php-composer(pear/archive_tar) >= 1.4.3
+BuildRequires: php-composer(pear/archive_tar) >= 1.4.14
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9 >= 9.3
+BuildRequires: phpunit9 >= 9.5.10
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
-# "php": "^7.3 || ~8.0.0",
-# "laminas/laminas-stdlib": "^3.3",
-# "laminas/laminas-zendframework-bridge": "^1.0"
-Requires: php(language) >= 7.3
+# "php": "^7.4 || ~8.0.0 || ~8.1.0",
+# "laminas/laminas-stdlib": "^3.6.1"
+Requires: php(language) >= 7.4
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.3 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/laminas-stdlib) >= 3.6.1 with php-autoloader(%{gh_owner}/laminas-stdlib) < 4)
Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0 with php-autoloader(%{gh_owner}/laminas-zendframework-bridge) < 2)
# From composer, "suggest": {
# "laminas/laminas-crypt": "Laminas\\Crypt component, for encryption filters",
@@ -204,7 +203,7 @@ exit (class_exists("\\Zend\\%{library}\\ToInt") ? 0 : 1);
: upstream test suite
# Skip test failing with OpenSSL 3.0 (not available algo)
ret=0
-for cmd in "php %{phpunit}" php73 php74 php80 php81; do
+for cmd in "php %{phpunit}" php74 php80 php81; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} \
@@ -231,6 +230,13 @@ exit $ret
%changelog
+* Thu Dec 2 2021 Remi Collet <remi@remirepo.net> - 2.13.0-1
+- update to 2.13.0
+- keep compatibility using laminas-zendframework-bridge
+ as this is only used using compat autolader
+- raise dependency on PHP 7.4
+- raise dependency on laminas-stdlib 3.6.1
+
* Mon Oct 25 2021 Remi Collet <remi@remirepo.net> - 2.12.0-1
- update to 2.12.0