summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-18 09:11:16 +0200
committerRemi Collet <remi@php.net>2022-07-18 09:11:16 +0200
commite9789d1f4f2237485a57a2fda3ff768a26b7adb0 (patch)
treed4f72406b3490aa537f68fbd072f043e85c06073
parent5982c43e2694182802ecae5a21fb58ee7aa91bbe (diff)
update to 2.17.0
-rw-r--r--composer.json5
-rw-r--r--php-laminas-filter.spec12
2 files changed, 9 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 1d76bc9..a8512bb 100644
--- a/composer.json
+++ b/composer.json
@@ -43,9 +43,9 @@
"pear/archive_tar": "^1.4.14",
"phpspec/prophecy-phpunit": "^2.0.1",
"phpunit/phpunit": "^9.5.10",
- "psalm/plugin-phpunit": "^0.15.2",
+ "psalm/plugin-phpunit": "^0.17.0",
"psr/http-factory": "^1.0.1",
- "vimeo/psalm": "^4.13.1"
+ "vimeo/psalm": "^4.24.0"
},
"conflict": {
"laminas/laminas-validator": "<2.10.1",
@@ -54,7 +54,6 @@
"suggest": {
"laminas/laminas-crypt": "Laminas\\Crypt component, for encryption filters",
"laminas/laminas-i18n": "Laminas\\I18n component for filters depending on i18n functionality",
- "laminas/laminas-servicemanager": "Laminas\\ServiceManager component, for using the filter chain functionality",
"laminas/laminas-uri": "Laminas\\Uri component, for the UriNormalize filter",
"psr/http-factory-implementation": "psr/http-factory-implementation, for creating file upload instances when consuming PSR-7 in file upload filters"
},
diff --git a/php-laminas-filter.spec b/php-laminas-filter.spec
index 17f456f..af8fc37 100644
--- a/php-laminas-filter.spec
+++ b/php-laminas-filter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit f5a3736cb49f06a3ba8941803bf84559bed4c3fa
+%global gh_commit 7c78483f22e118fbc98be41dc24b39e8c17cdcae
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-filter
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.16.0
+Version: 2.17.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -50,9 +50,9 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "pear/archive_tar": "^1.4.14",
# "phpspec/prophecy-phpunit": "^2.0.1",
# "phpunit/phpunit": "^9.5.10",
-# "psalm/plugin-phpunit": "^0.15.2",
+# "psalm/plugin-phpunit": "^0.17.0",
# "psr/http-factory": "^1.0.1",
-# "vimeo/psalm": "^4.13.1"
+# "vimeo/psalm": "^4.24.0"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.5.1 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0.1 with php-composer(phpspec/prophecy-phpunit) < 3)
@@ -87,7 +87,6 @@ Requires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# From composer, "suggest": {
# "laminas/laminas-crypt": "Laminas\\Crypt component, for encryption filters",
# "laminas/laminas-i18n": "Laminas\\I18n component for filters depending on i18n functionality",
-# "laminas/laminas-servicemanager": "Laminas\\ServiceManager component, for using the filter chain functionality",
# "laminas/laminas-uri": "Laminas\\Uri component, for the UriNormalize filter",
# "psr/http-factory-implementation": "psr/http-factory-implementation, for creating file upload instances when consuming PSR-7 in file upload filters"
Suggests: php-autoloader(%{gh_owner}/laminas-crypt)
@@ -231,6 +230,9 @@ exit $ret
%changelog
+* Mon Jul 18 2022 Remi Collet <remi@remirepo.net> - 2.17.0-1
+- update to 2.17.0
+
* Wed Jul 13 2022 Remi Collet <remi@remirepo.net> - 2.16.0-1
- update to 2.16.0
- add dependency on laminas-servicemanager