summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-17 09:50:21 +0100
committerRemi Collet <remi@remirepo.net>2021-03-17 09:50:21 +0100
commit2bd3e106f9c7d7ac2a1b39dff63d2ad019cdee5b (patch)
tree9eb7ce1dce9227d087c80b729d2b4d4c8be7409d
parentcf6b6d80224c473651de51652f4328cb7b8ebcec (diff)
update to 2.11.0 (no change)
-rw-r--r--.gitignore2
-rw-r--r--composer.json7
-rw-r--r--php-laminas-filter.spec11
3 files changed, 15 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/composer.json b/composer.json
index ca051e9..9883ba7 100644
--- a/composer.json
+++ b/composer.json
@@ -37,7 +37,9 @@
"pear/archive_tar": "^1.4.3",
"phpspec/prophecy-phpunit": "^2.0",
"phpunit/phpunit": "^9.3",
- "psr/http-factory": "^1.0"
+ "psalm/plugin-phpunit": "^0.15.1",
+ "psr/http-factory": "^1.0",
+ "vimeo/psalm": "^4.6"
},
"conflict": {
"laminas/laminas-validator": "<2.10.1"
@@ -67,7 +69,8 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
+ "static-analysis": "psalm --shepherd --stats"
},
"replace": {
"zendframework/zend-filter": "^2.9.2"
diff --git a/php-laminas-filter.spec b/php-laminas-filter.spec
index f99f0f3..0248b22 100644
--- a/php-laminas-filter.spec
+++ b/php-laminas-filter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit cfb40b104e92a0b52bee696b74f958798ad8faa4
+%global gh_commit dd295a15f5c13d0c13d69ca0107190b1f2083d91
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-filter
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.10.0
+Version: 2.11.0
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -50,7 +50,9 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "pear/archive_tar": "^1.4.3",
# "phpspec/prophecy-phpunit": "^2.0",
# "phpunit/phpunit": "^9.3",
-# "psr/http-factory": "^1.0"
+# "psalm/plugin-phpunit": "^0.15.1",
+# "psr/http-factory": "^1.0",
+# "vimeo/psalm": "^4.6"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.2.1 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.3 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.6 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
@@ -224,6 +226,9 @@ exit $ret
%changelog
+* Wed Mar 17 2021 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0 (no change)
+
* Wed Jan 6 2021 Remi Collet <remi@remirepo.net> - 2.10.0-1
- update to 2.10.0
- raise dependency on PHP 7.3