summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-12 16:26:20 +0200
committerRemi Collet <remi@php.net>2022-07-12 16:26:20 +0200
commit177c8d896ef881dcfba42b2396690890777f5703 (patch)
treea9982ac7307033f72d941fab4a5de579023f8b4b
parent48840a20ecabba043c58c0a06e975581f0b35276 (diff)
update to 2.15.1
-rw-r--r--composer.json2
-rw-r--r--php-laminas-filter.spec13
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 8744c7d..377fab9 100644
--- a/composer.json
+++ b/composer.json
@@ -38,7 +38,7 @@
"require-dev": {
"laminas/laminas-coding-standard": "^2.3.0",
"laminas/laminas-crypt": "^3.5.1",
- "laminas/laminas-servicemanager": "^3.7.0",
+ "laminas/laminas-servicemanager": "^3.14.0",
"laminas/laminas-uri": "^2.9.1",
"pear/archive_tar": "^1.4.14",
"phpspec/prophecy-phpunit": "^2.0.1",
diff --git a/php-laminas-filter.spec b/php-laminas-filter.spec
index b3e09f4..51b51dc 100644
--- a/php-laminas-filter.spec
+++ b/php-laminas-filter.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 98a126b8cd069a446054680c9be5f37a61f6dc17
+%global gh_commit a9295b93df24bcd90e9b87f470e5a0a0250d07ee
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laminas
%global gh_project laminas-filter
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.14.0
+Version: 2.15.1
Release: 1%{?dist}
Summary: %{namespace} Framework %{library} component
@@ -45,7 +45,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# From composer, "require-dev": {
# "laminas/laminas-coding-standard": "~2.3.0",
# "laminas/laminas-crypt": "^3.5.1",
-# "laminas/laminas-servicemanager": "^3.7.0",
+# "laminas/laminas-servicemanager": "^3.14.0",
# "laminas/laminas-uri": "^2.9",
# "pear/archive_tar": "^1.4.14",
# "phpspec/prophecy-phpunit": "^2.0.1",
@@ -54,7 +54,7 @@ BuildRequires: (php-autoloader(%{gh_owner}/laminas-zendframework-bridge) >= 1.0
# "psr/http-factory": "^1.0.1",
# "vimeo/psalm": "^4.13.1"
BuildRequires: (php-autoloader(%{gh_owner}/laminas-crypt) >= 3.5.1 with php-autoloader(%{gh_owner}/laminas-crypt) < 4)
-BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.7.0 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/laminas-servicemanager) >= 3.14 with php-autoloader(%{gh_owner}/laminas-servicemanager) < 4)
BuildRequires: (php-autoloader(%{gh_owner}/laminas-uri) >= 2.9.1 with php-autoloader(%{gh_owner}/laminas-uri) < 3)
BuildRequires: (php-composer(phpspec/prophecy-phpunit) >= 2.0.1 with php-composer(phpspec/prophecy-phpunit) < 3)
BuildRequires: (php-composer(psr/http-factory) >= 1.0.1 with php-composer(psr/http-factory) < 2)
@@ -203,7 +203,7 @@ exit (class_exists("\\Zend\\%{library}\\ToInt") ? 0 : 1);
: upstream test suite
# Skip test failing with OpenSSL 3.0 (not available algo)
ret=0
-for cmd in "php %{phpunit}" php74 php80 php81; do
+for cmd in "php %{phpunit}" php80 php81 php82; do
if which $cmd; then
set $cmd
$1 ${2:-%{_bindir}/phpunit9} \
@@ -230,6 +230,9 @@ exit $ret
%changelog
+* Tue Jul 12 2022 Remi Collet <remi@remirepo.net> - 2.15.1-1
+- update to 2.15.1
+
* Wed Feb 23 2022 Remi Collet <remi@remirepo.net> - 2.14.0-1
- update to 2.14.0