summaryrefslogtreecommitdiffstats
path: root/php-laminas-feed.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-14 16:24:54 +0100
committerRemi Collet <remi@remirepo.net>2020-01-14 16:24:54 +0100
commit0f15281166806937aae474523ce63f554555160a (patch)
treede8dd12f00c351f2b79f1281f088dac508301863 /php-laminas-feed.spec
duplicate ZF
Diffstat (limited to 'php-laminas-feed.spec')
-rw-r--r--php-laminas-feed.spec283
1 files changed, 283 insertions, 0 deletions
diff --git a/php-laminas-feed.spec b/php-laminas-feed.spec
new file mode 100644
index 0000000..4096f85
--- /dev/null
+++ b/php-laminas-feed.spec
@@ -0,0 +1,283 @@
+# remirepo/Fedora spec file for php-zendframework-zend-feed
+#
+# Copyright (c) 2015-2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit d926c5af34b93a0121d5e2641af34ddb1533d733
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-feed
+%global php_home %{_datadir}/php
+%global library Feed
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.12.0
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+License: BSD
+URL: https://zendframework.github.io/%{gh_project}/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.6
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-dom
+BuildRequires: php-hash
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-tidy
+# From composer, "require-dev": {
+# "phpunit/phpunit": "^5.7.23 || ^6.4.3",
+# "psr/http-message": "^1.0.1",
+# "zendframework/zend-cache": "^2.7.2",
+# "zendframework/zend-coding-standard": "~1.0.0",
+# "zendframework/zend-db": "^2.8.2",
+# "zendframework/zend-http": "^2.7",
+# "zendframework/zend-servicemanager": "^2.7.8 || ^3.3",
+# "zendframework/zend-validator": "^2.10.1"
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.4.3
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-cache) >= 2.7.2 with php-autoloader(%{gh_owner}/zend-cache) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-db) >= 2.8.2 with php-autoloader(%{gh_owner}/zend-db) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.7 with php-autoloader(%{gh_owner}/zend-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.8 with php-autoloader(%{gh_owner}/zend-servicemanager) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:18
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+BuildRequires: php-composer(psr/http-message) < 2
+BuildRequires: php-composer(psr/http-message) >= 1.0.1
+BuildRequires: php-autoloader(%{gh_owner}/zend-cache) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-cache) >= 2.7.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-db) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-db) >= 2.8.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-servicemanager) >= 2.7.8
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10.1
+%endif
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# From composer, "require": {
+# "php": "^5.6 || ^7.0",
+# "ext-dom": "*",
+# "ext-libxml": "*",
+# "zendframework/zend-escaper": "^2.5.2",
+# "zendframework/zend-stdlib": "^3.2.1"
+Requires: php(language) >= 5.6
+Requires: php-dom
+Requires: php-libxml
+%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-composer(psr/http-message) >= 1.0.1 with php-composer(psr/http-message) < 2)
+# remirepo:8
+%else
+Requires: php-autoloader(%{gh_owner}/zend-escaper) < 3
+Requires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5.2
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 3.2.1
+Requires: php-composer(psr/http-message) < 2
+Requires: php-composer(psr/http-message) >= 1.0.1
+%endif
+# From composer, "suggest": {
+# "psr/http-message": "PSR-7 ^1.0.1, if you wish to use Zend\\Feed\\Reader\\Http\\Psr7ResponseDecorator",
+# "zendframework/zend-cache": "Zend\\Cache component, for optionally caching feeds between requests",
+# "zendframework/zend-db": "Zend\\Db component, for use with PubSubHubbub",
+# "zendframework/zend-http": "Zend\\Http for PubSubHubbub, and optionally for use with Zend\\Feed\\Reader",
+# "zendframework/zend-servicemanager": "Zend\\ServiceManager component, for easily extending ExtensionManager implementations",
+# "zendframework/zend-validator": "Zend\\Validator component, for validating feeds and Atom entries in the Writer subcomponent"
+Suggests: php-autoloader(%{gh_owner}/zend-cache)
+Suggests: php-autoloader(%{gh_owner}/zend-db)
+Suggests: php-autoloader(%{gh_owner}/zend-http)
+Suggests: php-autoloader(%{gh_owner}/zend-servicemanager)
+Suggests: php-autoloader(%{gh_owner}/zend-validator)
+%endif
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+# From phpcompatinfo report for version 2.6.0
+Requires: php-ctype
+Requires: php-date
+Requires: php-hash
+Requires: php-pcre
+Requires: php-spl
+Requires: php-tidy
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+Provides: php-autoloader(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Zend\Feed provides functionality for consuming RSS and Atom feeds.
+It provides a natural syntax for accessing elements of feeds, feed attributes,
+and entry attributes. Zend\Feed also has extensive support for modifying feed
+and entry structure with the same natural syntax, and turning the result back
+into XML.
+
+Documentation: https://zendframework.github.io/%{gh_project}/
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+mv LICENSE.md LICENSE
+
+
+%build
+: Create dependency autoloader - deprecated
+cat << 'EOF' | tee autoload.php
+<?php
+require_once '%{php_home}/Psr/Http/Message/autoload.php';
+EOF
+
+: Generate autoloader
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+\Fedora\Autoloader\Dependencies::required([
+ '%{php_home}/Zend/Escaper/autoload.php',
+ '%{php_home}/Zend/Stdlib/autoload.php',
+ '%{php_home}/Psr/Http/Message/autoload.php',
+]);
+\Fedora\Autoloader\Dependencies::optional([
+ '%{php_home}/Zend/Cache/autoload.php',
+ '%{php_home}/Zend/Db/autoload.php',
+ '%{php_home}/Zend/Http/autoload.php',
+ '%{php_home}/Zend/ServiceManager/autoload.php',
+ '%{php_home}/Zend/Validator/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+install -m644 autoload.php %{buildroot}%{php_home}/Zend/%{library}-autoload.php
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('ZendTest\\%{library}\\', dirname(__DIR__) . '/test');
+EOF
+
+ret=0
+for cmdarg in "php %{phpunit}" php70 php71 php72 php73 php74; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+%{php_home}/Zend/%{library}-autoload.php
+
+
+%changelog
+* Thu Mar 7 2019 Remi Collet <remi@remirepo.net> - 2.12.0-1
+- update to 2.12.0
+
+* Thu Mar 7 2019 Remi Collet <remi@remirepo.net> - 2.11.1-1
+- update to 2.11.1
+
+* Thu Jan 31 2019 Remi Collet <remi@remirepo.net> - 2.11.0-1
+- update to 2.11.0
+- raise dependency on zend-stdlib 3.2.1
+
+* Thu Aug 02 2018 Shawn Iwinski <shawn@iwin.ski> - 2.10.3-1
+- Update to 2.10.3 (ZF2018-01)
+
+* Tue Jun 19 2018 Remi Collet <remi@remirepo.net> - 2.10.2-2
+- update to 2.10.2
+
+* Tue Jun 5 2018 Remi Collet <remi@remirepo.net> - 2.10.1-2
+- update to 2.10.1
+
+* Fri May 25 2018 Remi Collet <remi@remirepo.net> - 2.10.0-2
+- update to 2.10.0
+
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 2.9.1-2
+- update to 2.9.1
+- use range dependencies on F27+
+
+* Mon Dec 11 2017 Remi Collet <remi@remirepo.net> - 2.9.0-2
+- switch from zend-loader to fedora/autoloader
+
+* Tue Dec 5 2017 Remi Collet <remi@remirepo.net> - 2.9.0-1
+- Update to 2.9.0
+- raise dependency on zend-escaper 2.5.2
+- raise dependency on zend-stdlib 2.7.7
+- raise dependency on psr/http-message 1.0.1
+
+* Tue Oct 24 2017 Remi Collet <remi@remirepo.net> - 2.8.0-4
+- fix FTBFS from Koschei, add patch for PHP 7.2 from
+ https://github.com/zendframework/zend-feed/pull/50
+
+* Mon Apr 3 2017 Remi Collet <remi@remirepo.net> - 2.8.0-2
+- change dependency on psr/http-message to required
+
+* Sun Apr 2 2017 Remi Collet <remi@remirepo.net> - 2.8.0-1
+- Update to 2.8.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
+* Tue Nov 15 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-2
+- add path for PHP 7.1
+ open https://github.com/zendframework/zend-feed/pull/35
+
+* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 2.7.0-1
+- update to 2.7.0
+- raise dependency on zend-stdlib >= 2.7
+
+* Thu Jan 28 2016 Remi Collet <remi@fedoraproject.org> - 2.6.0-1
+- update to 2.6.0
+- raise minimal php version to 5.5
+- drop build dependency on zend-servicemanager
+- add optional dependency on psr/http-message
+
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.2-1
+- initial package